Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15548 Discussions

warning after QSYS system generation"Warning: Number of processors has not been specified which may cause overloading on shared machines. Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate value for best performance."

ASuba
Novice
3,281 Views

Hello

I am an newbie to Quartus design tool and its associated tools.

I am creating a system with nios11 processor in Qsys and after HDL Generation its shows a warning that "Warning: Number of processors has not been specified which may cause overloading on shared machines. Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate value for best performance."

How to rectify this warning(which parameter exactly) ?

 

5 Replies
Abe
Valued Contributor II
2,096 Views

Add this tcl expression...

 

set_global_assignment -name NUM_PARALLEL_PROCESSORS 4

 

... to the .qsf file.

ASuba
Novice
2,096 Views

I checked .qsf file and this expression is already there and generation of HDL in QSYS shows the same warning

Abe
Valued Contributor II
2,096 Views

If you're using the GUI, show the TCL window from the View menu. Then paste the above command into the TCL prompt and press Enter. Then run the compilation. Set the number of processors depending on the system that you have (2/4).

 

This is just a warning and can be ignored. It does not affect the compilation results only affects the compilation time.

ASuba
Novice
2,096 Views

Thanks. i will ignore it then

Edward1024
Employee
467 Views

Open your Quartus Tcl Console, and excute below command:  

 

set_global_assignment -name NUM_PARALLEL_PROCESSORS ALL

 

And you will not see that warning again when compiling the project.

Reply