Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
866 Views

IDE setup completed, but can't run Blink program

Dear Expert,

I'm beginner for Galileo Board. I follow the "Intel Galileo Board Getting Start Guide" step by step. install the IDE at my windows 8 (64bit) and it success. I can see the "Galileo (COM4)" at Device Manager -> Ports (COM & LPT). I skip the step 6 ( update your board firmward) as my local support inform me not required, because the deliver board already update with latest firmware (IOT DEVELOPMENT KIT), as I run the terminal program as show in below.

I continue with step 7: "Open the blink example", until step 10, " upload the program" but I can see the "Done upload" message at the Arduino screen. May I know what wrong on my setup? hope expert can give some guide. See the message from the Arduino screen below:

===================== PART OF TERMINAL PROGRAM LISTING=====================================

Starting OpenBSD Secure Shell server: sshd

[ 31.850515] NET: Registered protocol family 10

[ 31.936541] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

done.

Starting Distributed Compiler Daemon: distcc.

Starting syslogd/klogd: done

* Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon [fail]

Starting Telephony daemon

Starting Lighttpd Web Server: lighttpd.

date: invalid date ''

[ 43.428396] g_serial gadget: high-speed config # 1: CDC ACM config

info: Forever processing file: agent.js

Starting OProfileUI server

Stopping Bootlog daemon: bootlogd.

** (oprofile-server:990): WARNING **: Failed to create avahi client: Daemon not running

Starting tcf-agent: OK

iot-devkit (Intel IoT Development Kit) 1.0 clanton /dev/ttyS1

clanton login: [ 959.203023] g_serial gadget: high-speed config # 1: CDC ACM con fig

iot-devkit (Intel IoT Development Kit) 1.0 clanton /dev/ttyS1

clanton login:

=========================== End of terminal listing =============================================

========================== Listing from Arduino 1.5.3 ==========================================

Binary sketch size: 49,066 bytes (of a 262,144 byte maximum) - 18% used

cygwin warning:

MS-DOS style path detected: C:\arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh

Preferred POSIX equivalent is: /cygdrive/c/arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh

CYGWIN environment variable option "nodosfilewarning" turns off this warning.

starting download script

Consult the user's guide for more details about POSIX paths:

Args to shell: C:\arduino-1.5.3/hardware/tools/x86/bin C:\Users\user\AppData\Local\Temp\build4113998651985686361.tmp/Blink.cpp.elf COM4

http://cygwin.com/cygwin-ug-net/using.html# using-pathnames http://cygwin.com/cygwin-ug-net/using.html# using-pathnames

COM PORT 4

# !/bin/sh

Converted COM Port COM4 to tty port /dev/ttyS3

Sending Command String to move to download if not already in download mode

echo "starting download script"

echo "Args to shell:" $*

# ARG 1: Path to lsz executable.

# ARG 2: Elf File to download

# ARG 3: COM port to use.

# path contains \ need to change all to /

path_to_exe=$1

fixed_path=${path_to_exe//\\/\/}

# COM ports are not always setup to be addressed via COM for redirect.

# /dev/ttySx are present. Howwever, COMy -> /dev/ttySx where x = y - 1

com_port_arg=$3

com_port_id=${com_port_arg/COM/}

echo "COM PORT" $com_port_id

tty_port_id=/dev/ttyS$((com_port_id-1))

echo "Converted COM Port" $com_port_arg "to tty port" $tty_port_id

echo "Sending Command String to move to download if not already in download mode"

echo "~sketch download" > $tty_port_id

============================================ End of Listing ==================================

0 Kudos
0 Replies