Intel vPro® Platform
Intel Manageability Forum for Intel® EMA, AMT, SCS & Manageability Commander
2846 Discussions

IntelvPro Powershell error "Exception calling "Get" with "0" argument(s): "Unable to connect"

Chris145
Beginner
2,090 Views

Hi, 

New to this, but have some experience with Powershll, 

I have some machines set up with Intel AMT, and can accesses them with the web client and can control them with Mesh commander. I'd like to automate their power control with PowerShell, so I have found  IntelvPro.PSM1. 

 

I've manged to get the module installed and appears to be working, however, whichever command I run I get the error "Exception calling "Get" with "0" argument(s): "Unable to connect"

 

Here is my code:

Import-Module "C:\Bin\IntelvPro\IntelvPro.PSM1"
$AMTCred = get-credential
$powerState = Get-AMTPowerState -ComputerName 'pc.domain.local' -Credential $AMTCred -Port '16993' -TLS

I found I need to explicitly reference the PSM1 file, but this seems to be working.

 

I get this error:

"pc.domain.local"
"Cannot connect"
"Exception calling "Get" with "0" argument(s): "Unable to connect""

 

What Have I missed in setting this up or in running this simple commend?

 

Any help much appreciated! 

0 Kudos
8 Replies
Victor_G_Intel
Employee
2,073 Views

Hello Chris145,


Thank you for posting on the Intel® communities.


To continue with the assistance can you please provide the following:


  1. How many systems are in your current deployment?
  2. Is this a new deployment?
  3. Where exactly did you get the IntelvPro.PSM1 file? If possible, please share the link to it.
  4. Can you please provide us with more information about the machines that you have currently set up? (Model, AMT version, OS build)
  5. Please provide us if possible, with a discovery log of each of the different models of machines that are included in your deployment:


You can find the steps to get the logs below:


  • Download and unzip the Intel® Configurator v12.2
  • https://downloadcenter.intel.com/download/30340/Intel-Configurator
  • Open the unzipped folder, open the Configurator folder and run ACUConfigInstaller.msi
  • Open a Command Prompt window as an Administrator.
  • Go to drive C: \Program Files (x86) \Intel \SCS ACUConfig, and
  • Run the command: Acuconfig.exe /verbose /output console systemdiscovery
  • The discovery log file will be created in the same location the software ACUConfig was installed.
  • Default location: C:\Program Files (x86)\Intel\SCS ACUConfig


Regards,


Victor G.

Intel Technical Support Technician


0 Kudos
Chris145
Beginner
2,046 Views

Hi Victor, 

Thanks for getting back me! 

  1. How many systems are in your current deployment?
    I have 7 machines all the same
  2. Is this a new deployment?
    Quite new, I set it up in about May 22.
  3. Where exactly did you get the IntelvPro.PSM1 file? If possible, please share the link to it.
    The Powershell module comes from intel website: https://www.intel.com/content/www/us/en/download/674527/intel-vpro-technology-module-for-microsoft-windows-powershell-module.html 
  4. Can you please provide us with more information about the machines that you have currently set up? (Model, AMT version, OS build)
    All computers are the same.
    Model: HP Z2 G8 Tower Workstation with i7-11700K
    AMT version: v15.0.35
    OS: Windows 10: 21H1 Build 19043.1889)
  5. Please provide us if possible, with a discovery log of each of the different models of machines that are included in your deployment: uploaded PC1.domain.local.xml 

  6. Interesting, I got errors when running the Acuconfig tool. see output  in Command log.txt

Does that help?

0 Kudos
JoseH_Intel
Moderator
2,040 Views

Hello Chris145,


Looks like you provisioned your systems using the Intel SCS software package. Could you tell what version of the AMT SDK did you installed? The latest version can be downloaded from here: Intel® Active Management Technology SDK


Regarding the error you are facing, please take a look at this article, chances are it could be related: “WsmanUnauthorizedException” Error When Using PowerShell*... (intel.com)


Regards


Jose A.

Intel Customer Support Technician


0 Kudos
Chris145
Beginner
2,032 Views

Hi Jose, 

I don't think I used an SDK to provision them. I just directly accessed the machines (BIOS / UFEI) to turn on AMT - provide passwords etc. After that I was able to add them to Mesh commander, secure them with TLS and access them remotely, both through Mesh Commander or through the web interface.

Is it possible that I have missed some important step which would be done by this SDK?

 

Regarding your article. that setting appears to be set correctly:

Chris145_0-1662453050967.png

Any other suggestions?

 

0 Kudos
JoseH_Intel
Moderator
2,015 Views

Hello Chris145,


The AMT SDK contains a new PowerShell cmdlet for obtaining Intel UPID information: Get-UniquePlatformIDFeatureInfo.module. I think you might be missing some modules.

Intel® AMT SDK


Regards


Jose A.

Intel Customer Support Technician


0 Kudos
JoseH_Intel
Moderator
1,984 Views

Hello Chris145,


I am just following up to double-check if you found the provided information useful. If you have further questions please don't hesitate to ask. If you consider the issue to be completed please let us know so we can proceed to mark this thread as closed. I will try to reach you as a very last time on next Thursday 15th. After the thread will be automatically archived.


Regards


Jose A.

Intel Customer Support Technician


0 Kudos
Chris145
Beginner
1,932 Views

Hi Jose, 

Unfortunately, no, I have not been able to resolve this issue, I look a look at the SDK link which was sent, but it did not contain any different instructions to what I had before.

Is there any specific help relating to the error I'm seeing: "Exception calling "Get" with "0" argument(s): "Unable to connect"

0 Kudos
JoseH_Intel
Moderator
1,938 Views

Hello Chris145,


We will proceed to mark this thread as closed. If you have further issues or questions just go ahead and submit a new topic.


Regards


Jose A.

Intel Customer Support Technician


0 Kudos
Reply