Intel vPro® Platform
Intel Manageability Forum for Intel® EMA, AMT, SCS & Manageability Commander
2878 Discussions

SCS Add-on for SCCM Uninstall Errors


I am trying to uninstall the SCS Add-on (2.1 for SCCM 2.1.5) package on our SCCM server. I am getting the following error when I try to uninstall via the SCCMAddon executable.

- Failure: Could not load file or assembly 'AdminUI.WqlQueryEngine, Version=4.0.6000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded. .

Operation completed with error.

A few important notes,

1. This add-on was first installed when we were on SCCM 2012 R2. The installation worked fine. We have since moved to SCCM 2012 R2 SP1 and also installed CU1. I am not sure if this is an issue or not.

2. The primary site server that has both Configuration Manager installed and this Intel add-on has two drives. The OS is installed on C:\. All SCCM and Intel components are installed on E:\. This being said, I have also tried moving the contents of "E:\Microsoft Configuration Manager\AdminConsole\bin" to the folder that the add-on was installed from (also on E:\). "AdminUI.WqlQueryEngine" does exist, but I still get the same error.

OS: Server 2012 R2 Standard

SCCM 2012 R2 Configuration Manager SP1

Console Version: 5.0.8239.1203

Site Version: 5.00.8239.1000

I see that this is a known issue from other posts. No official 'solution' has been posted, though. Any advice would be greatly appreciate, as I have already spent a few days banging my head against the wall with this.



0 Kudos
2 Replies

Hi Matt,

Did you find a solution for this problem? We're facing the same issue.

Kind regards,


0 Kudos

HI SanderClompen,

In the 5.00.8239.1000 release of SCCM .NET 2.0 version was depreciated and since the SCCM add-on targets .NET 2.0 it couldn't load the SCCM dlls in order to function properly. This issue is resolved n the latest version of the SCCM add-on 2.1.7.

Please download (the download link is below) and install 2.1.7 and this issue should be resolved Intel® Setup and Configuration Software (Intel® SCS)

0 Kudos