Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12626 Discussions

Running NIOSV processor through 16 Bit On-Chip-Ram

himanshuvaria
Beginner
2,054 Views

Hello,

 

I am working around the NIOSV processor these days. As per the requirement I need to configure a design where NIOSV is used as CPU and On Chip Ram is used as program memory. The data width of On-Chip-Ram must be 16 bits.

 

I am able to build the  software project and run the ELF through On-Chip-Ram. But my NIOSV code does not get executed. On running the ELF through Debugging Mode(Ashling RISC-Free), I found out that it is not able to access the memory at some address point. I am facing this issue only when the data width of On-Chip-Ram is 16 bits. Everything works fine if the Data Width of On-Chip-Ram is 32 bits.

 

Please find the attached document and reference design for your reference.

 

Kindly suggest any solution to resolve the issues. 

0 Kudos
11 Replies
himanshuvaria
Beginner
2,034 Views

FPGA Board used : Cyclone IV E (EP4CE40F23C8)

0 Kudos
EBERLAZARE_I_Intel
2,027 Views

Hi,


I see that this issue is already filed in our IPS system, thus do you want to set the thread to close and continue our support to you in IPS?


0 Kudos
himanshuvaria
Beginner
2,026 Views

Hi,

 

I would like to continue the support in IPS. Can you please share more details on where can I access the IPS system ?

 

Thanks !!

 

 

0 Kudos
EBERLAZARE_I_Intel
1,980 Views

Hi,


For the IPS support, please check with your assigned FAE.


0 Kudos
EBERLAZARE_I_Intel
1,929 Views

Hi,


We are still working on the fix for the issue, can you provide the Quartus version that you worked on that produced the error?


0 Kudos
himanshuvaria
Beginner
1,921 Views

Hi,

 

The Quartus Version I am using is : Quartus Prime Standard 22.1.1

RiscFree IDE Version : 22.1std

0 Kudos
EBERLAZARE_I_Intel
1,886 Views

Hi,


Thanks for the info. We are still working on the workaround.


0 Kudos
himanshuvaria
Beginner
1,850 Views

Hello,

 

Any update regarding the issue from your side ?

 

Please share your response !!

 

Regards,

Himanshu

0 Kudos
EBERLAZARE_I_Intel
1,816 Views

Hi,


We are still working on the fix for this issue, it may take weeks to get the proper workaround, we would appreciate your patience.


0 Kudos
XleraSolutions
Beginner
1,029 Views

Hi there,

 

Has this issue been resolved? Currently seeing very similar issues with Q23.4. Works fine the first time, then restarting debug gives the same error. Have to reload the SOF.

 

Thx!

0 Kudos
EBERLAZARE_I_Intel
1,743 Views

Hi,


We will keep track the status update in IPS. I now transition this thread to community support. If you have a new question, Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.



p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


0 Kudos
Reply