Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12612 Discussions

Update nios-linux 20100621 buid error

Altera_Forum
Honored Contributor II
1,320 Views

After update nios-linux 20100621, when i make, get error : 

 

 

{standard input}: Assembler messages: 

{standard input}:365: Error: unrecognised instruction initda 

make[3]: *** [arch/nios2/mm/memory.o] Error 1 

make[2]: *** [arch/nios2/mm] Error 2 

make[1]: *** [sub-make] Error 2 

make[1]: Leaving directory `/root/nios2-linux/linux-2.6' 

make: *** [linux] Error 1 

 

Who knows to help me?
0 Kudos
11 Replies
Altera_Forum
Honored Contributor II
499 Views

Got same error when starting to play around with uclinux some time ago.  

Hope I remember right when I tell you to check  

 

a) your branches 

b) your toolchain 

 

So when working without mmu you should use nios2gcc-20080203.tar.bz2 and test-nios2 branches,  

when working with mmu you should use toolchain-mmu and branches trunk (uClinux-dist) / nios2 (linux-2.6) 

 

Hope this helps.  

Andi
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

I'm sure to use nios2gcc-20080203.tar.bz2 and test-nios2 branches (uClinux-dist & linux-2.6) 

 

and i make succesfull but not detected USB 1-0 : 1 port detected ,so i try to update and get above error  

 

can you see my post and help me 

 

http://www.alteraforum.com/forum/showthread.php?t=34708
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

I solved this problem with mount USB on uclinux and you shouldn't update source

0 Kudos
Altera_Forum
Honored Contributor II
499 Views

A quick 'RTFM' shows that the 'initda' instruction was added in rev 8.0 in May 2008. So it is likely that the toolchain you are using predates that change.

0 Kudos
Altera_Forum
Honored Contributor II
499 Views

 

--- Quote Start ---  

After update nios-linux 20100621, when i make, get error : 

 

 

{standard input}: Assembler messages: 

{standard input}:365: Error: unrecognised instruction initda 

make[3]: *** [arch/nios2/mm/memory.o] Error 1 

make[2]: *** [arch/nios2/mm] Error 2 

make[1]: *** [sub-make] Error 2 

make[1]: Leaving directory `/root/nios2-linux/linux-2.6' 

make: *** [linux] Error 1 

--------------------------------------------------------------------------------------------- 

Hallo kinhcan89, 

 

can u tell me how did you solve this Problem? i am having the same one! i Know its one year ago but maybe u remember :-).
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

 

--- Quote Start ---  

 

--- Quote Start ---  

After update nios-linux 20100621, when i make, get error : 

 

 

{standard input}: Assembler messages: 

{standard input}:365: Error: unrecognised instruction initda 

make[3]: *** [arch/nios2/mm/memory.o] Error 1 

make[2]: *** [arch/nios2/mm] Error 2 

make[1]: *** [sub-make] Error 2 

make[1]: Leaving directory `/root/nios2-linux/linux-2.6' 

make: *** [linux] Error 1 

--------------------------------------------------------------------------------------------- 

Hallo kinhcan89, 

 

can u tell me how did you solve this Problem? i am having the same one! i Know its one year ago but maybe u remember :-). 

--- Quote End ---  

 

 

Which toolchain do you use and which branch do you use (mmu / nommu)?
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

 

--- Quote Start ---  

 

--- Quote Start ---  

 

 

Which toolchain do you use and which branch do you use (mmu / nommu)? 

--- Quote End ---  

 

 

I am using pre-build toolchain nios2gcc-20080203.tar.bz2 and test-nios2 branches(uClinux-dist and Linux-2.6).
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

 

--- Quote Start ---  

 

--- Quote Start ---  

 

 

I am using pre-build toolchain nios2gcc-20080203.tar.bz2 and test-nios2 branches(uClinux-dist and Linux-2.6). 

--- Quote End ---  

 

 

I can remember that this was the wrong toolchain for systems with mmu. nios2gcc-20080202 prebuilt toolchain was for use with nommu-systems. The error message you posted looks like this is the problem here, too.
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

 

--- Quote Start ---  

 

--- Quote Start ---  

 

 

I can remember that this was the wrong toolchain for systems with mmu. nios2gcc-20080202 prebuilt toolchain was for use with nommu-systems. The error message you posted looks like this is the problem here, too. 

--- Quote End ---  

 

 

My Hardware Architect don't have on chip memory, I am using nommu system.
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

Maybe you should build the tool chain like: 

 

cd nios2-linux/toolchain-build 

git clean -f -x -d# clean on restart 

make gcc 

make elf2flt 

 

Then,use the new compiler you made. 

 

PATH=$PATH:/home/(user name)/nios2-linux/toolchain-build/build/nios2/bin 

 

Regards.
0 Kudos
Altera_Forum
Honored Contributor II
499 Views

Sorry to annoy you all but I'm trying to build the uClinux on DE2 Cyclone 2 (an old kit). I've had the same error and as far as I realized this is because the nios-linux version is new (nios2-linux-20120802) so may be it's not compatible with the NO MMU. However, I can't find any old version of this file like nios-linux-20090730 since all the links died. So anyone can show me how to fix the problem or provide with the link to download the old version to test.  

Thank you all.
0 Kudos
Reply