Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)

i5 9400f

Otto45
Beginner
486 Views

Hello! Recently I've had some problems with my i5 9400f. I know that the i5 9400f is a turbo boost CPU (base speed 2,9 and boost 4,0)  and it changes frequency depending on what task it is performing. Even when I don't have anything on my computer running my CPU is around 3,9 GHz. It hasn't always been like this,  before when I did not have anything running it was around 2,0 GHz. I have had the CPU for 2 years and it was this month that it randomly happened. When I play games now too my CPU goes over 90 degrees Celcius when before this had happened it was usually around 70-80. I have no idea what the problem is, I have already hard reset my PC deleting everything off every drive in case it was a virus, but that did not fix anything. If you know anything about this please respond I will appreciate any sort of help! 

0 Kudos
4 Replies
David_G_Intel
Moderator
437 Views

Hello Otto45


Thank you for posting on the Intel️® communities. The temperatures mentioned are not harmful for the processor, the maximum temperature allowed is 100°C. Intel Turbo Boost Technology is a way to automatically run the processor core faster than the marked frequency (Processor Base Frequency: 2.90 GHz). Once enabled, Intel Turbo Boost Technology works automatically under operating system control, if you don't feel comfortable with the current frequencies you can disable the technology with a switch in the BIOS. No other user-controllable settings to change Intel Turbo Boost Technology operation are available. 


Regards, 

David G 

Intel Customer Support Technician 


David_G_Intel
Moderator
410 Views

Were you able to check the previous post?  

Let us know if you still need assistance.    


Best regards,  

David G.  

Intel Customer Support Technician  


David_G_Intel
Moderator
395 Views

We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored. 


Best regards,  

David G. 

Intel Customer Support Technician  


Otto45
Beginner
376 Views
Hi! Sorry for the late response. I found another solution to the problem that fixed it. In control panel in the power management section if you select your power plan to high performance it will boost your CPU to its max so it stays around the max frequency all the time. So I fixed it by just turning it off, I had it on after I watched a youtube video that said you will have better gaming performance if you selected the high performance power mode. Anyways thank you so much for your responses and for taking the initiative to help. I will definitely come back here if I encounter any other problem with my CPU!
Reply