Community
cancel
Showing results for 
Search instead for 
Did you mean: 
kashyap__anurag
Beginner
109 Views

ia_visualizer exited with code 1

Hi, i have installed the edge insight with all success

after building and running the PCB demo i am getting the error in visualizer

i.e : ia_visualizer exited with code 1

i have attached the image of error message for reference.

kindly help me in this.

Thankyou for the support.

 

Not able to upload the pic, mentioning the error here

 

ia_visualizer | No protocol specified
ia_visualizer | 2020-08-28 05:27:14,292 : ERROR : root : [visualize.py] :main : in line : [629] : Error during execution:
ia_visualizer | Traceback (most recent call last):
ia_visualizer | File "visualize.py", line 504, in main
ia_visualizer | rootWin = Tk()
ia_visualizer | File "/usr/lib/python3.6/tkinter/__init__.py", line 2023, in __init__
ia_visualizer | self.tk = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
ia_visualizer | _tkinter.TclError: couldn't connect to display ":0"
ia_visualizer | 2020-08-28 05:27:14,294 : ERROR : root : [visualize.py] :main : in line : [631] : Destroying EIS databus context
ia_visualizer | NoneType: None
ia_visualizer exited with code 1
ia_dc | INFO:DataSourceZMQ: Initializing message bus context
ia_dc | INFO:DataSourceZMQ: Initializing subscriber for topic
ia_dc | INFO:AdeptWorkerDB:Registering Discovery Creek instance Surge..
ia_dc | INFO:AdeptWorker.Surge:Restoring from Surge_Example_adept_model.pck
ia_dc | INFO:AdeptWorker.Surge:Setting threshold to -100
ia_visualizer | No protocol specified
ia_visualizer | No protocol specified
ia_visualizer | 2020-08-28 05:27:15,544 : ERROR : root : [visualize.py] :main : in line : [629] : Error during execution:
ia_visualizer | Traceback (most recent call last):
ia_visualizer | File "visualize.py", line 504, in main
ia_visualizer | rootWin = Tk()
ia_visualizer | File "/usr/lib/python3.6/tkinter/__init__.py", line 2023, in __init__
ia_visualizer | self.tk = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
ia_visualizer | _tkinter.TclError: couldn't connect to display ":0"
ia_visualizer | 2020-08-28 05:27:15,546 : ERROR : root : [visualize.py] :main : in line : [631] : Destroying EIS databus context
ia_visualizer | NoneType: None
ia_influxdbconnector | I0828 05:27:15.593134 1 subManager.go:120] Subscribe data received from topic: camera1_stream_results in subroutine 1
ia_influxdbconnector | I0828 05:27:15.593263 1 InfluxWrite.go:73] Data after flattening: map[channels:3 defects:[] encoding_level:96 encoding_type:jpeg height:1200 img_handle:4793037776 width:1920]
ia_visualizer exited with code 1

0 Kudos
1 Reply
Sebastian_M_Intel
Moderator
96 Views

Hello kashyap__anurag, 

 

Thank you for submitting your question on this Intel® Community.  


To better assist you, we recommend that you submit your question on the Intel® Developer Zone.  

   

Please register and create an account so that you can receive further troubleshooting support, and get access to useful documentation.  

   

Intel® Developer Zone - Contact Page  

https://software.intel.com/en-us/support  

 

Please keep in mind that this forum will not be monitored by Intel.  

 

Regards, 

 

Sebastian M.  

Intel Customer Support Technician.  


Reply