Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
694 Views

ByteBlaster II problem

Hello, I built byteblaster-II, but face some strange problems with it. 

First of all, what I see is that LPT port pin 14 which is used to control BB-II buffers at PC boot is initialized to high, which means buffers are open, thus FPGA can not function. Second, I try installing BB-II as device in the programmer, but at the beginning it does not want to see device as BB-II. It allows me to select "Byteblaster", but then says that BB does not support active serial programming. Well, then I change to passive serial, select suitable file and click "start". Of course it says error. Then I select Active serial back, and ... then I can see BB-II in the hardware window! Great, not I can verify or download images to EPCS, BUT - after Quartus downloads image properly, it then drives pin 14 low, but in several seconds it drives this pin high back! This means that if I perform embedded device reset FPGA is dead because BB-II hijacks EPCS. 

Anyway had this experience, and how to deal with it? 

I tried installing driver, using bblpt /i to no material result. Also tried parallel port in ECP and PC-AT mode. 

Thanks. 

 

Edit: in general, what the heck Altera developed BB-II with buffers opening on /LF parallel port's line being inactive (high)? It should have been done otherwise - buffers opening on the low signal (/LF being active), then there will be no problem while PC booting and operating. 

 

Edit1: I found out by using older device with LPT port that detection of BB-II as BB may be related to me using notebook with docking station for former setup. But the issue with pin 14 being high is still there - when computer boots or does not perform any tasks on BB-II, this steady high level on pin 14 makes FPGA inoperable.
0 Kudos