Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,045 Views

The source has a e"The source has a empmpty signal of 2 bits, but the sink does not"

Hi verybody! 

I'm using SOPC Builder 9.0 version of studio. When I need to connect Scatter-Gather DMA controller to Frame Buffer and use Data Format Adapter and Timing adapter for that. 

But everytime get the error written in the subject between Data Format Adapter and Frame Buffer.  

What should I do? 

Thanks.
0 Kudos
10 Replies
Highlighted
Valued Contributor III
3 Views

Sorry for the mistake in the title of subject. The text of error is: 

"The source has a empty signal of 2 bits, but the sink does not."
0 Kudos
Highlighted
Valued Contributor III
3 Views

You can specify the error width for the SGDMA controller with it's wizard. 

 

Jake
0 Kudos
Highlighted
Valued Contributor III
3 Views

Really I don't know how it can help me:confused: I get that 2 additional bits in Data Format Adapter block when I turn on "Include Packet Support" option and it by default turns "Include Empty Signal" option to "Auto". I can't set that option to "None" because system don't allow me to do it because I want change "Data Symbols per beat" from 1 to 3.

0 Kudos
Highlighted
Valued Contributor III
3 Views

Do you have the same number of symbols per beat in the format adapter and the frame buffer?

0 Kudos
Highlighted
Valued Contributor III
3 Views

Yes. There is value 3 in "Data Symbol per Beat" textbox of Data Format Adapter and value 3 in "Number of Color Planes in Parallel" of "Frame Buffer". Am I right?

0 Kudos
Highlighted
Valued Contributor III
3 Views

Well I don't work with video streams, but I think that even if a pixel is made of 3 colors, it can't be considered as 3 different symbols. They can't be transmitted independently, you need the 3 of them to build a pixel. 

 

If you are transmitting the 3 colors in parallel, I would say that one pixel is one symbol. Did you try to set the number of symbols per beat to 1 and multiply the symbol size by 3?
0 Kudos
Highlighted
Valued Contributor III
3 Views

In that way everything is alright, but in my case I cant't do that because I'm using Bitec Dvi tx/rx daughter board which uses 3 color parallel transmittion mode only.

0 Kudos
Highlighted
Valued Contributor III
3 Views

Doesn't the daughterboard support receiving 1 24-bit symbol per beat instead or 3 8-bit symbols?

0 Kudos
Highlighted
Valued Contributor III
3 Views

No. But it's no matter I solved that problem. There is special component named "Color Plane Sequencer" which allows to change channel order to parallel. Anyway thanks you very much!

0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi all,  

 

I'm considering using the "color plane sequencer" inorder to splitt up a single video stream into two separate video streams. However, I'm bumping into a problem since the streams from the "color plane sequencer" are going to modules operating at different clock frequencies. One module operates at 27MHz while the other operates at 40MHz.  

 

Things seem okey for the module operating at 27MHz since it's using the same clock frequency as the "color plane sequencer", but for the module operating at 40MHz ("clocked video output") there is an error message saying that the modules need to be in the same clock domain.  

 

I did try placing a dc_fifo between the "color plane sequencer" and the "clocked video output", however this resulted in other error messages(see attached files), such as there being different ready latency between the "color plane sequenser" and the "dc_fifo". I tryed using the "Insert Avalon-ST Adapters" function, but his led to yet another error message sying: 

Error: Error: data_format_adapter_1: Adaptation for output symbolsPerBeat > input symbolsPerBeat requires the output empty signal to be present 

 

Has anyone got some thoughts on these issues ?
0 Kudos