Rapid Storage Technology
Intel® RST, RAID
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
2035 Discussions

Error 0xA0010002: Failed to create <name> volume

HDB2000
Beginner
467 Views

Going to give a little background and then get to my specific issue.

I am supporting a customer with an ASRock IMB-1313 motherboard supporting 10th-gen Intel Core CPUs.  It has RST 17.8 installed from the ASRock support page, along with the desktop RST UI.

The system was shipped with two 4 TB drives in an RST RAID 1 array.

When I connected recently to help with an unrelated issue, we saw that the system had a C: and volume both with a "SYSTEM" label, as if the mirror had broken.  We found that the SATA mode in the BIOS was set to AHCI.

We're used to seeing that now and again (but not used to seeing it bootable if the mode changes).  I really don't know how  it got into this state.  If we had somehow not set the RAID up when we shipped the system, under what other circumstances would we have the 2nd volume as a copy of the first?  It just doesn't make sense.

Anyway, I think we did try just setting the mode back to RAID, and as expected, the system would not boot.

I then updated the RST driver to 17.11, and noticed that there was an option to have the installer put the OS into safe mode to change the SATA mode to RAID for me, to preserve data.  To be safe, I backed up our application data, and then proceeded.

This all went pretty smoothly.  Picked up the Optane app from the Windows Store (now apparently required since 17.8).

Went through setup of the RAID volume to include current C: as the data to keep, but when I pressed create volume, I got a brief "volume creation in progress"  message, followed by "Failed to create SYSTEM volume" error, and error code 0xA0010002.

This was all logged into admin account, BTW.

I saw that the RST 18.x driver should also work with the IMB-1313 based on 10th gen CPU, so I then tried updated to RST driver 18.6.1.1016.

Got the same error.  Any ideas?

 

0 Kudos
2 Replies
Jean_Intel
Moderator
441 Views

Hello HDB2000,

 

Thank you for posting on the Intel️® communities. I am sorry to hear that you are experiencing issues

 

You may not have enough unpartitioned space at the end of the existing hard drive to add the RAID information. If possible, decrease the partition size on that hard drive by a few MB, and then try to create the RAID volume again.

 

The volume you are creating may not be supported in combination with the first volume on the array. Select a volume type and number of hard drives for that volume that are supported, and then try to create the RAID volume again

 

In case you still receive the error message, please, share a screenshot of the error message.

 

Best regards, 

Jean O.  

Intel Customer Support Technician

0 Kudos
Jean_Intel
Moderator
430 Views

Hello foreverbi,

 

We understand you have opened an email with us and we will continue to help you through that channel now. We will therefore close this community case. Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  

 

Best regards

Jean O.  

Intel Customer Support Technician

0 Kudos
Reply