Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
2,112 Views

Intel Rapid Storage Technology 11.6 Broke my RAID-0 - how do I fix it?

Ive been waiting for an update of RST for a loooong time to get trim support to my SSD RAID-0. In the beginning it was ridiculously fast but as discs got filled up not so impressing anymore. Then I heard that trim wasnt at all going to work in Windows 7 with raid and that I needed W8... I decided to upgrade from my stock drivers that came with my motherboard (Gigabyte GA-X58A-UD7 rev 2) anyway (RST 10.6).

After update I rebooted my computer. It didnt start, it just frooze on the W7 loading logo. Safemode showed that it frooze when loading classpnp.sys, and when I tried removing that it frooze at disk.sys. Put the files back in original order and ran recovery options to no avail. Nothing worked. I can interact with my raid when I start W7 in recoverymode and open a console but whenever I try to boot OS it just freezes. I have of course also tried to recover to an earlier point but this doesnt work either. Either the restore points are broken or the drivers are not replaced.

So thanks Intel for ruining a completely perfectly running system for me . Array: 2 x Intel X25M 120 GB Raid configuration: SATA mode is set to (XHD). The Extreme Hard Drive (RAID) option is disabled.Im using the Intel Raid (obviously), so other Raid options on my board are disabled.And SATA AHCI is ofc disabled since I am running SATA in XHD mode because that is the only way to have the Intel Storage Matrix Manager / Rapid Storage Technology create a RAID on the GIGABYTE system. These settings are correct and has been working perfectly for 3 years. Changing the settings in any way will disable my RAID from loading. I have absolutely no idea how RST 11.6 so efficiently managed to break my system but I am desperate for help. Ive been googling this problem for the last 5 hours and I have yet to find anyone with the exact same problem. The highlights of my setup that makes it unique is probably that I am running two SSD's in RAID-0 and using disks that I suppose could be considered old (they are working fine however w/o broken sectors and whatnot). And that my system is running on said raid, which makes it hard to boot system with the drivers set to currently manage the raid inside of W7. Ive been trying to get into my system to be able to purge my system from RST and use the Vanilla W7 drivers instead. But getting into the system seems hopeless. I need to boot system to remove drivers, but to boot system the broken drivers are loaded and boot fails. Catch 22 I would be very grateful for any and whatever input into this.
Tags (2)
0 Kudos
6 Replies
idata
Community Manager
242 Views

After some 50 hours of researching I finally gave up and dismantled my RAID and re-installed my system. Only after I did that did I find a solution to the problem.

The problem is that the system cannot load because of a new driver that it is trying to use. In Windows Startup Repair this was reported as "autofailover badpatch". So we are looking at a a bad patch.

A brilliant person over at the Microsoft COmmunity gave the solution!

http://answers.microsoft.com/en-us/profile/f784b2f1-2735-413e-9fdd-72d0d5f4f967 Oberwald replied on April 16, 2010

In reply to rc2550 post on April 16, 2010

You can restore your registry files manually to an earlier point by going through the steps outlined below. The process is involved and requires some careful typing. Ask a computer-savvy friend to assist you if you lack experience in this area. Note that it may reset your password to an earlier value.

1. Keep tapping F8 during the early boot phase.

2. Select Repair from the menu.

3. Log on as Administrator if prompted.

4. Select Repair when prompted.

5. Select the Command Prompt.

6. Identify the correct drive letter for your Windows installation. It could be a drive other than C: but it won't be X:. You do it by typing the commands

dir C:\Win*

dir D:\Win*

dir E:\Win*

until you find the Windows folder.

I will call that drive "Q:".

7. Type these commands:

cd /d Q:\windows\System32\config

xcopy *.* Q:\RegBack\

cd RegBack

dir

8. Examine the dates of the Software, System and SAM files. Were the files created before or after your problem became apparent?

9. If they were made before the problem became apparent then you can type these commands:

copy /y software ..

copy /y System ..

copy /y Sam ..

(the two dots are part of each command)

10. Reboot normally. If things do not work out then you can backtrack by copying the original registry files from Q:\Regback to Q:\Windows\System32\config.

 

http://answers.microsoft.com/en-us/windows/forum/windows_7-system/latest-patch-caused-system-to-no-l... http://answers.microsoft.com/en-us/windows/forum/windows_7-system/latest-patch-caused-system-to-no-l...

And thats all I needed to do. After reboot I could remove the RST drivers (I reinstalled them on new system again just to get to the bottom of things).

So thanks for nothing Intel. I sincerely hope you will start testing your drivers more thoroughly in the future.

idata
Community Manager
242 Views

Had the exact same problem with my HP 8570w updated the RAID software from 11.1.0.1006 to the 11.6 version. Followed the fix up to step 4 where Windows offered me a restore point (it hadn't until I had our Help Desk login as local admin). In any case, huge thanks to you and a big raspberry to Intel for not responding to your post.

idata
Community Manager
242 Views

I had the same problem on 2 different machines! Amazing is that Intel don't care about this! This is a bad patch!

 

I fix my problem In Windows Startup Repair!

 

Shame on you INTEL!

 

idata
Community Manager
242 Views

Warning! the version 11.7 of the Intel Rapid Storage Technology, is broken too!!!

DNewm3
Beginner
242 Views

I dont understand how you were able to access anything on the harddrive. I cant access the drive at all. But my issue has to do with 11.6 because the drive stopped booting right after upgrading, for a minute I had a BSOD that stated that iastorv was corrupted. That was the last coherent thing I got.

Any thoughts?

laptop HP dv7-7212nr, with bios Insyde F.2D

Amy_C_Intel
Employee
242 Views

Hello, Danthos:

I noticed that this thread is really old and there are several updates available since the 11.6 came out, so please try with this one https://downloadcenter.intel.com/download/25165/Intel-Rapid-Storage-Technology-Intel-RST-RAID-Driver... Download Intel® Rapid Storage Technology (Intel® RST) RAID Driver.

Regards,

Amy.