Community
cancel
Showing results for 
Search instead for 
Did you mean: 
James_H_4
Beginner
3,599 Views

[RESOLVED] Cannot login to Intel XDK v3900

The login problem should now be resolved (as of March 30 at 11:30 PDT). The workaround referenced in this thread should no longer be required. If you previously applied the workaround you do not need to "undo" or change anything, the workaround is compatible with the fix. You may be prompted to re-login if you were previously logged into the Intel XDK. The issue was due to the deployment of an incompatible authorization certificate.

------------------------    workaround no longer required    ------------------------

Please see this post > https://software.intel.com/en-us/forums/intel-xdk/topic/720758#comment-1900352 < for a workaround.

------------------------    original post    ------------------------

I received the following error.

The webpage at https://signin.intel.com/?appid=515&TYPE=33554433&REALMOID=06-900bfa3b-39d4-4f49-95b0-099aaaf63c20&G... might be temporarily down or it may have moved permanently to a new web address.

Tags (2)
0 Kudos
89 Replies
Maciej_Ż_
Beginner
477 Views

Previously i did install it on custom directory. So I removed XDK and tried installing it on default directory, with admin privileges. It did not solve the issue and still getting the same error message after clicking log in or sign up.

Eduardo_E_
Beginner
477 Views

Intel XDK 3900 Windows 10 Can't Login... 

PaulF_IntelCorp
Employee
477 Views

A proper solution for the 3900 login issue is still being investigated.

If you are using the Intel XDK to complete the HTML5 from W3C Xseries instructional course, use Brackets instead and read this FAQ.

In the meantime, we have identified a workaround for the Intel XDK login issue. Please try it and report back on this thread if it works for you. The workaround described below is for a Windows system. Instructions for a similar workaround can be provided for OSX and Linux, if needed. If you are seeing this problem on Mac or Linux, please report here.

This workaround requires that you have Chrome 55 or greater installed on the same machine that you are using to run the Intel XDK.

  • Close the Intel XDK.
  • Make sure your system date and time is correct.
  • Open a new tab in your Chrome browser (must be Chrome version 55 or later).
  • Type https://appcenter.html5tools-software.intel.com/ into your Chrome browser.
  • If you see a "Thank you for using the Intel® XDK." message in the browser, skip the next step, otherwise...
  • Sign into the Chrome browser login page using your Intel XDK login username and password credentials.
  • When you see a "Thank you for using the Intel® XDK." message in the browser, continue...
     
  • Copy this file: "%LocalAppData%\Google\Chrome\User Data\Default\Cookies"
    to this folder:   "%LocalAppData%\XDK\User Data\Default"
    (note there are spaces in the paths, so the double-quote characters are required!)
     
  • After a successful copy operation, restart the Intel XDK and you should be automatically logged into your XDK account.

To perform the Cookies file copy using a Windows command prompt:

> cd "%LocalAppData%\XDK\User Data\Default"
> copy "%LocalAppData%\Google\Chrome\User Data\Default\Cookies" .
Overwrite .\Cookies? (Yes/No/All): y
        1 file(s) copied.

IMPORTANT: do not forget the '.' character at the end of the copy command (above), it means "copy into this directory."

If your login times out, due to not using the XDK for an extended period of time (this usually takes a week or more), or you logout of the XDK, you may have to use this procedure again.

To create an account outside of the Intel XDK, goto https://software.intel.com/registration and follow the prompts.

Following is the same procedure, with some images included, for detail:

  • Close the Intel XDK.
  • Make sure your system date and time is correct.
  • Open a new tab in your Chrome browser (must be Chrome version 55 or later).
  • Type https://appcenter.html5tools-software.intel.com/ into your Chrome browser.
  • If you see a "Thank you for using the Intel® XDK." message in the browser, skip the next step, otherwise...
     
  • Sign into the Chrome browser login page using your Intel XDK login username and password credentials.
    Screen Shot 2017-03-16 at 17.10.47 .png
     
  • When you see a "Thank you for using the Intel® XDK." message in the browser, continue...
    Screen Shot 2017-03-16 at 17.11.30 .png
     
  • Copy this file: "%LocalAppData%\Google\Chrome\User Data\Default\Cookies"
    to this folder:   "%LocalAppData%\XDK\User Data\Default"
    (note there are spaces in the paths, so the double-quote characters are required!)
    Screen Shot 2017-03-16 at 17.04.23 _censored.jpg
  • After the copy, restart the Intel XDK and you should now be logged in.
James_H_4
Beginner
477 Views

I have not customized the install directory.

Eduardo_E_
Beginner
477 Views

It worked for me, Thanks.

Saulo_S_
Beginner
477 Views

I did this last method and it finally worked.
Now I can work on my projects.

KAMARULZAMAN_H_
Beginner
477 Views

Hello,
Today i tried to build my app but i can't get to log in (i tried with 3 different computers), and so i can't build.
Is the build server of Intel XDK offline ?
Does someone know when it will become available ?

Thanks.

Maciej_Ż_
Beginner
477 Views

last method also worked for me

Maciej_Ż_
Beginner
477 Views

KAMARULZAMAN H. wrote:

Hello,
Today i tried to build my app but i can't get to log in (i tried with 3 different computers), and so i can't build.
Is the build server of Intel XDK offline ?
Does someone know when it will become available ?

Thanks.

read the workaround

Artur_G_
Beginner
477 Views

I have just installed XDK 3900 but it does not work. I have the same problem as described above. Please help! What should I do?

By the way, I use Windows 7.

Artur_G_
Beginner
477 Views

I have done as Paul F. (Intel)  Fri, 03/17/2017 - 12:40 and  Eduardo E. Fri, 03/17/2017 - 15:16 have recommended., i.e. Copy this file: "%LocalAppData%\Google\Chrome\User Data\Default\Cookies"
to this folder:   "%LocalAppData%\XDK\User Data\Default"
(note there are spaces in the paths, so the double-quote characters are required!)

 

But still it does not work for me. I cannot login XDK to proceed! By the way, this is my first experience using this software. I use Visual Studio Code, and there is no problem like this.

PaulF_IntelCorp
Employee
477 Views

Artur G. wrote:

I have done as Paul F. (Intel)  Fri, 03/17/2017 - 12:40 and  Eduardo E. Fri, 03/17/2017 - 15:16 have recommended., i.e. Copy this file: "%LocalAppData%\Google\Chrome\User Data\Default\Cookies"
to this folder:   "%LocalAppData%\XDK\User Data\Default"
(note there are spaces in the paths, so the double-quote characters are required!)

But still it does not work for me. I cannot login XDK to proceed! By the way, this is my first experience using this software. I use Visual Studio Code, and there is no problem like this.

Did these steps succeed?

Paul F. (Intel) wrote:

  • Close the Intel XDK.
  • Open a new tab in your Chrome browser (must be Chrome version 55 or later).
  • Type https://appcenter.html5tools-software.intel.com/ into your Chrome browser.
  • If you see a "Thank you for using the Intel® XDK." message in the browser, skip the next step, otherwise...
  • Sign into the Chrome browser login page using your Intel XDK login username and password credentials.
  • When you see a "Thank you for using the Intel® XDK." message in the browser, continue...

If the above steps worked, then you probably are not copying the "Cookies" file properly. Please try again.

James_H_4
Beginner
477 Views

The workaround works for me. What is the ETA on the actual fix?

KAMARULZAMAN_H_
Beginner
477 Views

It worked for me, Thanks.

Johnny_N_1
Beginner
477 Views

The workaround worked for me. However, I had to sign-in to the Intel site using my default account for Chrome (I have two profiles) before copying and pasting the Cookies file.

Dower_C_
Beginner
477 Views

The last method of copying the cookies worked... What's up with that?

Youness_E_
Beginner
477 Views

Copying the cookies worked. Hoping this issue will be solved soon.

Patrick_T_2
Beginner
477 Views

This worked for me. Thank you.

Artur_G_
Beginner
477 Views

I've done as was recommended. In the result, I have received the message mentioned:

Thank you for using the Intel® XDK.

If you are accessing this service from AppPreview, you may close the sign in window.

Again, I've copied the file: "%LocalAppData%\Google\Chrome\User Data\Default\Cookies"
to this folder:   "%LocalAppData%\XDK\User Data\Default".
Now, when trying to enter XDK, a new window is opened "NW.js". So, what should I do then?

PaulF_IntelCorp
Employee
447 Views

Artur -- do you also see a standard XDK window? Or just that NW window? I recommend doing the following:

  • exit the XDK
  • open a command prompt window (terminal)
  • at the open command prompt, type the following commands:
    > cd %LocalAppData%\XDK
    > copy global-settings.xdk %UserProfile%\global-settings.old.xdk
    > copy "User Data\Default\global-settings.xdk" %UserProfile%\global-settings.new.xdk
    > rd /s /q *.*
    > copy %UserProfile%\global-settings.*
    > copy global-settings.old.xdk global-settings.xdk
  • start the XDK (it will likely not login)
  • exit the XDK
  • copy the Cookies file according to the workaround instructions
  • start the XDK

Let me know if that works.

Robert_T_1
Beginner
447 Views

This bug affected me too. The workaround works fine for me.

During my app testing I had to change the system time, and this is exactly what caused the problem.

Maybe that will help you with the bug fix?

Thanks

Reply