Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jan_Rüegg
Beginner
138 Views

SR300 disconnecting randomly

Hello

I've received more than one SR300 recently, and everything works fine so far. However, there is one major problem:

When using the camera, after some time (usually between 20 seconds and 2 minutes) of using the camera, the camera just turns off (green light goes off) and the application crashes or stops. Starting the application again usually works fine (although killing the DCM is sometimes necessary), for another minute or two.

We tried with different SR300, on three different computers (all with USB3 connection). All with the newest DCM for the SR300 and newest runtime. This happens with our applications, and the intel test applications (raw streams application). An external powered USB hub didn't help.

Any ideas what the problem could be, or how to fix these random disconnects?

Best

Jan

0 Kudos
6 Replies
Edward_S_Intel1
Employee
138 Views

Hi Jan,

Can you provide details, please:

1. How do you use camera: RSSDK sample (which sample) or your own application?

2. Does RealSenseDCM service exist and is started when camera turned off?

Ncare
Beginner
138 Views

Just adding to Jan's report, I've also had this problem - I actually sent the realsense back, after contacting support, since it seemed like it might be a hardware problem. Since then I've had the same issue with the replacement, but only intermittently.

Model: SR300 with latest DCM
Computer: Dell laptop with appropriate hardware requirements
Software: problem has appeared using both the Camera Explorer, RSSDK sample tools, and my own programs.

Generally if I unplug the device and plug it back into a different port, it starts working again.

Jan_Rüegg
Beginner
138 Views

More details:

  1. This happens both with the SDK (camera_viewer) and with our application
  2. Yes, this is true. I have to correct myself though: The camera is still running when the camera stream stops (or at least, the green light is still on).

The steps when it crashes:

  1. We start the camera viewer, everything is fine.
  2. After some time, without anything changing on the computer, the image stops, and the camera_viewer application gets unresponsive. The light is still on.sr300_camera_viewer_crash.PNGdcm_process_after_crash.PNG
  3. Closing the application and restarting it doesn't help, no images appear:sr300_cam_viewer_after_restart.PNG
  4. Unplugging the camera and replugging it (to the same port) makes it work again (back at step 1).

I also attached the sdk_info output for more information.

seyhmus_s_
Beginner
138 Views

I installed the camera driver v3.1.25.2599 SR300.
Intel reals Sense ™ Software Development Kit 2016 I installed R1.
I put SR300 camcorder to the USB 3.0 ports.
The game runs about 3 minutes while shooting video camera turns itself off and the green light is fading.

How do we solve this problem?

Cole_L_
Beginner
138 Views

Gonna go ahead and add that I am having similar issues. Working in Unity, I will run the game several times and the camera will work, then randomly the green light will go out, I hear the usb disconnect sound and the game crashes. This happens even when I don't change anything on the game itself. Seems to happen every so often after running the game a few times.

samontab
Valued Contributor II
138 Views

It sounds like a firmware problem on the SR300.

You could check if accessing different parts of the API allows you to run longer times.

Or even just opening the camera and not doing anything with it.

That would help to pin point if there's a specific firmware function with an issue.

I don't have a SR300 to test, but F200 and R200 with latest DCM can run indefinitely in my tests.

Reply