Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jphirani
Beginner
79 Views

Trying to install intel fortran (academic license) on a new computer

I am trying to install an academic license of intel fortran for linux on a new computer in our lab. As per the download information we need not renew the license till the version 2016/ Update 3 Eng/Jpn. But we are not able to install the license file. If we try to change the MacId on license by using "Manage" button we do not see any "x" on the old computer on which fortran was installed and not able to see an activation button on the new computer. We are attaching below the screen that we see when we press manage button. Please guide how do we install the intel fortran on the new computer.Fortran_0.jpg

0 Kudos
11 Replies
79 Views

Hi, Jphirani,

Your license is an old named-user license. You should not need to generate a new license file to install it on a different machine. You should be able to simply install it as normal.

Please let me know if the installation is successful.

- Alex

jphirani
Beginner
79 Views

Thanks Alex,

 

We tried to install it using the license file. But we are getting the message below when we specify the path of the license file.

"

/home/dell/Downloads/COM_L__FOR_XXXX-XXXXXXXX.lic
The license file(s) you provided is not valid for this product.
--------------------------------------------------------------------------------
Please press "Enter" to try again:

"

We are trying to install the vesrion 2016/ Update 3 Eng/Jpn of fortran.

Please help.

79 Views

Jphirani,

Please send me your license file using the Send Author a Message link on the gray bar by my name so I can see if there's something wrong with it.

- Alex

79 Views

Jphirani,

Your license expired in June of 2015.

The update you're trying to install has a build date of April 16th, 2016.

I'm not sure how you even downloaded it, but that update came long after your license expired and will not work with it. I believe the latest one you can get is probably 2015 Update 4.

- Alex

jphirani
Beginner
79 Views

Alex,

We tried it with 2013 version also. We are still getting the same problem. 1st it gave the problem that OS is new and then the license is not valid if we skip that warning. I am attaching the sceenshots below for the two problems.

Thanks.

79 Views

Jphirani,

What operating system, exactly, and OS version are you using?

Secondly, I don't remember off the top of my head whether you're supposed to enter the path up to, but not including the license file, as you did in the second screenshot, or whether you're supposed to include the license file name when you provide it. It might be worth a shot to try doing that (e.g. "Please enter the full path to the license file: /home/path/license.lic"), just in case, if you haven't yet.

Meanwhile, I'll keep looking into this. Unfortunately "This license file is not valid for this product" is one of the most common errors with literally dozens of possible causes. I appreciate your patience as I eliminate possibilities.

Edit: I might as well ask you for a log file. Before you attempt to install the product, please export INTEL_LMD_DEBUG=/tmp/IntelDebug.log (or set to another location of your choice). Then when you run the installer (from the same command window), it'll produce a log file called IntelDebug.log in /tmp (or wherever you decided to put it). Please click the Send Author a Message link on the gray bar by my name to send a private message, and attach the log.

- Alex

jphirani
Beginner
79 Views

Dear Alex,

We were able to install the program before we got your edit. We used 2015 version "l_fcompxe_2015.3.187". We are still not able to run our fortran programs though. We added following two lines in .bashrc file

source /opt/intel/composer_xe_2015.3.187/bin/compilervars.sh ia32
source /opt/intel/composer_xe_2015.3.187/bin/compilervars_arch.sh ia32

The error is #7002. we have used the "use numerical libraries" in the code. So we don't know if the installation and setting up the environment is correct? As the same code was working on the old computer that we had.

Thanks,

Jyoti

79 Views

Jphirani,

By error 7002 do you mean: "error #7002: Error in opening the compiled module file. Check INCLUDE paths"?

Chances are that this is not a problem with setting up the compiler itself, but setting up your code to compile, specifically in telling the compiler where to look for modules your code requires. Here's an old thread on this topic; it might help you.

- Alex

jphirani
Beginner
79 Views

Dear Alex,

We are getting error "

 error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [NUMERICAL_LIBRARIES]
    use numerical_libraries
------------^


"

We read that it requires IMSL libraries to run this. As this was running earlier, so please help us in installing the the IMSL libraries.

Thanks.

79 Views

Jphirani,

As far as I know, Intel does not provide or support IMSL on Linux. I can direct you to Rogue Wave's website, but that's about it, sorry.

For other people who are on Windows and have a similar problem, this guide may be of use. Please note that even on Windows, not all Parallel Studio variants contain IMSL.

If you're willing to rework your code, my understanding is that a large chunk of the functionality provided by IMSL is also provided by our Math Kernel Library. Depending on how you're using IMSL, you may be able to replace it with MKL (which is included in all Parallel Studio variant packages, so you already have it). However, this would require you to actually replace the usage of IMSL with the equivalent usage of MKL. And I can't guarantee that the particular functionality of IMSL you're using is provided by MKL at all; it depends on how you're using it.

- Alex

79 Views

Jphirani,

Has your issue been resolved? If I don't hear back by Thursday the 23rd, I'll go ahead and close the thread.

- Alex

Edit: I never heard back, so I'm closing this thread. If you have a similar question please create a new thread so we can get to you in a timely and efficient fashion.

Reply