Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jeff_S_1
Beginner
69 Views

XDK Bug: IDE does not respect custom Documents folder location

Jump to solution

I have My Documents on another hard drive.  So when I went looking for my project I went to My Documents but I didn't find it!

Turns out Intel saved the project to c:\users\user\documents rather than to my custom documents folder that My Documents points to.

Tags (2)
0 Kudos
1 Solution
PaulF_IntelCorp
Employee
69 Views

You can change that "default" location manually (the XDK is supposed to be smart about it, but something broke some time back and we haven't been able to get it fixed). Locate the "global-settings.xdk" file on your system (location varies as a function of the OS) and find this JSON object inside that file:

 "projects-tab": {
    "defaultPath": "/Users/paul/Documents/XDK",
    "LastSortType": "descending|Name",
    "lastSortType": "descending|Opened",
    "thirdPartyDisclaimerAcked": true
  },

The bit above came from a Mac. On a Mac "global-settings.xdk" is located under "~/Library/Application Support/XDK"

On a Windows machine global-settings.xdk is normally found in "%LocalAppData%\XDK" and the part you're looking for will look something like this:

  "projects-tab": {
    "thirdPartyDisclaimerAcked": false,
    "LastSortType": "descending|Name",
    "lastSortType": "descending|Opened",
    "defaultPath": "C:\\Users\\paul/Documents"
  },

Obviously, it's the "defaultPath" part you want to change.

BE CAREFUL WHEN YOU EDIT THE GLOBAL-SETTINGS.XDK FILE!! You've been warned...

Make sure it is proper JSON when you are done, or it may cause your XDK to cough and hack loudly. :) Make a backup copy, just in case.
 

View solution in original post

5 Replies
John_H_Intel2
Employee
69 Views

That is the default that is used. When you create a new project, you have the option to specify where the project is saved.

Did you specify your external drive when you started the project?

Jeff_S_1
Beginner
69 Views

I went with the default folder location.  There is literally nothing in c:\users\user\documents except my XDK projects.

I suppose the expected behavior would be to respect custom Windows folder settings.

PaulF_IntelCorp
Employee
70 Views

You can change that "default" location manually (the XDK is supposed to be smart about it, but something broke some time back and we haven't been able to get it fixed). Locate the "global-settings.xdk" file on your system (location varies as a function of the OS) and find this JSON object inside that file:

 "projects-tab": {
    "defaultPath": "/Users/paul/Documents/XDK",
    "LastSortType": "descending|Name",
    "lastSortType": "descending|Opened",
    "thirdPartyDisclaimerAcked": true
  },

The bit above came from a Mac. On a Mac "global-settings.xdk" is located under "~/Library/Application Support/XDK"

On a Windows machine global-settings.xdk is normally found in "%LocalAppData%\XDK" and the part you're looking for will look something like this:

  "projects-tab": {
    "thirdPartyDisclaimerAcked": false,
    "LastSortType": "descending|Name",
    "lastSortType": "descending|Opened",
    "defaultPath": "C:\\Users\\paul/Documents"
  },

Obviously, it's the "defaultPath" part you want to change.

BE CAREFUL WHEN YOU EDIT THE GLOBAL-SETTINGS.XDK FILE!! You've been warned...

Make sure it is proper JSON when you are done, or it may cause your XDK to cough and hack loudly. :) Make a backup copy, just in case.
 

View solution in original post

Jeff_S_1
Beginner
69 Views

"defaultPath":"c://Users//User\Documents"

Does not properly respect the flags of windows.

I will have to assume that "c://Users/User" is a field that is derived out of necessity but the "\Documents" folder is one that is hardcodeded rather than respecting proper windows pathing.

PaulF_IntelCorp
Employee
69 Views

Jeff -- you can change that path in that JSON object to point to where you want it to... I've got a long-standing bug/feature request in place to make this changeable via the UI. Paul

Reply