Community
cancel
Showing results for 
Search instead for 
Did you mean: 
asouz5
Beginner
1,864 Views

Dual Band 7260n horrible ping times?

Jump to solution

I just bought a bunch of laptops for my company and I am having a serious problem with our wifi cards. We purchased Win7 64 bit computers with the Intel DualBand 7260N chip. When I ping the router, I get on average, 60+ms round trip times on the wifi. With a different (old) laptop, connecting to the same AP, I get around 3ms to the same router.

I took a couple laptops home, to rule out anything at work, and I see the same results at the house. On my personal laptop, I can ping the home router and get 2ms response times. With the 7260N, I get 50+ms.

I have tried like three different drivers from intel's website, this happens on 5ghz and 2.4ghz. Please help.

-Aaron

0 Kudos
1 Solution
gstef1
Novice
145 Views

When you measure pings as a base line for connectivity you need to consider many things. Interference layer 1 and layer 2. Client / AP config etc.

Since you did some testing already. See what is different in configs on the client side in the driver of the 2 laptops.

Also try disabling UAPSD if enabled in the driver.

View solution in original post

7 Replies
tvete
Valued Contributor II
145 Views

No problems with my Dual Band 7260 on my laptop here. Maybe your router is having latency problems with Intel WiFi cards only. What is the adapter of your other laptop?

Microsoft Windows [Version 6.1.7601]

 

Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ping 192.168.1.101 -n 200

Pinging 192.168.1.101 with 32 bytes of data:

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=2ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: bytes=32 time<1ms TTL=64<p> Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

 

Reply from 192.168.1.101: byt...
gstef1
Novice
146 Views

When you measure pings as a base line for connectivity you need to consider many things. Interference layer 1 and layer 2. Client / AP config etc.

Since you did some testing already. See what is different in configs on the client side in the driver of the 2 laptops.

Also try disabling UAPSD if enabled in the driver.

View solution in original post

asouz5
Beginner
145 Views

So far the best solution is to disable U-APSD and reboot the laptop. Pings come down from 40ms to like 2ms... I only brought home 2 laptops, but that procedure right now works. I'll know more tomorrow.

gstef1
Novice
145 Views

UAPSD is a little bugger ... Let us know ..

Kevin_M_Intel
Employee
145 Views

Thanks you all for providing feedback on this matter. Here you can also find more information about this:

http://www.intel.com/support/wireless/wlan/sb/CS-034875.htm http://www.intel.com/support/wireless/wlan/sb/CS-034875.htm

Kevin M

BLaut
Beginner
145 Views

FWIW, disabling U-APSD on my 7260 (in a ThinkPad T520) totally resolved my issue where I could not reconnect after resuming from sleep. I changed the setting right after I saw this thread about 2 weeks ago, and it reconnects virtually every single time - it might happen once a week, where it happened every time (a dozen times a day) before. I also seem to have consistent throughput now, and the 5Ghz networks no longer mysteriously disappear. (I waited a couple of weeks to make sure I wasn't imagining things.)

My notebook demonstrated these symptoms both at home (Asus RT-AC66U) and at work (Cisco infrastructure, various models) - and *poof* - all is well once I disabled U-APSD.

I've had this adapter for a little over a year now and followed a lot of threads on this forum, but didn't have any major issues until about 2 or 3 months ago. Perhaps that coincides with the first driver containing U-APSD being installed on my notebook? I realize it was a later addition, or at least the setting/option appearing in the driver was.

Thanks!!

asouz5
Beginner
145 Views

Basically the problem is with U-APSD... I have tried the past 4 driver releases, all have the same poor performance unless you turn off U APSD. Interesting thing I noted...It appears that turning off U-APSD does not take affect until a restart, while enabling it, brings back the bad performance quickly, without a reboot.

At least on one revision of drivers (I think the one from April).

Reply