Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7655 Discussions

ICPS v. 3.1024.505.1 keeps failing with error code 15613


I have an HP Envy x360 laptop running Windows 11 Home 23H2 OS Build 22631.3593.  My Intel Driver & Support Assistant informed me I should install ICPS for Intel Wireless Products version 3.1024.505.1, so I selected download and install.  However, about midway through installation, I kept getting the error notification I've attached (see picture).  I tried installing the update several times.  After these failures, I tried starting my CURRENT version of ICPS, which no longer seemed to work--it wouldn't start.  So, I uninstalled that version, and installed version 3.1024.405.4, which does apparently work--apparently.


This is not the first time I've encountered difficulty installing ICPS through Intel Driver & Support Assistant, and it is becoming really irritating that the software either doesn't recognize the hardware I have, or is giving me software that just plain doesn't install.  It's truly irritating!


Can you--that is, can Intel--tell me if I really need version 3.1024.505.1 or not?  And--if not--did I install the correct version for my laptop, by installing 3.1024.405.4 from the Intel website?


I would need your help to figure out the Intel hardware my machine has, because I don't know exactly where to look, short of using Device Manager, which with my luck, isn't the correct way to find out!  Thank you.

0 Kudos
9 Replies

Hi, I want to add to the thread above that I am facing the same issue as he is.


My laptop is a Lenovo LENOVO 82Y7 or Yoga Pro 7 14IRH8, and now the Intel connectivity Performance Suite is Completely unuseable. Tried to follow the guide to completely uninstall the driver here: https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/yoga-series/yoga-pro-7-14irh8/solutions/ht513263-how-to-completely-uninstall-intel-connectivity-performance-suite-driver-from-a-system and https://www.intel.com/content/www/us/en/support/articles/000093451/wireless/wireless-software.html but to no avail.


I would love to hear a solution from Intel about this update issue.


Kind regards,

0 Kudos


I Got same issue too
already try to manual install, but still same error

when i try to open icps


it show this



0 Kudos

Intel, what I'm trying to find out is this.  Is ICPS version 3.1024.505.1 buggy (and will be fixed)?  Or, is it not even applicable to my HP Envy x360?


If ICPS version 3.1024.505.1 IS NOT buggy, then why doesn't Intel Driver & Support Assistant warn me, that my HP Envy x360 SHOULD NOT INSTALL the newest ICPS version, rather than basically blindly installing it?  (Why even offer it to me, if it is not appropriate for my system?)


It seems to me that Intel should know these things, and then WARN USERS that an application they are attempting to install IS NOT APPROPRIATE FOR THEIR COMPUTER, before making users uninstall applications they believed were appropriate.  Thank you.

0 Kudos

I'm using an INTEL NUC Laptop and I have the same issue. Based on the variety of devices, I suggest the software is buggy.

0 Kudos

I have tried the following in order to resolve/workaround this problem with installing the latest version of 'Intel Connectivity Performance Suite' (ICPS) - i.e. version 3.1024.505.1. However, ALL OF THESE METHODS FAIL with error message 'The wizard was interrupted before Intel Connectivity Performance Suite could be completely installed' and/or 'Error number 15613' (which means the same thing, apparently):

1) Automatic installation of ICPS via the 'Intel Driver & Support Assistant' tool.

2) Manual installation of ICPS via version 30.24.576 of the manual installer (downloaded from https://www.intel.com/content/www/us/en/download/738623/intel-connectivity-performance-suite-for-intel-wireless-products.html) - which the download page says is supposed to install the same version of ICPS itself (i.e. version 3.1024.505.1).

3) Manual uninstall of 'Intel Connectivity Drivers UWD' in 'Programs and Features' of 'Control Panel' (and reboot of my PC) and then retrying method (1) above.

4) Manual uninstall of 'Intel Connectivity Drivers UWD' in 'Programs and Features' of 'Control Panel' (and reboot of my PC) and then retrying method (2) above.


5) Any attempt to run ICPS from the Windows START menu now gives error message 'The Intel Connectivity Performance Suite is currently disabled. Would you like to enable it?'. However, whether I answer YES or NO to this question, the program just shows message 'Unable to start the Intel Connectivity Performance Suite' and only offers an EXIT button (which just closes this program entirely).

6) I have also tried manually uninstalling ICPS itself (by right-clicking it in the Windows START menu and selecting 'Uninstall') - then repeating tests (1) to (4) above. ALL 4 OF THESE REPEATED TESTS FAIL TOO, yielding the same error message as above - plus I am now missing ICPS from my PC's START menu altogether too.

NOTE: After tests (3) and (4) above, 'Programs and Features' in 'Control Panel' shows that 'Intel Connectivity Drivers UWD' HAS been (re)installed to the correct new version (30.24.576). However, it looks like the associated version (3.1024.505.1) of 'Intel Connectivity Performance Suite' itself has NOT also been (re)installed at this stage too.

It therefore looks like the installer is failing when the ICPS installation is attempted, but succeeds at an earlier point with installing the 'Intel Connectivity Drivers UWD' software element - so this certainly seems like a buggy ICPS driver update program to me.


I have an HP Envy x360 2-in-1 (Laptop 13-bf0500sa) PC with an 'Intel Wi-Fi 6E AX211 160MHz' network adapter, and I am running Windows 11 Home Edition on this device (64-bit, of course - as Windows 11 is ONLY available in 64-bit versions). I also have full admin rights on this PC and have attempted all of the above installation methods using these rights (i.e. ALL methods have FAILED).

I have also checked the version number of the device driver for the 'Intel Wi-Fi 6E AX211 160MHz' network adapter in my PC, and this is version - which is the latest version available at https://www.intel.com/content/www/us/en/download/19351/intel-wireless-wi-fi-drivers-for-windows-10-and-windows-11.html.

0 Kudos

AllanW, really good writeup (I'm not nearly so thorough).  What I can add is the following, which is a screenshot from Intel Driver & Support Assistant on the three updates I was notified of, and tried to install, at the same time.  Intel Wireless Bluetooth Drivers for Windows 10 and Windows 11, and Intel Wireless Wi-Fi Drivers for Windows 10 and Windows 11, were successful.  However, Intel Connectivity Performance Suite for Intel Wireless Products, was unsuccessful--a number of times--using the methods you described.

I finally resorted to finding the last version of Intel Connectivity Performance Suite for Intel Wireless Products (v. 3.1024.405.4) that worked, which I then downloaded and installed successfully.  And that's where I'm at right now.  Such a pain... 


Interesting how two of the updates were okay, but one was a failure.  That seems to add weight to the "buggy ICPS app" theory.



0 Kudos

I hate to say it but I am having the same problem too. I've tried everything the people here did and even uninstalled my previous ICPS version and tried to install the new one with no luck.  I had to go back and re-install the version I previously uninstalled and tried again with absolutely no luck and the same message, over and over again.  Help please.


I am running a HP Spectre x360 14-ef2047, Windows Home Version 23H2.

0 Kudos



The topic issue has not been solved, and will not be solved, until it is determined whether the ICPS for Intel Wireless Products version 3.1024.505.1 update has a problem (bug) which results in installation failures.  Several users are reporting these failures, so it isn't limited to my particular Windows 11 laptop.  Thank you.

0 Kudos



This gets a little more crazy.  I just visited the Microsoft Store, and see that Intel Connectivity Performance Suite is also offered there!  And it indicates what you see in this image--Installed version 3.1024.405.0!  However, I then double-checked the ICPS I have installed, and see that it is in fact 3.1024.405.4, as I stated in my original post.  So, is the Microsoft Store ICPS Additional Information not correct, and if it is, then why is it incorrect?


What has happened to me is this, basically.  I tried to install v. 3.1024.505.1 per Intel Driver & Support Assistant.  The installation failed.  I downloaded and installed an earlier version, v. 3.1024.405.4.  The installation completed and the app appears to function.  But then, I see v. 3.1024.405.0 on the Microsoft Store site, which is an even earlier version!  Way too confusing, Intel!  How are we to know which version is the most current, and the most appropriate for our particular systems?  Because we have Intel Driver & Support Assistant pushing us one version, the Microsoft Store showing another version, and a version "somewhere in the middle" actually on our computers.

I feel like I'm chatting with Morpheus, only he's offering me THREE pills to choose from... 


0 Kudos