Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7506 Discussions

Intel AC7260 limited access after sleep

MZ4
Novice
114,391 Views

Hello,

I have Intel AC7260 and there is a problem: after every wake from sleep mode i have limited access and no connection to the Internet. I can't ping router and any device in the network... Sometimes helps to reconnect but most often I need to reboot :/ Can someone help me please?

431 Replies
GGros1
Beginner
2,928 Views

What do you have to do to restore connection when it "drops randomly"? Does it resolves itself after some time or........? As with many people here, I removed the ProSet software and just use the bare drivers. I am running driver version 17.1.0.19, latest from Intel website [file name: Wireless_17.1.0_De164]. This resolved my limited access after sleeping and also stopped random loss of connection to AP. Before installing, remove drivers via the device manager (could be multiple iterations of process) till you get back to the Window supplied driver. From here, I loaded the driver above.

Take a look at my post at # 228 and # 231 in this thread to get an understanding of what is happening to me after resolving the above, rather than repeating. I think I am on to a possible solution but still testing it to see if it really is or am just lucky for a short time and problem will return.

0 Kudos
CSayr
Novice
2,928 Views

Thanks for the info. I'm not really sure yet, I'll have to monitor it more carefully. I never had the ProSet software installed so it's definitely not that.

0 Kudos
CSayr
Novice
2,928 Views

So at least so far it looks like I'm not having any issues at work, which I believe is a 2.4 GHz network. At home I have 2.4 GHz and 5.0 GHz networks but neither appears to be working correctly. It's a router provided by my internet provided but I can adjust the settings as needed. Even if the wireless chip is at fault, it looks like I can work around the issue via wireless settings. Any recommendations? If I can get this thing working at home, that will solve 99% of my issues since that's where I use it most of the time.

EDIT: It literally is connected as soon as I open the laptop - like it never lost the connection at all, but only at work. If I could get it working like this at home I would be a happy camper.

0 Kudos
DKimb
Novice
2,928 Views

Hi ShadowXOR,

I'm also using the 17.12.0.4 driver and haven't had a single failure on wake up since I installed it over a week ago. The main settings that make things work for me are to enable "Allow the computer to turn off this device to save power" under the Power Management tab on the 7260 properties dialog and enable the U-APSD option under the Advanced tab. Disabling these settings causes my system to fail on wake up almost every time. You should also look under the "Network Adapters" section in Device Manager for "Microsoft Virtual WiFi Miniport Adapter" and enable "Allow the computer to turn off this device to save power" under the Power Management tab of this as well.

Hope this helps.

D

0 Kudos
CSayr
Novice
2,930 Views

I've set everything as you described (though I don't have a Microsoft Virtual WiFi Miniport Adapter). Now I just have to wait and see how things go. Thanks!

0 Kudos
KFols
Beginner
2,930 Views

ShadowXOR,

I have the same driver and settings as Dilburt describes in post number 280 but, like you, don't have the Miniport Adapter installed. I've been problem-free for several weeks now, so hopefully you'll be fine with these settings, as well.

0 Kudos
CSayr
Novice
2,930 Views

Thanks, it looks like I need to tweak my router settings or something because it works perfect at the hotel I'm staying and at work, but has weird issues at home. Strangely all other devices work fine at home. Not sure what settings I need to tweak on my router or if they just don't get along. It's a hybrid modem/router provided by my ISP but has worked fine otherwise until now. Maybe it's not respecting the sleep/power saving Wi-Fi connection of the laptop? Not sure.

0 Kudos
CSayr
Novice
2,930 Views

Thanks to everyone that has offered help I believe I may have fixed it with some of the follow changes (not sure which did it, probably a combination and almost all of these were changed on my router, the only thing I did on the laptop was change networks and update drivers):

  • Installed the latest drivers (not the ones on the Intel site, the ones someone provided a manual download to, the ones Intel only sent to OEMs for some stupid reason).
  • Set Wi-Fi Tx Power Level to Low.
  • Switched to the 5.0 GHz network instead of the 2.4 GHz.
  • Enabled WMM.
  • Disabled Frame Burst.
  • Set Wireless Mode to N only.
  • Used a Wi-Fi signal tester and manually set the channel to 36.
  • The time on my router was off by a day (this has caused weird issues in the past believe it or not).

I'm not truly convinced it has been resolved yet but so far so good. I made a ton of tweaks to my 2.4 GHz network trying to get it to work better but I never even got to test the waking from sleep issues because the speed was abysmal. My Moto X still has better download speeds on 2.4 GHz than this laptop has on 2.4 or 5.0 GHz but it's plenty fast enough. Provided I don't encounter any drops during use I'll be a happy camper. Amazon even credited me back 15% of the purchase cost for my troubles - and that's why they're the best...I didn't even ask, they offered when I emailed them about the issues I was having inquiring how long my return period. But otherwise I love this laptop (UX303LA).

0 Kudos
LYang24
Novice
2,930 Views

Well...

Not all Wifi routers support 5 GHz. And not all Wifi routers support 802.11n ....

Also in general, 5 GHz has shorter range than 2.4 GHz.

0 Kudos
DKimb
Novice
2,925 Views

Hi joe_intel,

One other issue regarding the 7260 drivers are that they still have an issue that causes Dell's customized Quickset to produce the following error message:

"Error found! Submit this issue to Quickset owner!".

I'm using Quickset64 on an XPS 15 L521x but I searched and found this error going back to version 3.x.x of the ProSet Wireless releases across many different laptop manufacturers. Most mention it as a ProSet problem although it's affecting me and I only have the base driver installed. I doubt if this is related to the sleep/wake problems but it would be nice to think that this will also be fixed in future 7260 driver packages. Can you verify that Intel is aware of this problem?

Thanks,

D

0 Kudos
Jose_H_Intel1
Employee
2,925 Views

Dilburt, I am not aware of your issue either; did you contact your system manufacturer about it?

I suggest you trying the latest driver version 17.12 from the DELL*'s website as they should customize it to operate with the software they provide.

If the issue persists I suggest you contacting your local http://www.intel.com/p/en_US/support/contactsupport Intel support team for further assistance.

0 Kudos
KFols
Beginner
2,937 Views

I wanted to report that my Lenovo T440p has been working well with the 17.12.0.4 from Lenovo and found at http://support.lenovo.com/us/en/downloads/ds036007 http://support.lenovo.com/us/en/downloads/ds036007. I'd tried earlier drivers from both Lenovo and Intel and was seeing frequent failures of the wireless connection to re-connect when bringing my laptop out of sleep mode. This was the only problem I was having. Since installing this driver on 09/21/14, I've had no failures.

My T440p is running Windows 7 Pro as installed by Lenovo. I've removed a few of their stock apps but haven't significantly modified the install.

MZ4
Novice
2,925 Views

1. Download the driver from this web site: http://support.lenovo.com/us/en/downloads/ds036007 Intel Wireless LAN (11abgn, 11bgn, 11ac) for Windows 8 (32-bit, 64-bit), 7 (32-bit, 64-bit) - ThinkPad - Lenovo Support …

2. Uninstall (remove) old Intel LAN drivers

3. Instal the drivers package BUT in last window uncheck "Instal Intel Wireless LAN now" an click Finish.

4. Go to Computer -> System properties -> Device manager and click the right mouse button on LAN device. Than click update the driver -> Browse my computer... -> search the drivers folder that you installed in 3 and Update the driver.

Everything seems to be OK so far in my case.

0 Kudos
idata
Employee
2,925 Views

Have the same problem on Samsung R710 laptops from 2009 and 2008

Bios version 11SV

Windows 8.1 with latest updates

7260AC with latest drivers

The same intermitted error when running diagnostics

Please advice!

0 Kudos
DMass1
Beginner
2,925 Views

please add me to the list. I have the same problem as everyone else. Very disappointed that this isnt fixed yet.

I've tried to contact tech support via this site, but the contact form doesnt recognize the 7260 ac card and thus makes it impossible for me to proceed and contact intel.

 

I'm using windows 8 64 bit with latest intel drivers. I'm totally lost in this thread full workarounds and alternative driver.

What should i do intel????

0 Kudos
BW_
Beginner
2,925 Views

The only work around i found is to disable the wifi interface, wait 5-10 seconds and re-enable the interface.

By doing it this way you don't have to reboot your system.

Do not try to turn off wifi and turn it back on via the laptop buttons, that is not the same as disabling it and re-enabling it.

Steps for Win8.1, but i think it's the same for Win7

1. Right click on your wifi icon and select "Open Network and sharing center", or in Control Panel select network and Select "Open Network and sharing center"

2. Select "Change adapter Settings"

3. Right click on your Wifi Adapter (which is probably stuck at acquiring I.P.) and select "Disable"

4. Wait 5-10 seconds and the right click on the adapter again and select "Enable"

5. Wait a few more seconds and you should connect to your router.

You can keep this last window open in the background minimized so you don;t have to go through steps 1 and 2 every time.

Again this is only a work around so you don't have to reboot every time.

0 Kudos
VAdde
Beginner
2,925 Views

In a similar manner, when I turn on the computer from a cold boot or after a long period of sleep, I see that the adapter has been stopped by Windows 8.1 Pro "because it has reported problems. (Code 43)". I have found the same work-around - disable/enable the adapter. But I also use a bluetooth mouse, and when I activate bluetooth, it drops the wifi connection. My configuration:

  • Lenovo Thinkpad X1 Carbon (March 2014) with recent BIOS update
  • Windows 8.1 Pro
  • intel Dual Band Wireless-AC 7260
  • Intel Wireless Bluetooth 4.0 + HS Adapter
  • Intel Pro-set Wireless Driver 17.12.0
  • Intel Pro-set Bluetooth driver /patch 17.0.1405.0464

If I turn off bluetooth and again disable / enable, then the adapter connects to the WiFi.

Even when it connects, the fastest rate on my a/b/g/n network is 39 Mbps. My old (2008) XPS with an Intel Wifi Link 4965AGN connects at 117 Mbps.

I also reset the computer back to factory conditions and re-loaded everything carefully. I also made sure I loaded the bluetooth driver before the Wireless driver as per the Intel website on the bluetooth 4.0 + HS adapter.

Next step is to return the computer to the Microsoft Store and try to find a replacement ultrabook similar to the X1 without this adapter.

0 Kudos
SHaig
Novice
2,925 Views

Ok, so I've updated my extracted archive to include ALL of the 64bit drivers... This means it now includes Windows 7 and Windows 8 64 bit drivers.

Link: https://www.crc.id.au/files/Intel%20AC-7260%20v17.12.0.4.exe https://www.crc.id.au/files/Intel%20AC-7260%20v17.12.0.4.exe

Drivers are version 17.12.0.4

AGros3
Novice
2,925 Views

The 17.12.0.4 driver didn't fix the issue for me. I grabbed the one from the Win8 folder and I still saw the issue after a sleep with "Allow the computer to turn off this device to save power" unchecked. I also had a BSOD on my Win8.1x64 host with that driver when I unchecked that option and disabled u-APSD from the Windows device properties dialog at the same time and then hit OK.

CRCinAU, can you explain the difference between the Win8 and WinB folders?

idata
Employee
2,925 Views

I second grossag's finding.

Did not work for me either

0 Kudos
DKimb
Novice
2,925 Views

Make sure to try the driver with the Power Management option enabled. The 17.12.0.4 driver is working without problems on my Dell XPS 15 L521x laptop running Windows 7 Pro 64 with 7260 power management enabled. I have wake-up problems when I disable these options.

I have both the 7260 Power Management option enabled ("Allow the computer to turn off this device to save power" under the Power Management tab) and the U-APSD option enabled under the advanced tab. There is also a device named "Microsoft Virtual Wifi Miniport Adapter" that I have the power management option enabled to allow the computer to turn of the device.

0 Kudos
Reply