Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RMyer2
Beginner
3,514 Views

Intel Dual Band AC 7260 does not support fast ISP speeds Dell

I purchased a new Del Latitude E5540 Windows 7 Pro 64 bit with a Intel Dual Band AC 7260 wireless card.

The machine is loaded.

Surprise, when I measured wireless connection my Comcast 50 Mbps ISP download speeds I am only getting about half the bandwidth, 20 Mbps or so. Connected LAN Ethernet to the machine I get full bandwidth,no issue. I have been on the phone with Dell for hours installing new drivers, etc, no fix, no change in performance.

All my Macs, iMac, etc., measure wireless through the same networks a full bandwidth. I am really surprised that I can not full wireless through Dell's newest Laptop.

Dell is sending someone out to replace the wireless card, but I am not convinced that is going to do any good. The wireless card specs show there should be plenty of headroom in the card to support high internet speeds.

Anyone have any ideas or suggestions or is this something t

0 Kudos
15 Replies
tvete
Valued Contributor II
131 Views

Are you using Wireless-N or AC? It seems that your speed corresponds to Wireless-G's maximum throughput. Try following Intel's recommended settings here: http://www.intel.com/support/wireless/sb/CS-030709.htm Wireless Networking — What are the recommended settings for 802.11n connectivity?

Also make sure that WMM is enabled in the router aside from the recommended settings above.

RMyer2
Beginner
131 Views

The driver supports A band for the 5 Ghz network, and G Band for the 2.4 GHz network. Either network performs at about 50% of the Comcast 50 Mbps download speed. In the driver there is the option to turn on WMM. I did that and it did not make a difference. This is a huge difference between 50 Mbps, and 20 Mbps for the card. To me the Intel Driver on the Dell 5540 looks deficient. It is the current driver. Thanks for your response. I would like to get this solved because I wanted to use this machine to measure my clients wireless internet speeds.

There is no N option on the driver, and that really surprised me. The driver offers a,b,g.

Someone posted that I should set the Mixed Mode Protection on the driver to RTS/CTS enabled instead of the default that is CTS-to--self-enabled whatever that means. That did not make any difference. There a big gap of speed to make up between 50 and 20.

RMyer2
Beginner
131 Views

Thank you for you helpful reply. I did download a driver update but it did not help.

On the driver advanced menu it stills shows no option to select an N band.

The specs show that this card is N capable but no N band on the driver, only q,b,and g.

How do I get N capability on this Dell machine. Other folks are getting full performance.

What do you think I need to do?????

RMyer2
Beginner
131 Views

http://www.intel.com/support/wireless/wlan/sb/cs-025787.htm Intel� Wi-Fi Products — Where are the Wi-Fi network adapter properties in Microsoft Windows XP*?

Why in the Advanced Wireless Mode setting in there no N choice???????

The property's selection shows 802.11n Channel Width for both 2.4 GHz, and the 5.0 GHz networks.

The above link is XP and I have Window 7 b4 bit but the options are all the same.

Can someone help me on these. Maybe that will help.

tvete
Valued Contributor II
131 Views

Can you show this connection status screenshot like this:

Also, In all of Intel's cards, Wireless Mode is only (a/b/g). N mode is called High Throughput and AC mode is called Very High Throughput for 7260 / 3160 wifi cards while it's called 802.11n for Centrino wifi cards.

RMyer2
Beginner
131 Views

My Status looks yours but IPv6 shows Internet, Speed on mine 54.0Mbps, full signal Quality. On the Dell, I am connected to the G network via my Linksys EA6500 router. I am currently measuring through this network on the Dell using speedtest.net 28.72 Mbps, on the iMac same network same speed test measuring 55.79 Mbps.

So from your above posts it appears that with current drivers there is no way to select an 2.4 Ghz N network for a Intel Wireless Card even though the specs for the cards show N has a supported network.

So you only and best network solutions are G for 2.4, and A for 5.0. How are folks getting full band performance out of these wireless cards.

Am i doing something wrong or overlooking some settings.

tvete
Valued Contributor II
131 Views

Dell probably disabled Very High Throughput mode by default for some reason. Anyways, 30 Mbit is the fastest speed you can get on G or A mode. See this screenshot and see if you can get the AC mode working.

RMyer2
Beginner
131 Views

I made sure the driver was set to VHT mode but did not notice much improvement and under status still shows G mode connected.

Thank you for you help here.

I appreciate it. I hope I did not buy a lemon here.

RMyer2
Beginner
131 Views

I have the ea6500 router set on mixed mode because I have quite a few wireless devices that are g only.

Is that the problem? Does the router need to be set to only N for the N mode on the card to engage.

Thanks

tvete
Valued Contributor II
131 Views

Hmm. Did you enable WMM in the router (not the 7260 driver) settings? Make sure you enable that one in the router. Also make sure that your encryption is only WPA-2 Personal / AES.

I'm running my router on mixed mode too (b/g/n compatible). I know that if I disable WMM in the router settings, I won't get speeds higher than 54 Mbps.

RMyer2
Beginner
131 Views

OK, so I set the router on the 2.4Ghz network to N only mode, and I can not connect to the wireless card.

Security is WPA2 Personnal, Channel width is 20, N mode only, channel 11 so I had thought that this would auto connect me to the N band on the Dell wireless card. Not sure what to do next?

Thanks

RMyer2
Beginner
131 Views

Some good news applied a couple of windows updates and was able to connect g band to the 2.4 network and with speeds measuring about 54 Mbps. So the update must have done something.

I still cannot connect to the N band network. Dell told me to set the router to N only mode, and the card would auto connect, not so, no network could be found with this setting.

Looking at an advanced settings driver WEB intel post there appears to be 802.11n mode enabler selection but that option does not exist in my driver.

So how does one get this card to connect N mode????????

I can see N mode on the network status but the card only connects g.

tvete
Valued Contributor II
131 Views

Since you have Linksys EA6500, try enabling the 5 GHz band simultaneously with 2.4 GHz band. Keep the 2.4 GHz band in mixed mode while set the 5 GHz band to use AC mode (i.e. it can also be called 80 MHz channel width in the router). Also give a different SSID to the 5 GHz band. Let your Dell connect to the 5 GHz band and you should see speeds greater than 300 Mbps.

Jose_H_Intel1
Employee
131 Views

I agree with the suggestions above, http://www.intel.com/support/wireless/sb/cs-025343.htm channel bonding (wide channel) is recommended for 5 GHz (802.11ac). This is usually the default setting (auto) for the wireless adapter properties but you may need to verify the router settings too. Then, run this command in CMD: "netsh wlan show interfaces".

EWils1
Novice
131 Views

I know this is an old thread, but I've been determined to fix this issue of very slow speeds in a Dell XPS 15 9350 running Windows 10. I did a clean install of Windows 10 today to try to solve the problem, but nothing changed.

The Intel 7260 has both dual band AC wifi and Bluetooth onboard. It dawned on me that this might be related to the Bluetooth settings. Sure enough, I went into Settings and made like I was going to add a Bluetooth device. It searched for a while and found all my Bluetooth stuff. I didn't add a device, but the process of looking for a device added the Bluetooth symbol back to my task bar. With it running, the wifi speed on the 5G band to my ASUS router is clocking at around 450Mbps up and down (gigabit fiber service). I'm pretty happy.