Wireless
Issues related to Intel® Wireless Adapters and technologies
5974 Discussions

Intel(R) Wireless-AC 9560 160MHz; Code 10

Neo_Winter_Scott
Beginner
859 Views

Hi,

I have been having similar Code 10 problems to other users on this site, but I think my situation might be a bit different. My laptop model is an ASUS Q536F.

Every time I close the lid, sleep, or shut down my laptop, turning it back on produces a code 10 (with the same symptoms as other users), but I can resolve it by power cycling my computer. 
I have had this problem for a few months, and for a period of time, I had it fixed by doing either a BIOS update or a clean driver installation (I think it was the BIOS update, but I don't remember to be honest), but after a Windows update it broke again (and rolling back the update didn't help).

Recently, however, my power button on my laptop broke, and so the only way I have been able to force reboot my computer is by (1) restarting normally, (2) enter BIOS (3) lock wifi adapter; save and reboot (4) enter BIOS (5) UNLOCK wifi adapter; save and reboot, and then it will work again (as this power cycles the laptop). Since this is a kind of annoying process, I have been looking more seriously into fixing it. Clean installs on the drivers (multiple different versions of the driver) have not worked. Furthermore, ever since I have been having wifi problems, the Bluetooth has been unusable; I think the first time I solved this issue (this is my third time with it), I did so by uninstalling my Bluetooth device in the device manager, but that hasn't worked the past two times.

Thanks,

Neo

0 Kudos
4 Replies
Khun_Doug
Valued Contributor I
835 Views

Nep_Winter_Scott,

I can try to help, but I readily admit this seems to be slightly complicated. Looking over the SSU report, I see no Bluetooth device at all. I do see that you are using the latest BIOS and a newer wireless driver than what Asus has available.

What I would recommend is to download from the Asus support site the latest Bluetooth driver and networking driver, and also the latest wireless driver. Once you have the software available, I would then uninstall all of the network, Bluetooth, and wireless packages. Then install the network driver and the Bluetooth driver. If the wireless is not functioning, then install the wireless driver. But I recommend only using the software from Asus. The link to the download page is here: https://www.asus.com/US/supportonly/Q536FD/HelpDesk_Download/

The curious thing is on the download site, the network driver lists the 9560 device. It is possible the network driver is enough to get the wireless working without needing the wireless driver. Your install experience will tell the story on that.

The other thing I recommend is to try disabling Windows Fast Startup. It is possible all the hardware isn't being refreshed or initialized properly on startup/restart. You can find the controls for Fast Startup in Power Management. You will likely need to use the Advanced section of Power Management to access the setting for Fast Startup.

 

David_G_Intel
Moderator
752 Views

Hello Neo_Winter_Scott

  

Thank you for posting on the Intel️® communities. 

 

To resolve this, please share with us the following information:

  • Is this the wireless card that came originally installed in the computer?
  • Was the Bluetooth working properly before?
  • Drivers tested.

If you're willing to provide some reports for extra troubleshooting with us, please let us know and the information will be sent via email.

 

Regards, 

David G 

Intel Customer Support Technician 


David_G_Intel
Moderator
689 Views

Were you able to check the previous post?  

Let us know if you still need assistance.    


Best regards,  

David G.  

Intel Customer Support Technician  


David_G_Intel
Moderator
656 Views

We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.  


Best regards,  

David G. 

Intel Customer Support Technician  


Reply