Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7441 Discussions

Is it possible to enable monitor mode on linux for wifi the 6ghz frequency band on the AX210?

gen74
Beginner
5,177 Views

Hello,

Is it possible to enable monitor mode on linux for wifi the 6ghz frequency band on the AX210?
I'm using firmware iwlwifi-ty-a0-gf-a0-71.ucode, and driver core69 from backports on a
5.16.0-3-amd64 kernel.


I noticed the reg information changes when it gets placed into monitor mode. Below is how it looks when in managed mode:

# ip link set wlan0 up
# iw wlan0 scan >/dev/null
# iw reg get
global
country US: DFS-FCC
... (trimmed for brevity)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0 (self-managed)
country US: DFS-UNSET
... (trimmed for brevity)
(5945 - 7065 @ 1180), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, PASSIVE-SCAN
(7065 - 7105 @ 40), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN
(7105 - 7125 @ 20), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN


Now when I place it into monitor mode:

# ip link set wlan0 down
# iw wlan0 set type monitor
# ip link set wlan0 up
# iw reg get
global
... (trimmed for brevity)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0 (self-managed)
country 00: DFS-UNSET
... (trimmed for brevity)
(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5815 - 5835 @ 40), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN


# iw phy phy0 info
... (trimmed for brevity)
* 6975 MHz [205] (disabled)
* 6995 MHz [209] (disabled)
* 7015 MHz [213] (disabled)
* 7035 MHz [217] (disabled)
* 7055 MHz [221] (disabled)
* 7075 MHz [225] (disabled)
* 7095 MHz [229] (disabled)
* 7115 MHz [233] (disabled)

You will notice all the 6ghz frequencies are disabled or not displayed depending on the command.

Is there a way to enable these channels when in monitor mode?

Thank you

0 Kudos
8 Replies
Alberto_R_Intel
Employee
5,146 Views

gen74, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this scenario, we just wanted to confirm a few details about your system:

What is the model of the Intel® processor?

What is the model of the motherboard?

If this is a laptop, what is the model of it?

Is this a new computer?

When did you purchase it? / Did you build it?

Were you able "to enable monitor mode on linux" on this specific machine before?

If so, when did the issue start?

Did you make any recent hardware/software changes that might cause this problem?

The wireless card, did you purchase it separately or did it come installed on the computer?

Which Linux* version are you using?

Does the problem happen at home or in the work environment?

Please attach the SSU report so we can verify further details about the components in your platform, check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91600

https://www.intel.com/content/www/us/en/download/18895/26735/intel-system-support-utility-for-the-linux-operating-system.html?


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician



0 Kudos
gen74
Beginner
5,036 Views

> What is the model of the Intel® processor?
i7-6820HQ

> What is the model of the motherboard?
> If this is a laptop, what is the model of it?
Dell Precision 7510

> Is this a new computer?
No

> When did you purchase it? / Did you build it?
A couple of years ago

> Were you able "to enable monitor mode on linux" on this specific machine before?
No

> If so, when did the issue start?
n/a

> Did you make any recent hardware/software changes that might cause this problem?
no

> The wireless card, did you purchase it separately or did it come installed on the computer?
purchase separately


> Which Linux* version are you using?
debian, kernel 5.16.0-3-amd64, core69 backports. iwlwifi-ty-a0-gf-a0-71.ucode firmware

> Does the problem happen at home or in the work environment?
home

 

0 Kudos
Alberto_R_Intel
Employee
4,980 Views

gen74, Thank you very much for providing that information and the SSU report.


We will do further research on this matter, as soon as I get any updates I will post all the details on this thread.


Regards,

Albert R.


Intel Customer Support Technician


0 Kudos
Alberto_R_Intel
Employee
4,961 Views

Hello gen74, I just received an update on this matter.


While we are still working on this case, we just wanted to confirm:


Could you please re-run the command line '# iw list' and share the results?

Did you check directly with the WiFi Linux community about setting up monitor mode or package injection with those specific channels?

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

Please provide the exact version of the distribution and kernel being used from Linux*.


Regards,

Albert R.


Intel Customer Support Technician



0 Kudos
gen74
Beginner
4,868 Views

> Hello gen74, I just received an update on this matter.
>
> While we are still working on this case, we just wanted to confirm:
>
> Could you please re-run the command line '# iw list' and share the
> results?

I will list two, the first in managed mode, the second in monitor mode, you will notice in the
second, all of the 6ghz channels are disabled. I've attached them (they are torbig to fit inline).


> Did you check directly with the WiFi Linux community about setting up
> monitor mode or package injection with those specific channels?
>
> https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

I checked that web page, but it doesn't have any information as it pertains to the 6ghz channels. I
didn't see any issues with monitor mode or packaet injection on 5Ghz or 2.4Ghz channels, only 6Ghz.
I didn't seen any useful information in the community regarding these channels on the AX210 (or any
other product).


> Please provide the exact version of the distribution and kernel being used
> from Linux*.

: uname -a
Linux bear 5.16.0-3-amd64 #1 SMP PREEMPT Debian 5.16.11-1 (2022-02-25) x86_64 GNU/Linux

: lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux bookworm/sid
Release: testing
Codename: bookworm

After the initial problem, I tried using the latest firmware and driver at the time, which were
iwlwifi-ty-a0-gf-a0-71.ucode, and core69 respectivly from the following repos:

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git

Now that is what I'm currently running but it doesn't matter, the latest firmware and driver code
didn't make any difference.

Regards

0 Kudos
Alberto_R_Intel
Employee
4,844 Views

gen74, Thank you very much for letting us know those details and providing the report.

 

We will continue with our research on this matter, as soon as I get any updates I will post all the detail son this thread.

 

Regards,

Albert R.

 

Intel Customer Support Technician

 

0 Kudos
Alberto_R_Intel
Employee
4,765 Views

Hello gen74, I just received an update on this matter.


After reviewing the case, it is important to mention that when using Linux as Operating System, the Intel® wireless products are fully supported in station mode. As for monitor mode goes, the features and its support are limited, so it's expected that 802.11ac (uses OFDM) may function in monitor mode but 802.11ax(uses OFDMA) may not.


As an alternative, if by any chance your company is interested in developing monitor mode for your products, please get in contact directly and work with your Intel® representative.


You can also visit, register, and submit your inquiry on the Intel® Resource and Design Center website for further assistance on this matter: https://www.intel.com/content/www/us/en/design/resource-design-center.html 


Regards,

Albert R.


Intel Customer Support Technician



0 Kudos
jacob-ramey
Beginner
3,708 Views

I was able to get it into monitor mode and tuning to 6GHz channels properly on Fedora 35, kernel 5.14. I had trouble with ubuntu, unfortunately. 

[ 17.750723] iwlwifi 0003:01:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-64.ucode failed with error -2
[ 17.751640] iwlwifi 0003:01:00.0: api flags index 2 larger than supported by driver
[ 17.751710] iwlwifi 0003:01:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.0.2.25
[ 17.752260] iwlwifi 0003:01:00.0: loaded firmware version 63.c04f3485.0 ty-a0-gf-a0-63.ucode op_mode iwlmvm


Linux fedora 5.14.10-300.fc35.aarch64 #1 SMP Thu Oct 7 20:32:40 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

 

The trick to getting the channels to say enabled:

iw reg set US doesn't set the location for this card. It uses frames from a scan to determine location, then enables channels. Since you can only do this in 'managed' mode, do it when you start up then go into monitor mode.. i.e.

 

# put into managed

ifconfig wlan0 down

iwconfig wlan0 mode managed

ifconfig wlan0 up

 

# perform AP scan

iw wlan0 scan

 

# channels become enabled

 

# put back into monitor mode and do scanning

 

A first for me, but the reference was on twitter.

https://twitter.com/adriangranados/status/1529577592780640261?lang=en

 

 

 

 

0 Kudos
Reply