Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JLuke
Beginner
912 Views

New Fujitsu AH532/Win7 Centrino 2230 gets no or unusable signal

I recently got Fujitsu AH532 laptop with Centrino 2230 NIC. Even if I stand beside the AP, I never get full signal. If I try to use it than, the connection drops and is generally unusable. I've tried it with several accesspoints with the same results. If I walk further from the AP, I get no connection whatsoever.

If i plug cheap $5 802.11n USB stick from eBay, I get full signal and eventually really long rage.

I've heard about a guy with his AH532 having antenna disconnected from the factory, but it isn't my case.

There is a black antenna connected to "Main 1" and a gray one connected to "Aux 2". I've disconnected and reconnected them just to make sure there isn't a bad contact. It didn't help.

Anybody has idea, if the cables shouldn't be connected in the opposite order? I've read quite a lot from people having the same kind of trouble with this NIC in this forum.

What to do? I am sure the problem isn't in my Accesspoints. I have turned off powersaving features for the adapter.

I have the most recent drivers from Intel's site,

Tags (1)
0 Kudos
2 Replies
idata
Community Manager
81 Views

Thank you for your post.

Indeed the signal and speed should be maintained unchanged if you are in the same room and no furniture is in-between your laptop and the router and reasonable range. Not getting full signal while being next to the router is an indication of a hardware issue.

There is one setting that can affect the range and single strength, this is the transmit power. To access this setting go to device manager, double-click on "network adapters" double click on the Intel® Centrino® Wireless-N 2200 adapter then click on the 'Advanced' tab and set the 'transmit power' option to highest.

JLuke
Beginner
81 Views

Hi Nathalie,

my TX power is at maximum, that isn't the issue.

I'm now downloading newly released driver fromvhttp://downloadcenter.intel.com/Detail_Desc.aspx?ProductID=3507&DwnldID=22495&lang=eng&iid=dc_rss http://downloadcenter.intel.com/Detail_Desc.aspx?ProductID=3507&DwnldID=22495&lang=eng&iid=dc_rss.

I hope it helps.

BTW: the automated driver update check on your website didn't show this driver, i found it via google. The Driverupdate tool shows old driver from 2011 as the most actual version.

UPDATE: the driver download page, that it is 15.6... version, but it is the 15.4 in the installation. Nothing has changed, still the same.

Reply