Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7660 Discussions

Wireless 7265d repeatedly disconnects, then becomes unavailable until reboot in debian 11.7

Umbra
Beginner
1,071 Views

My wifi connection is normally stable, but then, without warning, will start stuttering. The card will show itself as restarting, which is confirmed via dmesg, but it never becomes stable again. Instead, after a highly variable amount of time, it will simply become unresponsive. It doesn't show itself as rebooting. dmesg stops showing any messages from iwlwifi, it just goes silent. Modprobe indicates that it's in use when trying to remove it, however no firmware shows up for the network card under lshw

I tried to use this post (https://community.intel.com/t5/Wireless/Wireless-7265-constantly-disconnecting-in-Ubuntu-20-04/m-p/1260967) to help debug, but it ended up not being a similar issue.

 

System information:

  • Hardware: Unaltered Asus ZenBook ux305f
  • Network Controller: Intel Corperation Wireless 7265 (rev 59) (shows up in lspci)
  • kernel version 5.10.0-23-amd64, which should support this card
  • iwlwifi and iwlmvm are both installed and loaded, and iwlwifi has definitely been initialized
  • lshw doesn't indicate any firmware is in use

 

The kernel log (dmesg) will show that iwlwifi says that there's a

  1. microcode software issue
    1. restarting 0x20000000
    2. status 0x00000050 (sometimes 0x00000040)
  2. a firmware error
  3. hardware error
    1. status 0x00000040

 

Several lines appear in the kernel log (dmesg) repeatedly, including: (All of these are pulled from iwlwifi messages in dmesg. Every single one)

  • Cannot send HCMD of  Phy DB cfg section
  • HW problem - can not stop rx aggregation...
  • failed to remove key ... from hardware (-5)
  • iwl_trans_wait_tx_queues_empty bad state = 0
  • selected rate control algorithm 'iwl-mvm-rs'
  • failed to read out thermal zone (-61)
  • HCMD_ACTIVE already clear for command TIME_EVENT_CMD
    • same as above but for commands
    • LQ_CMD
    • MAC_CONTEXT_CMD
    • STATISTICS_CMD
    • SHARED_MEM_CFG_CMD
    • BT_COEX_UPDATE_REDUCED_TXP
    • BT_CONFIG
    • ECHO_CMD
  • HCMD skipped: index (3) 35 2
    • numbers vary
  • Hardware error detected. Restarting.
  • Collecting data: trigger 2 fired.
    • Collecting data: trigger 15 fired.
    • Collecting data: trigger 16 fired.
  • Hardware restart was requested
  • FW already configured (0) - re-configuring
  • Applying debug destination EXTERNAL_DRAM
  • Failing on timeout while stopping DMA channel 8 [0xa5a5a5a2]
    • sometimes has other hexvals
    • [0x077d0001]
    • [0x077f0001]
    • [0x07fd0001]
  • Firmware error during reconfiguration - reprobe!
  • Failed to start INIT ucode: -110
  • Failed to run INIT ucode: -110
    • (or -5 sometimes)
  • Failed to start RT ucode: -110
  • mac start retry 0
  • direct-loading firmware iwlwifi-7265D-29.ucode
  • Found debug destination: EXTERNAL_DRAM
  • failed to load iwl-debug-yoyo.bin (-2)
  • iwlwifi transaction failed, dumping registers
  • 0x00000000 | ADVANCED_SYSASSERT
    • no other hexvals
  • FW error in SYNC CMD BT_CONFIG
    • PHY_DB_CMD
    • MAC_CONTEXT_CMD
    • REDUCE_TX_POWER_CMD
    • REPLY_BEACON_FILTERING_CMD

I haven't installed the debug drivers yet because I wanted to get as much info off the system as I could before rebooting it, but when I do I'll follow up with that. Attached is my (zipped) encrypted system logs (full kernel log, not limited to what dmesg outputs), as suggested by https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging. The SSU report is included in the zip. I had to double-wrap the zip so that the forums would let me attach the files.

 

When I posted this earlier, some things appeared to be misunderstood. All system logs are output from dmesg, as dmesg just access the kernel log. The issue is localized to the machine, as in it becomes unable to see any networks, and it will happen no matter if it is connected to a network currently or not. Running dmesg no longer shows messages from iwlwifi, because dmesg doesn't show messages from the entire history of the machine, just the most recent buffer of messages. Some of these were compiled using the more complete syslog file that my machine keeps.  I have access to a USB-Ethernet adapter, and that functions fine. The issue is not with my machine's general network capabilities.

 

Its important to note that the driver functions up until the crash, meaning that it gets initialized, and that iwlwifi is the one sending *all* of the above error messages (again, read via dmesg and the more complete syslog file).

This was initially posted here (https://community.intel.com/t5/Wireless/Wireless-7265d-repeatedly-disconnects-then-becomes-unavailable/td-p/1493042), but was closed because the iwlwifi driver was supposedly not initialized. I hope it is clear that it indeed has been.

0 Kudos
7 Replies
DeividA_Intel
Employee
1,044 Views

Hello Umbra,  


  

Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your Intel® Dual Band Wireless-AC 7265.  



In order to better assist you, please provide the following:  


1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?   

2. Is the Bluetooth working?   

3. What is your BIOS version?

4. Did you notice the issue after a system update? When did the issue start?

5. Have you tested the adapter with Ubuntu's latest version?



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Umbra
Beginner
1,038 Views

As mentioned in the system information, yes this is the same adapter that came with the machine. Yes, the Bluetooth adapter is working and scanning. It is able to connect to devices and transmit information. The BIOS version is UX305FA.206. This issue has been happening for a long time, at least a year. I unfortunately can't point to a single start date to the issue, but it's not impossible that a system update caused it. I have not tested it with Ubuntu's latest version, as I run debian and would rather not do a fresh install.

 

I appreciate the help!

0 Kudos
DeividA_Intel
Employee
1,025 Views

Hello Umbra, 


  

Thank you for the information provided 



I will proceed to check the issue internally and post back soon with more details. 


 

Best regards, 

Deivid A.  

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Employee
1,006 Views

Hello Umbra, 



Thanks for your patience. Before I proceed further, please test with the latest Debian stable kernel version and if the issue persists, provide the following:


1. Run the following commands and send us the outcome:  

· modinfo iwlwifi > If there is no output, then the module isn’t installed this is the distribution installation issue.  

· lsmod | grep iwlwifi > If the result is empty, the driver hasn't been loaded. Most likely to be a distribution issue.  

· To verify, please type: dmesg | grep iwlwifi > If the result is empty, the driver wasn’t initialized and this is a distribution issue. If there is a result populated, proceed with the next step.   

· dmesg | grep “No suitable firmware found!” > If the result is not empty, it means you don't have a suitable FW (api mentioned in the dmesg).  

· Please visit here: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi for supported FW, or here https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/ for the latest versions.  

2. If the above steps don't work, collect the debug data:  

Type: dmesg | grep ASSERT   


If the output is empty, please follow this wiki: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging to extract dmesg and trace-cmd.  


If the output has value, please collect it from the wiki FW dump too.  


  

Best regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Umbra
Beginner
993 Views

Hey, thank you for your help!

 

I'd really appreciate it if you read the post though, as all of this information is in the initial post, but I'll reiterate for you I guess.

With regards to the latest stable Debian version, the latest version actually changed five days ago as of today. When the issue happened last (I have yet to restart my machine), it was running the latest stable version at the time. The output of modinfo is attached to the initial post, as is the output of lsmod and lspci.

 

Regarding dmesg, this has been a recurring source of frustration. You all keep asking for dmesg output, but you don't seem to realize that it queries a buffer (i.e., the contents are not permanent) and doesn't reach back very far. Because this issue happened a while ago, there has been enough time that the buffer has emptied of the myriad messages that iwlwifi sent to the kernel. This means that, today, dmesg | grep iwlwifi outputs nothing.

 

However, before you claim that the driver was not initialized, the day that the issue happened, dmesg was chock full of messages from iwlwifi, and I have saved logs of that. If you read the initial post, that's what the massive chain of bullet points are from. Among those are many instances of ASSERT, and as such, I attached the entirety of my kernal log encrypted using the keys provided at https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging. 

 

Thank you for your time

0 Kudos
DeividA_Intel
Employee
983 Views

Hello Umbra, 



Thanks for the information provided. I will continue with the investigation and I will back to you in case I need further information or if I have any details for you.



Regards,  

Deivid A. 

Intel Customer Support Technician


0 Kudos
DeividA_Intel
Employee
938 Views

Hello Umbra, 



Thanks for your time. Based on the investigation perform, I recommend you as a workaround to try disabling the power management.



If the issue persists with this driver, you must check with Asus for further information and support.



Please keep in mind that this thread will no longer be monitored by Intel.  


Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Reply