Showing results for 
Search instead for 
Did you mean: 

intel centrino wireless n2230 on toshiba satellite p870 windows 8.1 cant connect

I have a 1 year old Toshiba Satellite P870 running windows 8.1 and have had no problems until connecting my new Galaxy Note 3 via usb which correctly installed its drivers etc and I was able to access the phone normally.

A week later I turned on the laptop and found that I could not connect to any WIFI.

A search of the Toshiba website for drivers does not list any drivers for the Intel Centrino wireless n2230 that shows in my Device Manager.

I called tech support and was told to install an Atheros driver which does not match my hardware and had no effect.

I have uninstalled the driver manually through device manager and downloaded both the Wireless_16.7.0_De164.exe driver only package and the Wireless_16.7.0_e164.exe full install package and also run the repair.

The website indicates the date for the driver release as 12/17/2013 and the driver version as 16.7.0

However after installation, device manager indicates the date as 8/22/2013 and the driver version as

It appears that the information on the website is in error and that the updated drivers are really older versions?

In any case every attempt to connect to a wireless connection yields 'Cant connect to this network'.

Yes I have checked and restarted the router, modem, computer, and verified the WEP key and tried multiple wireless connections and routers/locations that all worked before.

Running the Manual Diagnostic Tool passes all tests up to the Association Test which FAILS due to the fact that it cannot connect to anything and no further tests can run.

Toshiba is no help - they don't even list the device driver as one that comes with my serial number on their website.

Wired connection works fine through the Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30)

Subsequently to this issue I have intalled the following:

KEIS3Setip.exe from Samsung as well as the SAMSUNG_USB_Driver_for_Mobile_Phones_v1.5.33.0.exe

This has not affected the wifi connectivity either way. I have also applied all MS updates.


5 Replies

I am sorry for the issue. The correct driver version should be when using software package 16.7 with this wireless adapter and operating system. I recommend uninstalling Intel® Proset Software from Programs and Features as well as any trace of third party driver that are not intended for the devices installed in this computer. Then, install latest version again. Intel� Wi-Fi Products; Intel� PROSet Wireless Software driver versions by Operating System

Failing the association test could mean a mismatch between the wireless settings in the AP and the profile saved in the computer. Try deleting the profile and connecting again. You may also delete the profile and connect with the AP as unsecured just for testing. Intel� Wi-Fi Products; Understanding IEEE* 802.11 Authentication and Association Intel� Wi-Fi Products; Connect to your wireless network using Intel� PROSet/Wireless Software


Me again. Have to report that over the course of time the Intel centrino wireless n-2230 WiFi adapter fails to connect or intermittently connects to WiFi. STILL.

I have exhausted every option attempting to update, uninstall and or reinstall the drivers but have only spotty luck.

I really need someone to provide a procedure to uninstall all the drivers and do a fresh install.

Tried going into safe mode and removing device and deleting drivers, but on restarting the device comes back in device manager. Downloaded the latest driver from Intel, and did a fresh install and a repair. No joy.

Some things I have read seem to indicate that after doing a Windows 8.1 update you must install all driver updates in a specific order.... Not sure if that occurred now.. May be a contributing factor.

Have noted a great many posts online indicating similar issues with this WiFi adapter across many platforms. Seams to be a very well known problem, but I can't believe there is still not a reliable solution.


Honored Contributor II

Hello ksimmons1855,

Here are some instructions to get a clean install of your Wireless drivers:

1. Download the current version of your Wireless adapter drivers including Intel PROSet/Wireless WiFi Software, (you should also download the Bluetooth drivers), and save the files to your computer. You should use the OEM drivers as first option; in your case, you should be able to get them from Toshiba Support. If not, you can try with the generic drivers available from Intel® Download Center.

Current versions are 17.14.0 for WiFi and 17.1.1411.01 for Bluetooth.

2. Go to Control Panel - Programs and Uninstall Intel® PROset/Wireless Software. Also in Control Panel - Programs, Uninstall Intel® Wireless Bluetooth (if installed).

3. In Control Panel - Device Manager, go to Network Adapters, right-click on the Intel® Centrino® Wireless-N 2230, and select Uninstall, make sure to mark the option "Delete the driver software for this device".

Also in Control Panel - Device Manager, under Bluetooth radios, if it shows Intel® Wireless Bluetooth®, uninstall it selecting the option to delete the driver as well.

* After you uninstall them, do a "Scan for Hardware changes" or reboot. Check if the system installs any older driver versions for the Wireless and/or Bluetooth adapters. If it does, repeat the uninstall/delete until the Microsoft driver is used, or until no drivers are detected for the devices.

4. Install the Wireless Adapter driver you downloaded before; then install the Bluetooth® drivers as well.

If the issue persists, the problem may be in the Wi-Fi configuration, the router/AP, or due to external factors.


Toshiba wireless problem

Still having trouble with my Toshiba Satellite p870 with the centrino wireless n 2230.

My physical cable connection worked fine, just the wireless is troublesome. Works intermittently. Doesn't matter the environment it's in. Any router I try to connect to.

So followed your directions and has to go into safe mode to be able to finally remove the network adapter driver with delete option. And also deleted the Bluetooth drivers as suggested.

Rebooting normally or into safe mode and checking for hardware changes both end the same way.

No wired or wireless connectivity at this point, so have to use a thumb drive to transfer any drivers.

On device manager the system lists other devices; network controller and unknown device.

The network controller self identifies as Intel centrino wireless 2230 but the attempt to install the drivers automatically yields "the data is invalid".

The unknown device self identifies as generic Bluetooth adapter.... The data is invalid.

I downloaded wb-bt_17.1.1501.01_e64.exe

I get 'there is a problem with this windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.'

It then removes the files. I tried manually copying them to an alternate location and manually pointing the device manager to the files. No joy...

I then downloaded every possible option from Toshiba's website - non of which work either.

Seriously considering avoiding Intel wireless adapters forever after this 2 yrs long excursion into hell.


Honored Contributor II

We are sorry to know that you are having issues with your wireless connection.

Removing the drivers should be possible from a regular Windows* session, if you had to do it in safe mode, then it may indicate other type of issue in the system, further diagnostics would depend on the error shown when you tried to remove the components.

In order to install the driver again, please try downloading the driver only version of Intel PROSet/Wireless WiFi Software:

DRIVERS ONLY: wireless_17.14.0_De132.exe (if your OS is 32-bit) or wireless_17.14.0_De164.exe (if the OS is 64-bit).

If you are still not able to install the driver, try using the Intel® Driver Update Utility:

In this type of situation it is advised that you Contact our Support Center and engage a support agent to receive personal assistance using your prefered contact method.