Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4679 Discussions

Failed to launch vtune amplifier GUI

Enem
Beginner
2,321 Views

I can't launch my vtune-gui profiler(any version). I try to launch it with debug information from  cmd. And I get this message(on sreenshot).

I see the vtune's logo while 1 minute. After that it closses. What I tried to do? ping 127.0.0.1 - OK. netsh interface IPv4 show interfaces - OK.
My Laptop configuration: HP omen 15 dc-00008ur, i7-8750h, 32gb RAM. Also i tried launch vtune on PC with i7-7500, 8gb RAM - OK

Enem_0-1627246375614.png

Labels (1)
0 Kudos
1 Solution
Mariya_P_Intel
Moderator
1,702 Views

I understand your frustration, but please be patient. The suggested workaround is not so convenient as using vtune-gui "out of the box". But it would unblock the GUI usage while VTune developers work on the issue with high priority. You may also use your another PC with already working VTune GUI.


View solution in original post

19 Replies
AbhijeetJ_Intel
Moderator
2,240 Views

Hi,

Thank you for reaching out.

Could you please share with us the self-checker output to know whether the issue is related to installation?

To know more about self-checker, please refer: https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/installation/verif...

Also, could you try executing any of the vtune samples in command line.

To get detailed steps on executing the samples please refer: https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/introduction/tutor...

 

Regards,

Abhijeet

 

Enem
Beginner
2,232 Views
Enem
Beginner
2,214 Views

execute vtune sample in command line:

Enem_1-1627413975235.pngEnem_2-1627414008386.png

 

AbhijeetJ_Intel
Moderator
2,146 Views

Hi,

Thank you for sending the output screenshot.

Could you please attach the complete self-checker output as a text file so that we can analyze the issue from our end.

Regards

Abhijeet


Enem
Beginner
2,142 Views

Hi. Of course, take this

Enem
Beginner
1,990 Views
AbhijeetJ_Intel
Moderator
1,965 Views

Hi,

Thank you for providing the above information.

From the self checker files it seems that VTune installation have some problem.

Could you please try to uninstall the VTune profiler, delete all the associated files and again try to install it.

Use the following steps to uninstall Intel® VTune™ Profiler from your system:

  1. Open the Control Panel window and select the Programs and Features option.
  2. Select Intel VTune Profiler <version> from the program list.
  3. Select Uninstall/Change from the actions at the top of the table or from the right-click menu. A window opens with installer options.
  4. From the drop-down menu in the VTune Profiler section, select Remove.
  5. Follow the installer prompts to complete the uninstallation process.

https://software.intel.com/content/www/us/en/develop/documentation/vtune-install-guide-windows/top/u...

 

Download link: https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/vtune-profiler/download...

 

Regards

Abhijeet

 

Enem
Beginner
1,962 Views

I have already tried reinstalling the program (also as indicated in your instructions). It didn't change the state of affairs.

Enem
Beginner
1,960 Views

Right now I tried it again - to no avail

AbhijeetJ_Intel
Moderator
1,838 Views

Hi,

We are working on this internally.

We will get back to you soon with an update

Regards

Abhijeet


Mariya_P_Intel
Moderator
1,820 Views

Hi @Enem,

Could you please share additional details on the error?

  • What exact steps you do to "launch it with debug information from cmd"?
  • There is a strange "C:\Program Files (x86)\Intel\oneAPI\vtune\2021.5.0\-1" location on your screenshot.
    • Does it exist?
    • Is it referenced by some of environment variables? (Please provide the output of set | findstr -1 and set | findstr vtune commands)
  • Please provide the installer logs of vtune installation and of vtune re-installation from %tmp%\intel_oneapi_installer\<date-and-time>

Thanks, Mariya


Enem
Beginner
1,805 Views

1. vtune-gui --log-to-console --log-level=debug.

2.1. no, this file does not exist, but I suspect that this is some kind of error not on my part. Nick_F wrote about it here https://community.intel.com/t5/Analyzers/Can-not-launch-intel-VTune-Profiler-2021-2-in-Windows-10/m-...

2.2. 

Enem_0-1628635646240.png

Enem_1-1628635689540.png

3. (look in attached file)

Mariya_P_Intel
Moderator
1,775 Views

Thanks for sharing details.

Seems that vtune-gui failure happens if username contains non-Latin (e.g., Russian or Japanese) characters.

For further investigation, please provide the vtune logs from %tmp%\amplxe-log-<username>, OS version, and tell if <username> is Administrator or not.

As a workaround, please use vtune-gui under the user with Latin-characters name.


Enem
Beginner
1,759 Views

Windows 10 ver 21H1(build 19043.1110). My user (дом) is administrator. I tried changing the username by writing it in Latin letters and reinstalling. It turned out to be ineffectual.

Enem
Beginner
1,746 Views

the username as a folder has not changed (and as reported by Microsoft, it will not change https://answers.microsoft.com/en-us/windows/forum/all/how-to-change-username-on-pc-located-in-cusers -in / ed70f119-0dd3-422f-a3f9-6dcff3a2bcad)

Mariya_P_Intel
Moderator
1,724 Views

I would recommend not to rename the current user (due to Windows limitations), but to create a new local account and use it for running vtune-gui. Please check if it works for you.

Anyway, this case is reported to VTune development team and I will let you know when get any update from them.


Enem
Beginner
1,721 Views

I can not start the program because intel did not implement support for UTF-8 encoding and have to create a new account specifically for vtune? sounds very unpleasant and inconvenient

Mariya_P_Intel
Moderator
1,703 Views

I understand your frustration, but please be patient. The suggested workaround is not so convenient as using vtune-gui "out of the box". But it would unblock the GUI usage while VTune developers work on the issue with high priority. You may also use your another PC with already working VTune GUI.


Enem
Beginner
1,682 Views

creating a new user solved my problem, thank you very much for your help. hope to see the correct solution in the next updates!

Reply