Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
682 Views

Getting uC/Probe working with BeMicro SDK

I'm working through the BeMicro SDK tutorial, and I'm at Module 6: Instrument the Design using uC/Probe. I run through the setup in Module 6 with no problem, but at step 6.4, "Press the play button to begin the captures session," nothing happens. 

 

It isn't clear to me if the uC/Probe play button is supposed to start the program on the board, or if I should start the program from inside Eclipse (and uC/Probe just watches as it executes), or if there is something else that needs to happen to connect everything. Of course, I did try hitting Play in uC/Probe and then running in Eclipse, but nothing happens in uC/Probe. 

 

I'm probably missing something simple here. What should I be doing to get results to display in uC/Probe?
0 Kudos
4 Replies
Highlighted
Valued Contributor III
6 Views

I found the answer myself. The "Installation Utils & Issues to Avoid" folder had a document named uCProbe Setup - Fix.doc, which said the problem was that Quartus bin wasn't in the path. When I added it to the path, everything worked.

0 Kudos
Highlighted
Valued Contributor III
6 Views

Hi daloalt, 

 

May i know where is the path you add. Sorry about that as i can't find any document come with/inside the ucprobe installer. 

 

If possible, can you upload the Fix.doc as reference, as i really had no idea how to make ucprobe work. 

 

Thanks.
0 Kudos
Highlighted
Valued Contributor III
6 Views

A month late, but figured worth noting... 

 

I had the same issue and I couldn't find the document noted earlier either, but on another thread at: 

 

http://ez.analog.com/thread/11004 

 

I found this tidbit: 

 

“After installation add to the “Path” system variable the entry ”%QUARTUS_ROOTDIR%\bin\“ on the third position in the list”. 

 

In my case, I just added it to the QUARTUS entry at the of my Path and I was able to get everything to get the uCProbe numeric and scale monitoring of the temp sensor to work in the BeMicro SW lab (lab1.c). 

 

Hope this helps.
0 Kudos
Highlighted
Valued Contributor III
6 Views

Dear bbanyan, 

 

Thanks a lot for you information. Now I'm able to show the result on datascreen. 

 

It's really helpful. Thanks. 

 

Jayze ng
0 Kudos