FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5154 Discussions

"Can't recognise flash attached to device 2" Error 18591 : Brand new Arria 10

KSmil
Beginner
847 Views

I have a brand new Arria 10 FPGA dev kit. I have set all the switches appropriately, according to the User Guide. When using the Quartus Programmer I get the following error after autodetecting the device:

 

"Can't recognise the Flash device that attached to device 2. The Flash device is not supported by Quartus Prime software" Error 18591

 

I am able to use the Board Test System software provided (program the device with the GPIO/Flash sof file, for example).

 

Thanks,

 

Karl

0 Kudos
5 Replies
SreekumarR_G_Intel
298 Views
Hello Karl , Can I know what version of the Quartus software you are using to program ? Here is the couple of the things you can try .. i) Changing the frequency of the JTAG ii) Can you bypass all the devices expect the Arria 10 and try the same for now ? Thank you, Regards, Sree
KSmil
Beginner
298 Views

​Hi Sree,

 

I seem to have let your reply slip past me - apologies.

 

I am still getting the same error message with a JTAG frequency of 6M or 24M.

 

I am able to program the Arria 10 directly with a SOF file but as the software can't identify the Flash I'm unable to program it with a POF.

 

Thanks,

 

Karl

SreekumarR_G_Intel
298 Views

Hello Karl,

Sorry i didnt get the notification either from your post update. i

Are you using the eval board ?

 

Thank you ,

 

Regards,

Sree

KSmil
Beginner
298 Views

Hi Sree,

 

Yes, it is the FPGA eval board I am using.

 

Thanks,

 

Karl​

SreekumarR_G_Intel
298 Views

Can you check the Board bypass setting ? I remember i saw in hw board having options to by pass the flash etc , iam not sure here what will be the problem ..I do have Arria 10 SOC kit and GX kit ..both working fine and i am able to access the same .

Hope we are missing some setting .

 

Thank you ,

 

Regards,

Sree

Reply