Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mikabrown
Novice
10,992 Views

Iris Xe and AWS Workspaces

Have an issue with the AWS Workspaces client on my HP laptop with 11th Gen i7-1165G7 / Iris Xe.  In the end it feels like a driver issue...

The login screen for the app does not show my input, but if I blindly enter username/pw, it will log in.  Then the main desktop screen is just black.  Occasionally a portion of the screen will become visible if I move things around / minimize / maximize.

I found similar issues for 11th Gen Iris Xe reported with Citrix and Logos apps.  Suggested from Logos was to disable acceleration for WPF applications via registry: HKCU\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration : 1

This immediately solved the problem, but disabling acceleration doesn't seem like a long term fix.

Tried with Intel driver version up to this weeks  27.20.100.9126.

Tried with Workspaces version up to current 3.1.2.  

So is this a know issue with the Intel drivers and the 11th Gen Iris Xe? Or more with the app?

Thanks!

Mika

 

 

0 Kudos
41 Replies
Maria_R_Intel
Moderator
6,677 Views

Hello mikabrown,


Thank you for posting on the Intel* Community.


We do not have reports of this yet to consider it as a known issue from Intel, but to better assist you and investigate, please provide us with the below information:


  • Can you please provide pictures or a video to check the issue?


 

Provide the Intel® System Support Utility (Intel® SSU) 

 


Best regards,

Maria R.

Intel Customer Support Technician


Imtiyaz
Beginner
6,665 Views

Hi,

I am also facing similar problem, I can connect to Amazon AWS from my other machines and laptop with older configuration, but the latest configuration laptop just displays black screen.

 

mikabrown
Novice
6,637 Views

Here's t he SSU and a screenshot.

Maria_R_Intel
Moderator
6,652 Views

Hello Imtiyaz,


Thank you very much for reporting this. I will check the information and let you know if the best course of action will be to create a new thread for you, for more accurate support, please expect my response soon.


Best regards, 

Maria R.  

Intel Customer Support Technician 


Maria_R_Intel
Moderator
6,650 Views

Hello mikabrown,


Were you able to check the previous post?

 

Let me know if you need more assistance.

 

Best regards, 

Maria R.  

Intel Customer Support Technician 


Maria_R_Intel
Moderator
6,611 Views

Hi!


Thank you very much for the information, we will proceed to check this internally and post back soon with more details.


Best regards,

Maria R.

Intel Customer Support Technician


mikabrown
Novice
6,533 Views

Any update on this - I'm now finding the same issues running TurboTax as I was in AWS Workspaces.  And the issue is being reported by other users with 11th Gen Iris Xe and Microsoft WPF:

https://proconnect.intuit.com/community/proseries-tax-idea-exchange/homebase-view/idi-p/108218

Most common issue still appears to be in pop-up windows (like for login and product registration) that are blank or the info in them is hung and does not respond, but you still enter the info - you just don't see any changes visually.

Thanks!

mikabrown
Novice
6,531 Views

More developers reporting the similar bug with 11th Gen Iris Xe and WPF:

https://github.com/dotnet/wpf/issues/3817

https://support.verbum.com/hc/en-us/articles/360052835211-Display-problems-on-11th-gen-Intel-process...

Just wondering - is Intel aware of this?

Maria_R_Intel
Moderator
6,502 Views

Hello mikabrown,


We are still working on this internally. Thank you very much for your patience and understanding, also for the reports that are very helpful for us.


Please, expect an update soon.


 

Best regards, 

Maria R.  

Intel Customer Support Technician 


JuniorJr
Novice
6,396 Views

Yeah, same issue here.

Black screen, but I know 'things' are going on in the background. I can see the cursor change to resizing cursor and when I drag, then connect form another device, I see that my window resize did occur, but I just can't see it (when connected w/ a Surface Pro+ device.  It's "alive" but just all black.

Mickey7
Beginner
6,034 Views

I have been having the same issues as everyone else. I am wondering if there is any update from the Mod's post on 1/24 as that's been over 3 weeks ago?

mikabrown
Novice
6,023 Views

No update from Intel.  No new drivers released either. 

For those trying to survive with this :  For some of the apps like TurboTax, there's only a few popup windows that are impacted by the issue...  For those windows, if I drag them back and forth between my displays they refresh so I can see what I blindly typed...

JuniorJr
Novice
6,018 Views

After having more issues with other apps and dialog boxes in addition to my black AWS Workspaces screen... I just returned the Surface Pro 7+. 

Can't deal w/ that, and I really wanted to keep it, but this was a dealbreaker.  Couldn't do my work and lack of Intel getting on this quickly was it for me. Many others in my company w/ the same issues (with Workspaces). We've gotta run a business.

newmindtim
Beginner
5,935 Views

We are having this issue in our software as well. Our only option until Intel provides an update is to detect the video controller and force the ProcessRenderMode to SoftwareOnly.

RonaldM_Intel
Moderator
5,904 Views

Hello everyone,

I would like to let you know that this issue has been filed as a bug with our driver development team (bug ID# 14013495876). I cannot promise any particular outcome or ETA yet, but as soon as there is any news or update I'll be posted here.

Thank you for you patience.

Best Regards,

Ronald M.

hhugh
Novice
5,245 Views

Please provide an update on this urgent issue which renders many products unusable unless hardware rendering is disabled. This has been well documented since at least November - almost 4 months. (See https://github.com/dotnet/wpf/issues/3817)

Is there a link where we can view the status of this bug id 14013495876?

mikabrown
Novice
4,240 Views

Been 2 full months since I reported this and 4 months since it was first reported.  It's not like this is an isolated issue - reports from HP, Dell, Lenovo, MS Surface just in this thread.  There's been nearly a dozen releases of drivers for this card since the issue was reported:

https://downloadcenter.intel.com/download/30266/Intel-Graphics-Windows-10-DCH-Drivers

Would seem like a pretty trivial driver fix for Intel - especially when software developers are able to brute force their way around it and end users can turn off acceleration to mitigate most of the issues.  

But all the driver release notes only tout optimizations for a string of games (great if you are playing Fortnite).  Would seem like a major driver issues with software developed on a Microsoft framework would rank a little more attention.

Intel - you can do better...

 

RonaldM_Intel
Moderator
4,226 Views

Hi everyone,

The latest news on bug ID# 14013495876 is that our driver dev team was able to replicate the issue and it is now under debugging process. 

As soon as there is further updates I'll update this thread.

Regards,

Ronald M.

mikabrown
Novice
3,868 Views

For those still struggling with this issue for AWS Workspaces - 

AWS decided the issue was big enough to disable all HW acceleration by default in the latest 3.1.4 release.

https://docs.aws.amazon.com/workspaces/latest/userguide/client_troubleshooting.html#screen_artifacts

https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-windows-client.html#window... 

I tried the latest 3.1.4 and it resolved my issue.  I have other programs built on the same MS framework that also have issues, so still have to use the Avalon.Graphics hack in general until Intel addresses.

 

StefanBalbo
Beginner
3,517 Views

Thank you for addressing this issue.

This is becoming really urgent for us. We have now seven customer sites reporting blank sign in dialogs on this GPU. 

Stefan

Reply