Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
18036 Discussions

Most games (not all) don't appear to be utilising laptop discrete GPU

FatBarry
Novice
856 Views

Repost of an issue I'm trying to resolve on Reddit/Nvidia forum/Microsoft/Dell forum:

  • Status: UNRESOLVED
  • Computer Type: Laptop - Dell Inspiron 7577
  • GPU: Intel HD Graphics 630 (Integrated) / GTX 1060 Max-Q - 6144 MB GDDR5, no overclock
  • CPU: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
  • RAM: 16GB, DDR4, 2400MHz
  • PSU: Laptop - I am running on power, not battery
  • Operating System & Version: Windows 10 64-bit 21H1
  • GPU Drivers: 496.13, upgrade from 462.xx

Description of Problem:

Recently reinstalled/clean reset (aka Fresh Start) of Windows. Running Diablo 2 Remastered fine, no problems (steady high framerate), but any other game that is remotely demanding or requires the GPU (Pillars of Eternity 2, Kingdom Come Deliverance, Unreal Tournament - the 1999 one...), I'm getting FPS in the range of 2 FPS to about 10 FPS. These are games that, prior to system reset, were steady on 60 FPS+, depending on the game. I initially thought this was a Pillars of Eternity 2 problem, but having tried other games, it is more widespread - except for Diablo 2 Remastered. From what my eyes can see, the graphics don't look like they are using the GPU (lots of pixellation along edges, etc.), but according to Task Manager, GPU 1 is being utilised. However, I've not seen total system utilisation of the GPU, RAM or CPU exceed about 50%.

Troubleshooting:

  • Clean install of drivers > no change
  • Clean install of drivers using Wagnard DDU > no change
  • Moving games to the SSD from the HDD (currently Diablo 2 is the only game on SSD) > no change
  • Using Windows 10 Graphics Options to set GTX 1060 as preferred GPU > no change
  • Enabling GPU Scheduling > no change Switching to a "High Performance" power plan (still on power not battery) > no change

 

Switchable graphics / Optimus seems to be working fine (games are switching between GPU 0, GPU 1). Intel Graphics Command Centre doesn't seem to recognise the other GPUs:

 

intel.png

(One of those unknowns is Citrix virtual, the other is the GTX 1060)

 

I've tried several steps from other forum posts:

  • Wagnard DDU fresh driver install with manufacturer (Dell) driver package
  • Using Windows Graphics settings to set preferred GPU
  • Using Nvidia Control Panel to set preferred GPU

The issue is not that the GTX 1060 isn't being utilised - it is, and switchable graphics seems to be working. But utilisation is far below what I would expect in most cases. See below:

1. Pillars of Eternity II: Deadfire - a scene with a lot of geometric detail, character models and lighting. Framerate = about 2-3 FPS. Game has been reliably switching between GPU 0 (Intel HD Graphics 630) and GPU 1 (GTX 1060). However, max GPU 1 utilisation is about 6%-8%, where it was previously (before Windows 10 reinstall) sitting up at around 50%-60%.

pillars.png

 

2. Kingdom Come: Deliverance - The main menu, which has a live backdrop with a lot of geometric detail, foliage and foliage effects (bushes swaying in the breeze, etc.). Framerate = about 2-3 FPS. Game also switches between GPU 0 and GPU 1 on loading, but GPU 1 utilisation is capped at about 10%-12%.

kcd.png

3. Diablo II Resurrected - A scene with a lot of lighting effects, a lot of character models and movement and physics effects. Settings for the game are almost maximum. Framerate = 60-70 FPS. GPU 1 is being utilised as expected - around 60% - 70% depending on load, and is switching back to GPU 0 when load reduces (menu, loading screens, etc.)

d2r.png

So, from my perspective:

  • Intel HD Graphics 630 doesn't seem to be recognising other GPUs
  • There is a rendering/utilisation issue with the GTX 1060

I am also engaging with Microsoft, Nvidia and Intel support, but have had limited responses. Microsoft has advised that this issue is possibly related to switchable graphics not functioning properly.

0 Kudos
1 Solution
Stefan3D
Honored Contributor II
791 Views

"In regards to this behavior, Intel Graphics Command Center shows non-Intel discrete cards as "unknown", we would like to inform you that Intel® is aware of this and the cause for this issue is being currently investigated. A fix will be included in the next Intel Graphics Command Center release."

Source: https://community.intel.com/t5/Graphics/Graphic-processor-undetected/m-p/1321518#M101655


Regarding the utilisation problem i would guess that Citrix virtual confuses NVIDIA Optimus which already is a picky technology by itself.

View solution in original post

4 Replies
FatBarry
Novice
814 Views

Would love some support....

Stefan3D
Honored Contributor II
792 Views

"In regards to this behavior, Intel Graphics Command Center shows non-Intel discrete cards as "unknown", we would like to inform you that Intel® is aware of this and the cause for this issue is being currently investigated. A fix will be included in the next Intel Graphics Command Center release."

Source: https://community.intel.com/t5/Graphics/Graphic-processor-undetected/m-p/1321518#M101655


Regarding the utilisation problem i would guess that Citrix virtual confuses NVIDIA Optimus which already is a picky technology by itself.

FatBarry
Novice
784 Views

I'll try uninstalling Citrix, however I had it installed prior to my Windows 10 reinstall without issue.

 

I've uploaded a couple captures to YouTube to show you an example of what I mean.

 

Ghostrunner running with Direct X 12 (using the -dx12 launch argument):

https://www.youtube.com/watch?v=4TwMm6iawmI

 

As you can see above (apart from a couple slow downs due to the fact I'm recording in OBS Studio), its pretty darn smooth. GPU utilisation is high and steady, and using GPU 1 - 3D (which is the GTX 1060)

 

Ghostrunner running with Direct X 11 (the "standard" launch option):

https://www.youtube.com/watch?v=F9Z9Q5THZ-E

 

As you can see in this video, FPS is garbage - though not always. When there aren't many light sources, FPS jumps up again. But most notably: GPU 1 - 3D is still being utilised, but utilisation is way down (< 15%).

 

I'm also cross-posting this to Nvidia support (it seems like it could be an Nvidia problem too). I still haven't heard from them, but if I do, I'll post it here. Thanks for your help so far.

FatBarry
Novice
767 Views

I use Citrix for remote work from home. Citrix installs a "Citrix Indirect Display Adapter". When I uninstalled Citrix and restarted, the problem was resolved, and all games started utilising my GPU again.

 

It appears that the GPU priorities were all messed up, and that was the cause of the issue. I'm guessing this is something governed by the Windows registry.

 

I don't know why I didnt have this issue previously (Citrix was also installed prior to my Windows 10 reinstall), but uninstalling Citrix fixed the problem. I guess I'll have to come up with some sort of solution for work from home now...

 

Thanks for your help, lifesaver.

Reply