Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AOCon1
Beginner
688 Views

Why am I unable to launch several games while the driver is installed? (Intel HD Graphics 4000)

Starting sometime last week or so (mid-February 2019) I am no longer able to launch several games on my PC. The confusing thing is that if I uninstall the Intel Graphics Driver, these games are all able to launch!

 

The problem

Several of my games can't launch. For some games, the window appears for a split second then instantly closes (this is the case for all Valve Source Engine games). For others, an error message appears.

For Just Cause 2:

JC2Error.PNG

 

For Terraria:

Terraria.PNG

 

For Metro 2033:

Metro.PNG

 

What I've done so far

This is the information found on dxdiag:

dxdiag1.PNG

 

dxdiag2.PNG

 

By the way, I realize the driver information in the upper right is out of date. This is because I tried rolling back to a previous version to see if that would help, which it did not.

To roll back to the previous version, I uninstalled the driver via the Add/Remove Programs method described here: https://www.intel.com/content/www/us/en/support/articles/000005598/graphics-drivers.html

 

After uninstalling the driver, I attempted to run the games again and found, surprisingly, that they would launch without error. However, without any Intel drivers installed, they tended to run at sub-10FPS at lowest settings (whereas a few months ago, depending on the game of course, I could often get close to 30 FPS on low or medium settings).

I tried reinstalling the newest driver, but the errors returned. I then tried uninstalling that driver at a later date, and was able to launch the games again. I've tried installing older driver versions, but they produce the same results.

To reiterate, I have been able to launch all of these games without issue before. The performance has never been great, since my laptop is pretty old at this point, but they would at least launch. I have tried restarting my PC multiple times.

Thank you for reading through this, I will appreciate any help.

0 Kudos
3 Replies
Alberto_R_Intel
Moderator
109 Views

AOCon1, Thank you for posting in the Intel® Communities Support. We recommend to install the graphics driver provided by the manufacturer of the computer, since that driver was customized by them work with your specific platform. I looked on Dell's web site and I found that there are 2 graphics drivers available, one of them if for AMD* and the other one for Intel®, please try to install both graphics drivers: AMD version 15.201.1101 ,A01: https://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverid=6ykw1&oscode=wt64a&produc... Intel® version 10.18.10.4242 ,A00: https://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverid=rrdd3&oscode=wt64a&produc... If the problem persists, since the processor works with Intel® HD Graphics 4000, we can always try to install the Intel® generic graphics driver version 15.33.47.5059: https://downloadcenter.intel.com/download/28164/Intel-Graphics-Driver-for-Windows-15-33-?product=814... Please provide the SSU report in order to confirm which is the graphics controller that the laptop is working with: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility To attach the file, once you choose "reply", select the "clip" icon on the lower left corner. Regards, Alberto R. Intel Customer Support Technician Under Contract to Intel Corporation
AOCon1
Beginner
109 Views

Hello, Alberto. Thanks for looking into my question. Unfortunately, neither the generic Intel driver nor the one provided on the Dell website solve the problem. Also, the AMD driver seems to have no effect- the installation completes and a message appears saying it was "successful," but everything acts as it does when no driver is installed. Device Manager still lists the display adapter as the "Microsoft Basic Display Adapter," which is what it does after uninstalling a driver (when an Intel driver is installed, it's shown as "Intel (R) HD Graphics 4000"), and features such as being able to use multiple monitors are not supported. Also, when trying to use dxdiag, it caused my computer to crash and restart, providing the error code VIDEO DXGKRNL FATAL ERROR. Thankfully, this particular issue only applies to the AMD driver, and I can still use multiple monitors and dxdiag when using any Intel driver.

 

I tested the AMD driver last, and after doing so, I updated the driver via the Device Manager menu using the automatic updater, which has installed an Intel driver. This is the state in which I ran the System Support Utility, the log of which is attached here.

 

As far as I'm aware, the driver issue is only affecting video games; I can always sit down with a good book instead. Thanks for trying to help!

Alberto_R_Intel
Moderator
109 Views

AOCon1, You are very welcome, thank you for sharing those details. The issue seems to be related to a compatibility problem between the games and the Windows* version installed. Since the games are not that new, most likely they were designed to work with Direct X version 10 or 9C, at the moment when you install Windows* 10 Direct X version 12 gets installed automatically, according to some reports the Direct X version 12 is not backwards compatible with versions 9C or 10, that is why the games are not launching. There might be a work around to make it compatible or to install the files missing manually, but that is something that you will need to check directly with Microsoft* or with the game developer. In the following link you will find some suggestions that we can try in order to try to run the games: https://www.intel.com/content/www/us/en/support/articles/000030981/graphics-drivers.html Regards, Alberto R. Intel Customer Support Technician Under Contract to Intel Corporation
Reply