Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1082 Discussions

Hi, I tried to apply the stimuli using modelsim to the sequential adder that I described in vhdl. In particular:

MPitt3
Beginner
587 Views

1) I tried to generate the clock signal like this (with create wave): here is the screenshot:create_wave.png

 

But doing so it does not work,

 

 

num1 is the first number to be added

num2 is the second number

s, the result always fixed to zero

rst is the reset active low 

 

create_wave2.png

here is the result of the simulation:

 

 

2) I generated the clock like this :

clock1.png

clock.png

Now the result is correct.

 

Why in the first case is it wrong? Thanks a lot .

 

0 Kudos
1 Solution
Vicky1
Employee
185 Views

Hi,

Thanks for the details.

Why don`t you use latest Free Quartus(Lite) & Modelsim starter versions?

http://fpgasoftware.intel.com/18.1/?edition=lite&platform=windows&download_manager=dlm3&product=mode...

I would like to suggest you, try at your end with latest versions also as mentioned vector waveform in previous post.

I am looking forward to listen you.

Thanks,

Vicky

View solution in original post

4 Replies
Vicky1
Employee
185 Views

Hi,

Which modelSim edition & version are you using?

would you like to provide project files archive?

Please check the links below & if possible try at your end & let me know how it works for you.

https://www.youtube.com/watch?v=7yKO3PFNiMQ

https://www.youtube.com/watch?v=a8JAkKhxlQI

Regards,

Vicky

 

Vicky1
Employee
186 Views

Hi,

Thanks for the details.

Why don`t you use latest Free Quartus(Lite) & Modelsim starter versions?

http://fpgasoftware.intel.com/18.1/?edition=lite&platform=windows&download_manager=dlm3&product=mode...

I would like to suggest you, try at your end with latest versions also as mentioned vector waveform in previous post.

I am looking forward to listen you.

Thanks,

Vicky

MPitt3
Beginner
185 Views

 

Thanks a lot !!

I solved, the result is now correct as you can see from the photo with the new version of the software !! We see that the old version had some problems ... thanks again really

 

 

 

 

correct.png

Vicky1
Employee
185 Views

Hi,

Glad to know that our suggestion helped to resolved your issue.

Thanks,

Vicky

Reply