Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

oneAPI command line

Rodrigues__Pedro
Beginner
1,508 Views

I started command line from oneAPI prompt and ifort and icl aren't on the path. 

Is this an issue(bug)?

 

0 Kudos
1 Solution
Steve_Lionel
Black Belt Retired Employee
1,266 Views

To see everything, do a:

set path > path.txt

and attach path.txt to a reply here.

To edit system environment variables in Windows 10, click the Start button, then Settings (gear icon). Click System, then About. Scroll towards the bottom and select Advanced System Settings. Click Environment Variables.

Scroll down to Path under System variables, select it and click Edit.

I don't recommend doing this blindly - you can render your system unusable. Let's see the path.txt from the set command first.

View solution in original post

25 Replies
mecej4
Black Belt
1,165 Views

Which packages did you install? Did you install just the base OneAPI toolkit, or did you also install the HPC toolkit? Open the Windows Programs and Features control panel. Do you see the OneAPI compilers listed in it?

Rodrigues__Pedro
Beginner
1,155 Views
Yes. I have both installed
Ron_Green
Moderator
1,148 Views

What about 'icx' and 'dpcpp' are those found?  Just try

icx -V

dpcpp -V

and also try

ifx -V

 

You can try to uninstall the HPC Toolkit and try to re-install it.

Rodrigues__Pedro
Beginner
1,137 Views

nothing. also mpiexec isn't found. It seems that nothing is set. nor the compiler nor mpi or mkl

Steve_Lionel
Black Belt Retired Employee
1,128 Views

I am unsure what you mean by "started command line from oneAPI prompt". What exactly did you do? Which OS is this?

If you simply started a command prompt session, then this is expected behavior. In order to get the compilers added to the executables path, you have to invoke the compiler's setvars script. The Windows install adds a shortcut to the Start menu to do this, or you can call setvars.bat yourself. I'll also comment that on Windows, if you're using Powershell instead of cmd.exe, this won't work. See Solved: ifort not recognized as an internal or external command - Intel Community for more info.

 
Rodrigues__Pedro
Beginner
1,125 Views

I am on WIN10 with VS2019. I used the oneAPI command line shortcut added after the installation. I also called setvars.bat and nothing.

Rodrigues__Pedro
Beginner
1,121 Views

I suppose that setvar script doesn't have the lines to add:

 - ifort;

 - icl;

 - mpiexec;

 -  MPI library path(.lib and .dll);

 - MKL library path (.lib and .dll);

how can I change the script to add these?

 

 

Steve_Lionel
Black Belt Retired Employee
1,107 Views

You don't need to modify setvars.bat.

Please show a screenshot of the command prompt window from the start where it opens and when you type "ifort".

Rodrigues__Pedro
Beginner
1,098 Views

see the image attached

Steve_Lionel
Black Belt Retired Employee
1,092 Views

Thanks for the image. The problem here is the error about "findstr", that is aborting the setvars. As best as I can tell, this is coming from some component other than the compiler calling a sys_check.bat file which invokes Python to do a "findstr". I see that some of the oneAPI components require that Python be installed (the compiler does not.)

See if installing the latest Python (from python.org) resolves this. If not, perhaps one of the Intel support people will pick this up.

 
Rodrigues__Pedro
Beginner
1,087 Views
I have Python. Os this a VS2019 conflict?
Steve_Lionel
Black Belt Retired Employee
1,081 Views

Nothing to do with VS2019. Let me suggest this. Run the oneAPI Base installer again. When it lets you select which components are installed, uncheck all but "Intel Distribution for GDB", let it finish and see what happens when you try again.

One of the Base components is giving an error in its setup, but it isn't a component I have installed so I can't tell which one it is. It isn't the compiler, that much I can tell you.

If you have support, open a ticket at Online Service Center  Otherwise, hope that one of the support reps picks up on this and helps you.

 
Rodrigues__Pedro
Beginner
1,060 Views

Got the same: see attached file.

mecej4
Black Belt
1,055 Views

findstr is a standard Windows command utility. If it cannot be found, the implication is that an earlier step in the installer script (or other batch scripts that the installer script called) corrupted %PATH% and, as a result, the findstr command is no longer accessible.

Ron_Green
Moderator
1,052 Views

on that command window, do this and send us the output

echo %PATH%

 

the PATH environment variable is of fixed number of characters.  If you have a LOT of installed software it's quite possible the character limit was exceeded.  You mentioned some possible conflict with older versions of PSXE.  How many PSXE versions do you have installed?  Could you remove some apps?  But first let's see that PATH.  We suspect it may be over the character limit and it's truncated, missing some key paths.

Rodrigues__Pedro
Beginner
1,047 Views

attached the $PATH to the file

Rodrigues__Pedro
Beginner
1,007 Views

I don't have any more PSXE installed. What is missing on the PATH var?

Steve_Lionel
Black Belt Retired Employee
1,001 Views

You're missing "C:\Windows\system32;C:\Windows;C:\Windows\System32" at a minimum. Windows\System32 is where findstr is located, and missing those will cause a lot of problems.

The inclusion of ' ' in your path is troubling - it should be removed. Do you know how to edit system environment variables?

After removing that, reboot and try again.

 
Rodrigues__Pedro
Beginner
995 Views

Windows GUI (ENV vars)  doesn't show all the path. The oneAPI path is loaded at command and has a lot more keys. So, I don't know how where to change it outside the oneAPI prompt. Can you help?

Rodrigues__Pedro
Beginner
816 Views

I removed " " from the $PATH var using windows GUI for that. Do I have to add m ore keys there? Which?

Reply