Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12757 Discussions

LED lights on HADES Canyon not working after BIOS update


I used Intel Driver and Support Assistant to update BIOS and drivers to NUC8i7HVK4 after system rebuild.

Now no LED's working at all, completely dark. (Skull, power and status lights)

Followed suggested steps:

  1. Made sure the Software LED control is enabled in BIOS: 
  2. checked that LED lights were disabled from the Tray Application, LED Manager for Intel® NUC. Please attach a picture of the settings you have applied to your Intel® NUC.
  3. Checked that the LED Manager for Intel® NUC Service is installed and running. 

If left alone long enough the skull will flash in some sleep mode (proof LEDs still physically connected).

Tried disconnecting everything waiting 30min and rebooting.

No progress, suggestions?



167 Replies
Super User Retired Employee
In BIOS Setup, disable software control, save and reboot. If this works, go back to BIOS Setup and re-enable software control.
May also want to reinstall latest BIOS using jumper-based BIOS Recovery.
Hope this helps,

Attempted to disable software control via BIOS and rebooted without success.

I have just performed  a jumper base BIOS recovery without success.

No changes to symptoms.

No LED lights unless I leave it running for an extended period then the skull LEDs flash while it is sleeping.

Do you have anything else to try?

Thanks, Scott

Super User

Hi @ScottyP 

I would try this:

If you didn't yet, disconnect the CMOS battery and reconnect it after few minutes (disconnect also the Power Adapter).

Reset BIOS to default settings (F9 (Y), F10(Y).





New Contributor I

You are not alone:

It seems that Intel messed something up. Quite annoying without the LED lights.

I hope that there will be a fix soon.


I have tried all suggested options multiple times including disconnecting the CMOS battery.

LEDs on my HADES only work when system goes in to sleep mode.

When does INTEL forecast a fix for this BIOS problem?

Thanks, Scott

Has any one heard any stories of specific monitor incompatibilities causing this kind of problem?


New Contributor I

After having tried all suggested instructions the problem still persists. Really really frustrating.

My recommendation: Do not install the latest BIOS!


I am thinking about openning a warranty case, which is somewhat stupid, since it seems to be a software related problem. But what else can I do?


Hello all,


Thank you for reporting this.


Please try to use the settings shown on the image attached:


>F2 to get into the BIOS


>LED control

>Uncheck the "LED Zone Controls"

> In the "LED Color adjustments" use: Manual-User defined.


*Refer to the image.


Please, let me know the outcome.


Best regards,

Maria R.

Intel Customer Support Technician




New Contributor I

Thanks a lot for your reply.

I have tried this several times (unchecking & saving & restarting: no LED lights, then checking & saving & restarting: no LED lights and again and again and again). No success. I also reflashed the BIOS using different methods, set the BIOS to default values, pulled the power cable for about a day, etc. etc. still absolutely no LED lights in normal usage. 

The LED lights work in sleeping mode, so this is not hardware related. And also not OS (Win 10) related, since there are also absolutely no lights after powering the NUC up (nevertheless I updated the Intel LED manager to its newest version and also all drivers).

The problem first occurred during the first restart just after the BIOS update (the skull flashed twice in deep red, after that all lights were gone).


I've been following this because I have the same issue.  The Intel Driver and Support assistant recommended BIOS 64 and after successful install, all LEDs are out and I've tried most of the suggestions here (excepting a power button re-flash or jumper change).  Same experience with others that the BIOS cannot manually turn the lights on.  However, I am finding that in the Windows LED manager I can get any of the lights back but only if the section is set to track the CPU activity.  All other choices to set a LED zone to follow any other activity result in a dark LED zone (HDD, power supply draw, turn on with power, etc.).


Hello Maria, thankyou for your suggestion but it did not have any effect.

I see you are asking to close thread.

Does that imply that you think that this is a warranty issue with my specific unit rather than a problem with the BIOS last installed?

Thanks Scott


Hello all,


Thank you for let me know the outcome.


If the issue persisted after those steps, the best is to contact Intel* Technical support directly, using the internal support, so an agent from your region can verify the warranty of your units. Feel free to provide this thread as a reference.


@ScottyP , 

Please let me know if I can proceed to close this thread.



Best regards, 

Maria R.  

Intel Customer Support Technician 


New Contributor I

I know this seems like a software issue but just out of interest have you tried opening up the chassing and disconnecting and re-connecting the LED cable (the one you have to detach before you get to where RAM and SSD slots are)? My LEDs work most of the time but sometimes they either go completely dark or display the wrong color. Each and everytime I get this fixes by opening up Hades Canyon, detaching the LED cable and the re-attaching it to its slot. I get the feeling the connector is a bit flimsy and gets easily dislocated by moving the chassis etc.


TL;DR If any LED issues occur, I'd first detach/re-attach the LED cable to see what happens and then proceed from there.

New Contributor I

Thanks a lot for your reply. This is what I did first: without success

Since the lights work in sleep mode and also if you set them to track the CPU activity in the Intel LED manager (as Keith1 found out), this seems to be really a software/firmware related issue. And the problem occurred immediately after the bios update, so ...

I can't understand why this thread is supposed to be closed and I am afraid to send in my computer for a warranty case (taking several weeks) only to be faced with the same problem afterwards.


Super User Retired Employee

Have you tried using the LED manager yourself? [Aside: AFAIAC, everyone should be running it anyway.] If this works - and, for the sake of argument, it does - then you know that the EC's firmware (or the BIOS-to-EC communication) is the issue. Since we know that this firmware is updated as part of the BIOS update process, you would be accomplishing nothing by RMAing your unit.

If, on the other hand, using the LED Manager does not work with your unit, then, by all means, go ahead and RMA it.



Yes, I always use the LED manager. I have set all LEDs to CPU usage and yes they all work.

When I return to the default settings, returns to being a dark ship.

Power state, HD activity, Wifi, Ethernet activity and power limit are not illuminating the LEDs.

CPU Usage is the only variable being monitored by LEDs correctly.

The system suspends while I stop for lunch and the skull flashes correctly reflecting the current power state.(default settings)

I think my hardware is fine and that pursuing RMA will involve more lost time and income.

The system I have built with this kit is not so unique that I should be tripped up by a BIOS update.

I am still inside warranty period but that does not seem to cover this problem.

I will have to purchase a new unit to stop wasting time, wait for Intel to fix problem the sell old one.

Thanks for trying to help


I am also using the LED manager. After BIOS 64 the LED manager only causes any zones to light if the zone(s) are assigned to monitor CPU activity.  All other sources of illumination (power applied, HD activity, etc) cause a zone to go dark.  The BIOS setup is unable to illuminate any zones, even if manually set to a "constant on" state.

Even weirder is that I get flashing "eyes" when in sleep mode yet LED manager shows no zones configured as such!  Certainly looks like the BIOS programmer may have included some code that incorrectly modified the LED functionality.

I'd love to hear if anyone who applied BIOS 64 still has fully functional LEDs.  I had never modified the LED settings in the BIOS, nor had I ever installed or used LED manager until after the BIOS update caused the issues.  BIOS 64 was also the first BIOS update my NUC had ever had, I believe it was on BIOS 29 before.


New Contributor I
Hello, i have exactly the same issue after updating to the latest bios version. During the update process the leds of NUC are still working, but after the update process is done, no leds are working any more. Seems that the latest bios version is corrupt.

I have (2) NUC8i7HVK models.  One updated to the latest BIOS just fine.  The other had the now infamous LED problem.  I believe the NUC that had the problem skipped a couple of BIOS updates as I hadn't done it in a while (machine is used infrequently).  The NUC that works was always kept 100% up-to-date on all drivers and BIOS updates.

I called Intel support and they said no more NUC8i7HVK's were in service inventory for warranty replacement.  As a result, they offered to give me my money back which I accepted.  The NUC11i9 Extreme will likely be out in Q1-'21, so I'll just apply the money towards that.  The only thing I'll need to determine is if I can reuse my DRAM.


Mine does the same so it is obviously a fault introduced by this update.

Come on intel these units are not cheap by any means sort it out.

New Contributor I
I tried downgrading to an older bios version, but with version 63 i had no success, the led still not working. But i cannot find earlier bios versions on intel download center.