Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
9,864 Views

NUC10 - can't enable Legacy Boot ??

Jump to solution

Just got a NUC10i7FNH after weeks of waiting. Trying to get up to speed with it, and right out of the gate I noticed I'm not able to enable Legacy Boot at all. The options are greyed out and can't be enabled/disabled. Tried updating to the current (0037) BIOS. Searched thru all BIOS screens & options that I could find.

 

screenshot: https://i.imgur.com/2MAD5Sq.png

 

Is this just not possible??

 

0 Kudos

Accepted Solutions
Highlighted
Super User Retired Employee
8,146 Views

Did you disable both Secure Boot and Modern Standby? Both of those must be disabled before you can enable Legacy Boot.

 

Let me add: there is no modern version of Linux that doesn't support UEFI.

 

Hope this helps,

...S

View solution in original post

15 Replies
Highlighted
Super User
8,146 Views

Because legacy bios is dead. Is there any specific reason you need it?

 

Doc

 

0 Kudos
Highlighted
Beginner
8,146 Views

Yes - some bootable linux (e.g. xcp-ng) and other bootable USB disks don't work in UEFI, so unable to e.g .install Xen or update the Firmware on my internal Micron SSD...

0 Kudos
Highlighted
Super User Retired Employee
8,147 Views

Did you disable both Secure Boot and Modern Standby? Both of those must be disabled before you can enable Legacy Boot.

 

Let me add: there is no modern version of Linux that doesn't support UEFI.

 

Hope this helps,

...S

View solution in original post

Highlighted
Beginner
8,146 Views

Wow, Not sure HOW you knew that or figured it out (I spent hours searching) but THANK YOU !!

Disabling Modern Standby did indeed allow Legacy Boot mode to be enabled.

 

0 Kudos
Highlighted
Beginner
8,146 Views

Having the same problem but cannot find in the bios where to disable Modern standby :-(

 

0 Kudos
Highlighted
Super User
8,146 Views

Hello @MHuus1​ 

  1. The Modern Standby function is usually activated in Power > Secondary Power Settings. It depends on Bios configuration. In you NUC it may be something like this: " Native ACPI OS PCIe Support". By default it is disabled. So, you don't need to change this setting. In order to enable Legacy Boot, disable Secure Boot only.
  2. I want to warn you. You can not switch between ACPI S3 mode and Modern Standby. Switching from one standby power model to another is supported only with complete Operating System reinstallation.

 

Leon

 

0 Kudos
Highlighted
Beginner
8,146 Views

POWER > Secondary Power Settings > Sleep Type support: Legacy S3 Standby

0 Kudos
Highlighted
Super User Retired Employee
8,146 Views

In the FN NUC, it is the top parameter in the Secondary Power Settings. Note that entry to Secondary Power Settings​ scene is hard-to-spot link at bottom (below last parameter) of Power Settings scene.

...S

0 Kudos
Highlighted
Beginner
8,146 Views

Thanks, all now working fine!

0 Kudos
Highlighted
Beginner
7,888 Views

Hi,

I'm having this issue on two NUCs 10i7FNH, but on both after enabling Legacy Boot I can't see any video signal on outputs (no matter if TB or HDMI).
I tried everything - removing SSD, RAM, secure jumper. After power on NUC runs fans for about 10 seconds, after that fan slows down, but nothing is visible on monitor. No BIOS, no boot options, blank screen. Tried recovery BIOS, no success. After having this issue on one NUC, I updated BIOS to the latest available v0039 on second one and then enabled legacy boot. Right after enabling it the same problem occured on second NUC.

Does anyone have an idea what else could I try?

0 Kudos
Highlighted
Super User Retired Employee
7,863 Views

Try the following process for blindly resetting the BIOS:

  1. Note: Until Step 11, may not see anything on screen.
  2. Power off the NUC.
  3. Power on the NUC, holding the power button in for a 4-count (1001, 1002, 1003, 1004).
  4. Wait 15 seconds.
  5. Press F2.
  6. Wait 5 seconds.
  7. Press F9.
  8. Press 'Y'. BIOS configuration should now be reset.
  9. Press F10.
  10. Press 'Y'. Reset BIOS configuration should now be saved and Visual BIOS exited.
  11. The NUC should reset and you should see the BIOS Splash Screen displayed.
  12. Press F2 and then do whatever changes you need in BIOS.

I hope this works; I haven't tried this process myself with one of the new Aptio5 BIOSs yet.

...S

Highlighted
Beginner
7,666 Views

Hi,

thank you Scott for your input, yet before you wrote it I've returned both NUCs to reseller. Later I passed them your advise, they reportedly tried that but no success. I will get it replaced by two new devices. Looks like I have to stay away from legacy boot option to avoid such surprises in future.

Thanks anyway, maybe someone else can use your way. Take care!

Greg.

 

0 Kudos
Highlighted
Super User Retired Employee
7,642 Views

In this age where state-sponsored hacking is seemingly a norm, everything that you can do to make and keep your system more secure is worth the effort. Fact is, UEFI Boot is far, far more secure than Legacy Boot. Legacy Boot should be avoided at all costs.

...S

Highlighted
Beginner
7,542 Views

Hi,

I got two new NUCs to replace and I stay away from enabling Legacy Boot.

But there is new issue - I tested 3 or 4 usb sticks prepared to boot in UEFI mode and none of them works - computer stops reading a stick after some time and nothing more happens.

What bothers me is that even the one I made using the NUC itself doesn't work in this NUC. From Aomei Backupper I prepared 'bootable media' > bootable disc based on Win PE environment > 'create UEFI bootable disc' > write on USB stick.

Plugged in front or back USB port, no difference. The same USB sticks tested in other computers (Lenovo laptop, desktop Dell, even old NUC 5i3 series) works correctly. What the heck? How would I restore system image if something goes wrong? So far I used to do system image once a week and it saved my ass a few times.
I'm starting to suspect that is something wrong with NUC series 10, at least with it's BIOS. I'm starting to suspect that is something wrong with NUC series 10, at least with it's BIOS (latest v0039).

0 Kudos
Highlighted
New Contributor III
5,889 Views

Use Rufus to create a bootable USB flash drive.

https://rufus.ie/

Works best on all the NUCs I have used. Also, make sure you are using quality flash drives. Cheap drive use cheap controllers and are not recognized easily. Make sure to select GPT as the format type, not MBR.

 

0 Kudos