Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
274 Views

No Windows Boot Manager option in boot menu

Jump to solution

Hi.

A few weeks ago I bought a NUC8i3BEH from Amazon. I purchased a Windows 10 Pro license to be able to run Windows on it just in case, even though I bought it as a powerful retrogaming machine, with a dedicated Linux-based OS (RecalBox). I also installed Ubuntu as well.

While I see both Recalbox and Ubuntu's GRUB boot options, I can't get to install the Windows Boot Manager option in the NUC's BIOS. The strangest thing is GRUB sees Windows Boot Manager and boots it if selected.

Is there a limit on the number of boot options in the NUC's BIOS? If not, how do I solve this ?

Thanks in advance.

Labels (1)
0 Kudos

Accepted Solutions
Super User
175 Views

Hi @moisemust 

There is a limited number of boot entries in BIOS.  Could be that the Windows Boot Manager isn't visible in BIOS and/or Boot Menu, because you have to much entries there. Please check this and delete some old and not used entries (if any).

This video show how to do this from Windows. This is an additional method. 

This video shows how to do this in Linux (using efibootmgr).

Leon

 

View solution in original post

0 Kudos
10 Replies
Super User
262 Views

Hi @moisemust 

You should disable the Secure Boot option in BIOS. There is lot of articles on net dealing with Dual Boot installation. See this tutorial for an example.

Leon

 

0 Kudos
Beginner
257 Views
Hi and thanks for your reply.

I forgot to mention it, but I did disable secure boot already, otherwise Ubuntu wouldn't install.
0 Kudos
Super User Retired Employee
244 Views

What kind of drive are you (or want to be) booting from? If it is NVMe, then you *must* use UEFI Boot.

...S

0 Kudos
Beginner
226 Views

No, no NVMe, just a SATA m.2 SSD.

0 Kudos
Beginner
222 Views

I'm using UEFI Boot though (Legacy is even disabled and Windows boots fine from Grub).

0 Kudos
Super User Retired Employee
192 Views

I am no expert on Grub, but I have always thought that it was necessary to install Windows before Linux. This may be why it is not working.

...S

0 Kudos
Beginner
186 Views
That's what I did. I installed in the following order: 1. Windows 2. Ubuntu 3. Recalbox

I did the installs twice, as every time Windows Boot Manager wouldn't appear in the BIOS. It still doesn't. I also tried a few commands from the Windows install USB (created with the 2004 mediacreationtool provide by Microsoft on their website).

I also checked the EFI partition, the necessary files for booting Windows are present (at least the same as on my other desktop, which uses UEFI, are there).
0 Kudos
Super User
176 Views

Hi @moisemust 

There is a limited number of boot entries in BIOS.  Could be that the Windows Boot Manager isn't visible in BIOS and/or Boot Menu, because you have to much entries there. Please check this and delete some old and not used entries (if any).

This video show how to do this from Windows. This is an additional method. 

This video shows how to do this in Linux (using efibootmgr).

Leon

 

View solution in original post

0 Kudos
Beginner
154 Views

OK that's what I thought.

 

Thanks.

0 Kudos
Moderator
145 Views

Hello @moisemust

Thank you for posting on the Intel® communities.

We hope that the information provided by the community has been helpful to clarify your concern. Since the thread has been marked as "Solved" we will proceed to close this inquiry now from our end. Communications with community peers may continue, but if you need any additional information from Intel, please submit a new question as this thread will no longer being monitored.


Best regards,

Andrew G.

Intel Customer Support Technician


0 Kudos