Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15322 Discussions

Exporting and importing design partition

TYilm2
Beginner
1,404 Views

Hello, Please tell me what am i doing wrong?

I have project. I would like to mek an IP of it or something that my students can not see the contents (VHDL code). VHDL code I do not want to provide. Hence I do.

1- I create a project with a certain device (cyclone 5).

2- I add all my VHDL codes and set the top level.

3- Start compilation (without this the next step will not work)

4- Analysis and elebrotaion

5- Export design partition

The I create another peoject

6- I make a schematic. Here I instantiate the symbol file of the previous project and add some other to my project.

7- Then I import design partition that I have created.

8- I try to create the programming file.

This is not working. I tried almost everything but no result.

Error (171173): Node SWITCH[6] from partition Audio_Codec24:inst cannot preserve previous placement at PIN AJ11 and honor the location assignment to PIN AE11

 

I tried almost every option when exporting the design partition. For example empty, post-synthesis post-fit etc.

 

Question: Is there someone who can tell me what am i doing wrong. Can you give also a step by step plan.

 

How can I instantiate .qxp file in a schematic if using the .bsf is not correct.

Should i make for all of the vhdl file a n export and create .qxp for each.

 

Any help will be very appriciated. I am using the device 5CSEMA5F31C6 (DE1-SOC board)

 

 

 

0 Kudos
7 Replies
KhaiChein_Y_Intel
170 Views

You may remove the conflicting location assignments or recompile the specified partitions by setting the Netlist Type of Post-Synthesis for the specified partitions.

TYilm2
Beginner
170 Views

Dear Kyeoh, Thanks for answering. I tried all possibilities including Post-Synthesis. I stil get the same problem. I almost give it up. Is there any other way to do it without providing the sources?. Thanks again.

 

sstrell
Honored Contributor III
170 Views

As mentioned, you've got a pin assignment in the partition you're exporting and that assignment can't be preserved when it's imported. Remove the assignment.

TYilm2
Beginner
170 Views

Thanks for answering. I understand that it has something to do with double pin assignment. But the case is there is no pin assignment in the first (exported) project. At least I did not assign any pins. Is this happening automatically during generation or exporting because I have chosen a certain device Should I remove the chosen device too. Or Should I remove also the pin assignments in my big project where I instantiate or import the created partition. Thanks again.

TYilm2
Beginner
170 Views

One last remark that maybe helps. As I said I tried it many times. Yesterday I did the following:

I deleted everything except:

  • symbol files
  • vhdl codes of components
  • bdf files
  • .qsf file
  • qpf file

Then I opened the project. I removed all assignments. I have chosen my device. I opened the .qsf file to be sure there is no pin assignments. And indeed there were no assignments.

 

After all this I followed the steps. The same happened. I will try today by removing the device too and see where I land.

 

Thanks any way for all help. Thanks for answering.

 

KhaiChein_Y_Intel
170 Views

Can you provide a small test case and steps for me to reproduce the error?

KhaiChein_Y_Intel
170 Views

Is there any updates?

Reply