Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RSing16
Beginner
973 Views

Hello, I am using cycloneIV device for a simple project to explore tool using web version. and ended up with following error at simulation.

Error is as following..

 

Error\: ModelSim-Altera Error\: \# \*\* Error\: \(vsim-3033\) ledblink\.vo\(63\)\: Instantiation of 'cycloneive_io_obuf' failed\. The design unit was not found\.

 

please help.

 

Thanks

 

0 Kudos
4 Replies
AnandRaj_S_Intel
Employee
85 Views

Hi,

 

Which version of Quarts and modelsim is used?

May be due to library missing on modelsim version so try with appropriate version of modelsim.

Can you share the design or share more information on design(Like IP used, and its configuration)?

 

Best Regards,

Anand

 

Abe
Valued Contributor II
85 Views

Hi,

 

Have you compiled the Cyclone IV FPGA device libraries for ModelSim. If using the Intel FPGA version, then at the vsim command line you will have to specify the library name using the -L option..

 

vsim -work.. -L 220model_ver -L altera_mf_ver -L cycloneive_ver -L alteralnsim_ver -L altera_ver -L fiftyfivenm_ver -L lpm_ver -L twentynm_ver. This will include the device libraries for simulation.

RSing16
Beginner
85 Views

hello,

Suggested solution did not work.

I have tried below command and ended up with error loading design.

vsim -work -L 220model_ver -L altera_mf_ver -L cycloneive_ver -L alteralnsim_ver -L altera_ver -L fiftyfivenm_ver -L lpm_ver -L twentynm_ver

 

 

# vsim 220model_ver -L altera_mf_ver -L cycloneive_ver -L alteralnsim_ver -L altera_ver -L fiftyfivenm_ver -L lpm_ver -L twentynm_ver

# Start time: 17:35:57 on Nov 26,2018

# ** Error: (vsim-3170) Could not find '220model_ver'.

#        Searched libraries:

#            C:/intelFPGA/16.1/modelsim_ase/altera/verilog/altera_mf

#            C:/intelFPGA/16.1/modelsim_ase/altera/verilog/cycloneive

#            C:/intelFPGA/16.1/modelsim_ase/altera/verilog/altera

#            C:/intelFPGA/16.1/modelsim_ase/altera/verilog/fiftyfivenm

#            C:/intelFPGA/16.1/modelsim_ase/altera/verilog/220model

#            C:/intelFPGA/16.1/modelsim_ase/altera/verilog/twentynm

#            C:/d_rbs/Projects/8b10b/MB/project/simulation/modelsim/gate_work

# Error loading design

# End time: 17:35:58 on Nov 26,2018, Elapsed time: 0:00:01

# Errors: 1, Warnings: 0

 

please let me know if I need to get some more files for the installation.

 

Thanks

 

 

Abe
Valued Contributor II
85 Views

Ok, so the issue with the Cyclone IV E IOBUF sim model is resolved. This error is due to the sim library name. What I had provided earlier for the 220 Model lib is incorrect. You can remove the -L 220model_ver and then re-run the simulation. It should work this time.

Reply