Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
15798 Discussions

I think it is a bug. ModelSim cannot be called from Quartus on Ubuntu

domvito55
Beginner
1,162 Views

1) I have Quartus Prime Lite 21.1 installed on Ubuntu 20.04 and it is working fine.

2) I also have ModelSim 20.1.1 and it is working fine

3) I've put the right path to ModelSim on Quartus Prime, and it can even recognize the version as we can see on pictures 1 and 2. I've tried 2 variations:

a) /home/domvito55/intelFPGA_lite/20.1/modelsim_ase/bin

and

b) /home/domvito55/intelFPGA_lite/20.1/modelsim_ase/linuxaloem

4) But when I try to run ModelSim from inside Quartus, it does not open! And I get the following message which is pretty odd, as I've never installed Questa, and I didn't even put a directory path for Questa.

Error: You selected ModelSim as Simulation Software in EDA Tool Settings, however NativeLink found Questa Intel FPGA in the path -- correct path or change EDA Tool Settings and try again
Error: NativeLink simulation flow was NOT successful

I've spent all day today trying a bunch of stuff, but I couldn't solve it.

I'll put the transcription of the log file in the end.

domvito55_0-1647133722711.png

domvito55_1-1647134327519.png

 

Log file

Info: Start Nativelink Simulation process

========= EDA Simulation Settings =====================

Sim Mode : Gate
Family : maxii
Quartus root : /home/domvito55/intelFPGA_lite/21.1/quartus/linux64/
Quartus sim root : /home/domvito55/intelFPGA_lite/21.1/quartus/eda/sim_lib
Simulation Tool : modelsim
Simulation Language : vhdl
Version : 93
Simulation Mode : GUI
Sim Output File : somador1bit.vho
Sim SDF file : somador1bit__vhdl.sdo
Sim dir : simulation/modelsim

=======================================================

Info: Starting NativeLink simulation with ModelSim software
Sourced NativeLink script /home/domvito55/intelFPGA_lite/21.1/quartus/common/tcl/internal/nativelink/modelsim.tcl
Error: You selected ModelSim as Simulation Software in EDA Tool Settings, however NativeLink found Questa Intel FPGA in the path -- correct path or change EDA Tool Settings and try again
Error: NativeLink simulation flow was NOT successful

 

================The following additional information is provided to help identify the cause of error while running nativelink scripts=================
Nativelink TCL script failed with errorCode: issued_nl_message
Nativelink TCL script failed with errorInfo: You selected ModelSim as Simulation Software in EDA Tool Settings, however NativeLink found Questa Intel FPGA in the path -- correct path or change EDA Tool Settings and try again
while executing
"error "$emsg" "" "issued_nl_message""
invoked from within
"if [ catch {exec $vsim_cmd -version} version_str] {
set emsg "Can't launch $tool Simulation software -- make sure the software is properly installed..."
(procedure "launch_sim" line 88)
invoked from within
"launch_sim launch_args_hash"
("eval" body line 1)
invoked from within
"eval launch_sim launch_args_hash"
invoked from within
"if [ info exists ::errorCode ] {
set savedCode $::errorCode
set savedInfo $::errorInfo
error $result $..."
invoked from within
"if [catch {eval launch_sim launch_args_hash} result ] {
set status 1
if [ info exists ::errorCode ] {
set save..."
(procedure "run_sim" line 74)
invoked from within
"run_sim run_sim_args_hash"
invoked from within
"if [ info exists ::errorCode ] {
set savedCode $::errorCode
set savedInfo $::errorInfo
error "$result" $savedInfo ..."
(procedure "run_eda_simulation_tool" line 334)
invoked from within
"run_eda_simulation_tool eda_opts_hash"

0 Kudos
8 Replies
YEan
Employee
1,088 Views

Hi,

 

Have you change the path in Assignments->Settings-> EDA tool settings?  

 

Thanks,

Ean

domvito55
Beginner
986 Views

Yes, I tried it... Sorry... Your e-mails were going to my spam box... So I just saw it now.

YEan
Employee
1,024 Views

Hi,

 

Does your issue has been resolved?

 

Regards,

Ean

 

domvito55
Beginner
986 Views

Nop. What I did instead was step back the Quartus and the ModelSim to version 20.1, so now I can use it normally. But I could not make the previous arrangement to work.

YEan
Employee
1,006 Views

Hi,


We do not receive any response from you to the previous question that have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Regards,

Ean


domvito55
Beginner
985 Views

Sorry, I havent seen it, because your e-mails were going directly to my spam box.

YEan
Employee
936 Views

I just noticed that you used ModelSim in  Quartus Prime Lite 21.1. Unfortunately, the simulation software ModelSim has been removed in Quartus 21.1 and it was replaced by Questa. https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/rn/archives/rn-qts-std-dev-... 

domvito55
Beginner
895 Views
Reply