Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15481 Discussions

System Console: Open Service Path cannot be found

JBayl
Beginner
919 Views

Hi, 

I have an existing TCL script that I use to test our products using System Console via byteblaster.  The script stopped working probably sometime after i installed 19.2 or when i started developing on the Cyclone 10GX development board.

The error is at the very start of the script which is when i execute:

set mm [ lindex [ get_service_paths master ] 0 ]
open_service master $mm

What I get from open_service is:

error: open_service: Path cannot be found
while executing
"open_service master $mm"

Since the open_service fails, master_write/read commands doesn't working.  The byteblaster is working because i can configure the FPGA.

I'm using a PC with Windows 10 Pro 64 bit.  I developed the script either on Quartus Version 16 or 17 and TCL runs also doesn't work with the same failure on these 2 versions.

 

Thanks!

 

0 Kudos
3 Replies
sstrell
Honored Contributor III
911 Views

I know the open_service command was deprecated a while back and replaced with claim_service, but I don't know if that currently means that open_service commands would fail.

If you manually enter the set mm... command in the console, do you get a response that the service path was found?

#iwork4intel

JBayl
Beginner
905 Views

There's no output response when I run set mm [lindex [get_service_paths master ] 0 ]

If open_service was deprecated, what's the new sequence?

I tried the procedure written on Locating and Opening the Master Service written on Page 10 here:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug_system_console.pdf

but I get:

error: claim_service: Path  cannot be found
    while executing
"claim_service master $master_service_path mylib"
    invoked from within
"set claim_path [claim_service master $master_service_path mylib]"

sstrell
Honored Contributor III
901 Views

Just to verify, you've been able to program the device over JTAG and this has worked for you previously?

In System Console, do you see your connection into the system in the System Explorer section and does the Messages window indicate any issues when you start the tool?  Is there any chance you have more than one device on JTAG and the index of 0 needs to change?

#iwork4intel

Reply