Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
304 Discussions

Programmer error in auto-detecting the FPGA

VRama10
Beginner
745 Views

Hi,

In Cyclone 10 GX board, when I try autodetecting the devices in programmer, in recent times, Quartus 18.1 pro programmer is not detecting the 10CX220Y.

I tried renaming the unknown device ID and changing the instruction register length to 10.

After that I was able to program the device, but still couldn’t run the nios application code. For some reasons, the Eclipse is not detecting the target connection path.

 

I tried uninstalling all the pro version, and when I reinstall, the autodetect feature works for a couple a times, and then It keeps repeating the same error. The blaster driver seems to be good too.I would really appreciate any suggestions on this. unknown_device.pngunknown_device1.pngunknown_device2.png

0 Kudos
5 Replies
Ahmed_H_Intel1
Employee
306 Views
Hello, Are you using a Dev-Kit or your custom board? this is very important for me to understand how I can help you. Regards.
VRama10
Beginner
306 Views

I'm using Cyclone 10 GX development board built by intel

Ahmed_H_Intel1
Employee
306 Views

Hi,

Did you try to refresh the connection on Eclipse? Uncheck the systemID check box to see if the Eclipse will detect the NIOS II.

Regards,

VRama10
Beginner
306 Views

Hi,

I did, it still didn't show up.

But reinstalling the programmer solved it.

Thanks!!!

Ahmed_H_Intel1
Employee
306 Views

Great.

Reply