Intel® oneAPI Data Analytics Library
Community support for building compute-intensive applications that run fast on Intel® architecture.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

Which GNU C/C++ version is required?

joachim_d_
Beginner
163 Views

Hi there, as there are two conflicting answers on this, the open source version on GIthub claims

GNU C/C++ 5.1 here (https://github.com/01org/daal)

but in the Getting started guide system requirements on the Intel website (https://software.intel.com/en-us/articles/intel-daal-2016-system-requirements)

it says

GNU C/C++ 4.9

 

 

0 Kudos
1 Solution
Ilya_B_Intel
Employee
163 Views

Hi, Joachim

If you take pre-built version of the library, you will be able to use it with GCC 4.9+

In order to build library from sources, you will need GCC 5.1+.

View solution in original post

2 Replies
Ilya_B_Intel
Employee
164 Views

Hi, Joachim

If you take pre-built version of the library, you will be able to use it with GCC 4.9+

In order to build library from sources, you will need GCC 5.1+.

joachim_d_
Beginner
163 Views

Excellent thank you I am using the prebuild-version and it seems to work fine with GCC4.9.2 

Reply