Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SSyno
Novice
12,070 Views

Drivers for Intel Dual Band Wireless-AC 7260 Card?

Jump to solution

Just put a new system together and installed an Intel Dual Band Wireless-AC 7260 in it. Used Windows 8 Pro. x64. I cannot find drivers for the Intel Dual Band Wireless-AC 7260.

Anyone know where I can get drivers for this card? I purchased the card from Provantage.

0 Kudos
183 Replies
ROwen2
New Contributor I
81 Views

This fixed it:

#

# Debugging Options

#

CONFIG_IWLWIFI_DEBUG=y

CONFIG_IWLWIFI_DEBUGFS=y

CONFIG_IWLWIFI_DEBUG_EXPERIMENTAL_UCODE=y

CONFIG_IWLWIFI_DEVICE_TRACING=y

CONFIG_IWLWIFI_P2P=y

CONFIG_IWLEGACY=m

CONFIG_IWL4965=m

CONFIG_IWL3945=m

Also, as for the nvidia-bug...

https://devtalk.nvidia.com/default/topic/549532/linux-3-10-incompatibility-in-function-lsquo-nv_i2c_... https://devtalk.nvidia.com/default/topic/549532/linux-3-10-incompatibility-in-function-lsquo-nv_i2c_...

Try Nvidia-325. Working on my laptop with linux-3.11-rc1 and bumblebee 3.2.1.

DElli7
Beginner
81 Views

I attempted to load both a Win 7 & Win 8 Bluetooth driver for the AC7260 and unfortunately...nothing. At least the Wi-Fi portion of the AC7260 is working.

Has anyone been able to solve the Bluetooth issue for the AC7260 in Win 8 Pro x64? I'd hate to buy a USB nano Bluetooth adapter until a resolution has been found.

Thanks very much.

BHart4
Novice
81 Views

Sager Notebooks has posted a new Windows 7 and Windows 8 driver(both are same driver) for the AC-7260.The driver version is 16.1.0.14

http://www2.sagernotebook.com/pages/notebooks/download.cfm?ProductType=9380 http://www2.sagernotebook.com/pages/notebooks/download.cfm?ProductType=9380

The driver works on 3 different notebooks that I tried it on>MSI,LG,Samsung

The driver supports both 32bit and 64bit versions of XP,Vista,W7,W8 and Windows 8.1 Preview.

LT1
Novice
81 Views

In Re: Bluetooth for Windows 8 -- my AC7260 card loaded Intel (and Microsoft's) driver just fine, in both Win 7 and Win 8. Perhaps your laptop has BT switched off? My Acer laptop lets you enable Bluetooth separate from WiFi via the Fn key... just a thought.

LT1
Novice
81 Views

@ SmogHog -- thanks for chiming in with that. You are correct, that file does include Win7 and Win8 drivers for x32/x64. Heck, it even includes XP x32 and x64 drivers. Intel does in fact deliver.... even if they took a while. Brand-spanking new, too.. The date on the *.sys driver files is July 11, 2013.

NV3
Beginner
81 Views

does anyone else find it ridiculous that we have to rely on a computer manufacturer to release a driver before intel?

ROwen2
New Contributor I
81 Views

Ridiculous that Linux drivers are out before Windows 7... Although I use Linux A LOT more then Windows I still need Wireless to work in Windows...

Working on my HP DV6T-7000 with Windows 7 HP 64bit. Bluetooth works out of the box...

Now I wonder why the connection speed in Windows is faster then in Linux...

From 295 Mb/s to 120 MB/s...

NV3
Beginner
81 Views

LOL at this thread being marked as answered. Completely not true.

wface
Beginner
81 Views

@ryanvade What are you using to edit the .ko object code files? My gedit and nano are both displaying them incorrectly.

ROwen2
New Contributor I
81 Views

@warfacegod

I didn't. I used modinfo to see if the iwlwifi module was using the new firmware, which it wasn't. After making the above changes (around 7 posts ago) to the 3.11-rc1 kernel configuration the module started using the firmware. I suppose that the newer firmware is still considered experimental so you have to explicitly say to use experimental firmware. After building the kernel with the changes I now get this...

$ modinfo iwlwifi

filename: /lib/modules/3.11.0-rc1/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko

license: GPL

author: Copyright(c) 2003-2013 Intel Corporation <</span>mailto:ilw@linux.intel.com ilw@linux.intel.com>

version: in-tree:d

description: Intel(R) Wireless WiFi driver for Linux

firmware: iwlwifi-100-5.ucode

firmware: iwlwifi-1000-5.ucode

firmware: iwlwifi-135-6.ucode

firmware: iwlwifi-105-6.ucode

firmware: iwlwifi-2030-6.ucode

firmware: iwlwifi-2000-6.ucode

firmware: iwlwifi-5150-2.ucode

firmware: iwlwifi-5000-5.ucode

firmware: iwlwifi-6000g2b-6.ucode

firmware: iwlwifi-6000g2a-5.ucode

firmware: iwlwifi-6050-5.ucode

firmware: iwlwifi-6000-4.ucode

firmware: iwlwifi-3160-7.ucode

firmware: iwlwifi-7260-7.ucode

srcversion: 8D22459AE64431AADA3B30D

...

I am mad though. Windows is getting around 300 Mb/s. While Linux hasn't gotten more then 150 Mb/s. I am glad it works but come on. Powersaving is off, I am a few feet from the router. Netgear R6300 V2. Why so slow?

BBrad4
Novice
81 Views

Works great for both ac wireless and bluetooth on the Dell XPS with Win7. You'd think Intel would make them available for download.

wface
Beginner
81 Views

Ah, that explains it. I thought that would be the case but was hoping to find a way read these .ko files properly. I tried doing that but now with the 3.9 kernel. Although, I didn't have to set those options with wireless-testing. Figured since 3.10 and 11 have that nVidia bug thing, I'd try one I know will run nVidia. Refuses to compile. Error code 2 which was supposed to have been fixed in 3.2 I've pretty much given up. I've gone the route of asking damentz, the Liquorix guy, to compile the new 7000.c into his next update.

Barring that, may try and get the nVidia drivers running under 3.11.

I got 300Mb/s with the wireless-testing kernel almost continuously. Never went higher but I never gave it a reason to. I've an ASUS RT-AC66U router. At least with that one you need to have the 5 GHz signal set to 80 MHz channel only. No 20/40. I suspect it's the same for all routers. Did you change your antenna when you put the new card in? My understanding is that many antennas are capable of utilizing a 5 GHz signal but most can't use full ac speeds. I suspect mine can't. Might explain why I never saw the 866 Mb/s the ac7260 should be able to do.

I also tend to use ~15 feet as a default distance for testing wireless. With wireless, there is such a thing as too close and your "few feet" sounds like it might be just that.

NV3
Beginner
81 Views

I can also verify that the Sager driver is working in a Dell that I have installed this card in. Shameful that Intel still hasn't released an official driver for this for Windows 7.

MTrid
Beginner
81 Views

On the other hand, I'm unable to get the Sager driver to work on my Lenovo s205 E-450 laptop.

Well, the driver installs and seems to be ok, but I'm not able to associate to any network ("unable to connect" message), and the adapter sometimes requires disabling/re-enabling to actually scan for networks.

jlort1
Beginner
81 Views

Installed this card in two Dell XPS 12s, neither has Bluetooth now. I have no toggles to turn BT on and off. Wifi works. Reinstall the 6235, BT is back. Any ideas? BT doesn't show in device manager with the ac 7260.

DQuir1
Beginner
81 Views

I am starting to think a couple of things about intel not releasing drivers for these cards.. and us finding drivers from sites like sager and clevo..

1. ether these cards are bad,,,

or

2, the drivers are bad and these cards were released well ahead of scheadule..

I have an Alienware m18x-r2 and it has the killer 1103 in it and with my asus rt-ac66r(wich is the same as the 66u)

i get a steady 450MB connection with file transfers at and exceeding 40MB/sec

With my ac7260 card i dont get any where near that speed..it is all over the board... never holds a continuous speed..

have i seen the higher speeds that are advertised for this card.. sure i have... but it will not hold them and upon any activity it drops... so i.e. it will go say 720mb/sec .. then i start some thing it will drop to 150..200... 350...300...195...139... and so forth.. but at idle right now it sits at 300mb/sec

I am disapointed that these forums and message boards are never really responded to by intel employies...

well please intel,drop us some words of wisdom about this issue please.. and some drivers! that work properly!

PSmit14
Novice
81 Views

I am pretty much in the same boat but with an Acer with Win 7. I have tried uninstalling and reinstalling 7 ways from Sunday with no luck(or Bluetooth). But if I plug in a Bluetooth dongle, not a problem.

PSmit14
Novice
81 Views

I'm having issues with my Acer, the computer kind of just stops working, the 2.4Ghz WiFi drops and then comes back and then everything starts working again.

I'm about ready to put my 6200 back in. The range on these 7260's don't seem to be all that great, with the old card I could cover the whole house on 5Ghz at 300Mbps, with these 7260's I'm lucky to get half that speed.

BBrad4
Novice
81 Views

The sager Win7 drivers works fine on my 1702 XPS and my speed is at a consistent 866.7. The only thing I did differently was that I tried to install the Win8 drivers found on the intel site. The only thing that worked with the Win8 drivers was the bluetooth. I didn't pay too much attention during the sager driver install but both the wireless and bluetooth work fine. It might be worth a try to get the bluetooth working.

jlort1
Beginner
81 Views

Bluetooth DOESNT show in Device manager. Nothing, not even unknown device.