Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Novice
11,902 Views

Drivers for Intel Dual Band Wireless-AC 7260 Card?

Jump to solution

Just put a new system together and installed an Intel Dual Band Wireless-AC 7260 in it. Used Windows 8 Pro. x64. I cannot find drivers for the Intel Dual Band Wireless-AC 7260.

Anyone know where I can get drivers for this card? I purchased the card from Provantage.

0 Kudos
183 Replies
New Contributor I
89 Views

Perhaps you got a bad card?

If you have devcon installed you can get some more detailed information:

devcon listclass net

0 Kudos
Beginner
89 Views

Maybe a bad lot. I purchased 2, neither showed bt. Wifi signal bounced all over the place. Both laptops are Dell XPS 12s, ivy bridge i5s. Using win8 64 bit intel drivers.

0 Kudos
New Contributor I
89 Views

Sorry to hear that. I got mine from Amazon. Bluetooth and wireless seem to work on both win 7 and Diamond II-B. But, like what has been stated before, I cannot get speed past 300 Mb/s. Linux is stuck at 150 Mb/s. Hate that..

I would take a look at the devcon output. Just to check.

0 Kudos
Beginner
89 Views

I got mine from compsource. No issues that I know of with it. I don't use and have bluetooth disabled on my laptop so I can't say if it works or not. I would tend to think you're right about a bad lot. This being new, it's entirely possible Intel hasn't worked out all the manufacturing kinks yet.

0 Kudos
Beginner
89 Views

Do you show Bluetooth in device manager?

0 Kudos
Beginner
89 Views

I'm using Debian Linux so don't have Device Manager. However, I'll put the card back in and check to see if Bluetooth works.

0 Kudos
New Contributor I
89 Views

Device manager:

Bluetooth Radios

--> Generic Bluetooth Adapter

--> Microsoft Bluetooth Emulator

...

Network adapters

--> Bluetooth Device (Personal Area Network)

--> Bluetooth Device (RFCOMM Protocol TDI)

--> Intel(R) Dual Band Wireless-AC 7260

Devcon:

C:\WinDDK\tools\devcon\amd64>devcon listclass net

Listing 26 devices in setup class "Net" (Network adapters).

...

PCI\VEN_8086&DEV_08B1&SUBSYS_40708086&REV_63\4&31D34B42&0&00E3: Intel(R) Dual Band Wireless-AC 7260

BTH\MS_BTHPAN\7&1E5610C2&0&2 : Bluetooth Device (Personal Area Network)

BTH\MS_RFCOMM\7&1E5610C2&0&0 : Bluetooth Device (RFCOMM Protocol TDI)

...

0 Kudos
Beginner
89 Views

 

As you can see in my screenshot, I have none of that.
0 Kudos
New Contributor I
89 Views

BIOS is not disabling it? You checked for hardware-switches that could disable it? Any kind of black-listing?

-> Press Windows key + R and type services.msc in the search field and press ENTER. 

-> Double-click the Bluetooth Support service.

 

-> If the Bluetooth Support service is stopped, click Start.

 

-> On the Startup type list, click Automatic.

 

-> Click the Log On tab.

 

-> Click Local System account.

 

-> Click OK.

 

-> If you prompted to restart the computer, click yes.
0 Kudos
Beginner
89 Views

In my old D830, I have to use the card in the WWAN slot for Bluetooth to show up. In the Wifi slot, it does not. The BIOS seems to prevent anything that isn't a wifi device from working in that slot.

0 Kudos
Beginner
89 Views

Compiling wireless-testing no longer works to run the ac7260. It's displaying some odd error on boot that doesn't look even vaguely familiar and isn't going into the logs for some reason. Awesome.

In other words, I have no way I know of to test Bluetooth.

In other news, I've heard back from damentz. He's unwilling to compile the driver into his next update of Liquorix because he says some of the patches in wireless-testing aren't ready by a long shot. Which jives nicely with what I said above. He recommends getting in touch with the kernel backports folks. http://techpatterns.com/forums/about2311.html http://techpatterns.com/forums/about2311.html

0 Kudos
Beginner
89 Views

The new 3.11 series has the 7260 patches from wireless-testing and works fine. The 325 series Nvidia module compiles as well with the appropriate patches. You could either compile that yourself from the source available on kernel.org, or I also hear that Ubuntu's mainline compiles will work on most Debian-based distros.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc2-saucy/ Index of /~kernel-ppa/mainline/v3.11-rc2-saucy

0 Kudos
Beginner
89 Views

I've tried the 3.11-rc1 a few different ways. Never could get both nVidia and Intel drivers at the same time. I was unaware that the rc2 version had been released until you posted. Thanks.

0 Kudos
Beginner
89 Views

These guys have a working patch that I use on Ubuntu for Nvidia 325 with Linux 3.11:

https://launchpad.net/~xorg-edgers/+archive/ppa/+sourcepub/3364901/+listing-archive-extra

I don't know whether using the pre-built debs on anything other than Ubuntu will fly, but if not, the source and patch files are there to build from scratch.

0 Kudos
Beginner
89 Views

Normally a .deb is a .deb is a .deb. Unfortunately, Canonical has made a habit of doing bad things to many of their packages that make them iffy at best for the rest of Debian land. I must admit that I avoid Ubuntu packages like the plague unless I have no choice. So much so, in fact, when I found out that Mint LMDE was rebranding some Ubuntu packages for their own repo, I stopped using LMDE.

I've got the amd64 package and gdebi says depends are good and it will let me install it. That's actually a good sign that it hasn't been through the ubuntu wringer. About 1/2 of ubuntu .debs I've tried in the last year, gdebi won't do anything with. Either it sits there or the Install button is greyed out so I can't even watch it sit there doing nothing.

I'm going to try tinkering with the sgfxi script first. Failing that, I'll give the edger's package a shot. Failing both, my Atheros card is going back in (again) and the 7260 will go on the shelf for a couple months.

0 Kudos
Beginner
89 Views

Yeah...I've been aware of that with Ubuntu. In the past I tried one of their kernels with Debian to see if I could use a newer one without compiling from scratch and it wasn't pretty (the latest Debian kernel I could get at that time was based on 3.2, but I hear they have an experimental 3.10 finally). Since the link I gave you is straight from mainline with none of Canonical's typical kernel patches, maybe it'll work. I'll cross my fingers for ya.

0 Kudos
Beginner
89 Views

I have a 1st & 3rd generation I7 Toshiba laptops (both running Win 8 Pro x64) that are having the same issues. WiFi works, but Bluetooth does not work (it does not even register in the Device Manager). I have yet to test to see if the AC7260 will work in the WWAN slot.

By putting the card in the WWAN slot, does your wifi still work? Are you using WIn 7 or Win 8 on your old D830?

0 Kudos
Beginner
89 Views

I have Windows 7 on the D830. Wifi is recognized and works in either the Wifi or WWAN slot, but Bluetooth is not recognized at all in the Wifi slot (doesn't show up in device manager, same symptom as you). I do have some other issues with the current driver from Sager not working too well on Windows 7 with the card in either slot, but I'm pretty sure that's a software issue for me since it works beautifully in Linux. It's possible things might work for you in the WWAN slot (both your laptops have one?). It probably depends on the BIOS. On my D830, the BIOS only has a whitelist on the Wifi slot, the WWAN slot appears to act as a completely open and normal miniPCIe slot and all functionality of the card works just fine.

0 Kudos
Beginner
89 Views

 

I've never had a dell that was whitelisted. I don't have wwan slot. the new xps 12 4th gen comes with a ac-7260 installed. I tired those drivers and got a warning of not for my system. Wifi worked, single jumped all over the place.
0 Kudos
Beginner
89 Views

The Debian site doesn't show any results but their search is notoriously uncooperative.

That's good to know about the edger's package. Doesn't do me any good though. The rc2 kernel gives me that same warning during boot and I still can't find it in the logs.

However, some of you may be interested to know that I did find this:

Jul 22 20:58:48 warhammer kernel: Bluetooth: hci0 failed to open Intel firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq(-2)

Jul 22 20:58:48 warhammer kernel: Bluetooth: hci0 failed to open default Intel fw file: intel/ibt-hw-37.7.bseq

In other words, my ASUS does see bluetooth.

0 Kudos