Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7590 Discussions

Linux ibt-20-1-3 driver does not scan for a specifc device while it is detected using windows driver

epheo
Beginner
790 Views

Hi,

When using 8087:0029 AX200 Bluetooth with the ibt-20-1-3 driver one specific (BLE) device is not detected while scanning.
On the other hand, the same 8087:0029 controller using Windows does detect the device correctly.

This device is also correctly discovered using another 8087:0033 card with ibt-0040-0041 on Linux.

The device is a GoPro with address in the CE:4B:10:34:XX:XX range that connects using Low Energy Bluetooth.

 

$ sudo dmesg | grep -i 'Bluetooth: hci0: Found device firmware'
[ 8.590790] Bluetooth: hci0: Found device firmware: intel/ibt-20-1-3.sfi
$ lsusb |grep 8087
Bus 001 Device 003: ID 8087:0029 Intel Corp. AX200 Bluetooth
 $ uname -a && cat /etc/redhat-release 
Linux fedoradesktop 6.4.13-200.fc38.x86_64 #1 SMP PREEMPT_DYNAMIC Wed Aug 30 17:07:31 UTC 2023 x86_64 GNU/Linux
Fedora release 38 (Thirty Eight)
$ hciconfig -a
hci0: Type: Primary Bus: USB
BD Address: 14:F6:D8:65:71:DC ACL MTU: 1021:4 SCO MTU: 96:6
UP RUNNING PSCAN ISCAN
RX bytes:3235 acl:0 sco:0 events:222 errors:0
TX bytes:8027 acl:0 sco:0 commands:180 errors:0
Features: 0xbf 0xfe 0x0f 0xfe 0xdb 0xff 0x7b 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH SNIFF
Link mode: PERIPHERAL ACCEPT
Name: 'fedoradesktop'
Class: 0x7c0000
Service Classes: Rendering, Capturing, Object Transfer, Audio, Telephony
Device Class: Miscellaneous,
HCI Version: 5.2 (0xb) Revision: 0x20ce
LMP Version: 5.2 (0xb) Subversion: 0x20ce
Manufacturer: Intel Corp. (2)
$ modinfo btintel
filename: /lib/modules/6.4.13-200.fc38.x86_64/kernel/drivers/bluetooth/btintel.ko.xz
firmware: intel/ibt-12-16.ddc
firmware: intel/ibt-12-16.sfi
firmware: intel/ibt-11-5.ddc
firmware: intel/ibt-11-5.sfi
license: GPL
version: 0.1
description: Bluetooth support for Intel devices ver 0.1
author: Marcel Holtmann <marcel@holtmann.org>
rhelversion: 9.99
srcversion: 6E15B16D7DCE127A97A0FFA
depends: bluetooth
retpoline: Y
intree: Y
name: btintel
vermagic: 6.4.13-200.fc38.x86_64 SMP preempt mod_unload

 

I did try power restting both client and controller.

Other devices seems to be correctly detected but I do not own any other BLE ones to pin point the issue to BLE specificly.

 

My bluetooth Controller is configured in default dual mode that supports both bredr and le.

$ cat /etc/bluetooth/main.conf |grep ControllerMode
#ControllerMode = dual

 

If you have an idea, I'll appreciate any help.

Many thanks,

Thibaut.

 

0 Kudos
3 Replies
IsaacQ_Intel
Employee
766 Views

Hello @epheo

 

Thank you for posting on the Intel️® communities. We would be more than glad to help you with your issue.

 

In order to have a better understanding of your issue, please provide me with the following:

 

SSU: Please download and scan your system using our tool, Intel® System Support Utility so we can help check your system info first. Once finished downloading, open the tool, click on scan 'Everything', click next, then save the system information to a .txt file. Please provide the .txt file.

This document will be necessary to check your entire system, in order to find possible errors or incompatibilities.

 

Also, please answer the questions below:

 

1.      Can you provide more information about the GoPro device itself, such as its model and firmware version?

2.      Have you encountered similar issues with other BLE devices, or is this problem specific to the GoPro?

3.      Are there any notable differences in the way the ibt-20-1-3 driver handles BLE compared to the ibt-0040-0041 driver or the Windows driver?

4.      Have you tried to identify any specific code or configuration variations between these drivers that could explain the difference in behavior?

5.      Which version of the ibt-20-1-3 driver are you using on Linux?

6.      Can you provide details about the Linux system, such as the distribution and kernel version?

 

 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
IsaacQ_Intel
Employee
722 Views

Hello epheo

 

We hope you are doing fine.

 

Were you able to check the previous post?

Let us know if you still need assistance.

 

Best regards,

Isaac Q. 

Intel Customer Support Technician


0 Kudos
IsaacQ_Intel
Employee
701 Views

Hello epheo

 

We hope you are doing fine.

 

We have not heard back from you. So we will close this thread. If you need any additional information, submit a new question, as this thread will no longer be monitored.

 

Best regards.

Isaac Q.

Intel Customer Support Technician.


0 Kudos
Reply