Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ANava7
Beginner
2,260 Views

Quartus 17 can't programm DE10 Lite on Ubuntu 16

I have installed Quartus 17 on Ubuntu 16.04 and the problem is that after select USB-Blaster and Trying to upload the programm to the DE10 Lite, always get FAILED. I was working with a EP1C3T144 but just in Windows, using Quartus 10, at that time Ubuntu never recognized USB-Blaster. Now I don't know if I forgot to install something, for the installation of Quartus, I did:

  • sudo dpkg --add-architecture i386
  • sudo apt-get update
  • sudo apt-get install libxft2:i386 libxext6:i386 libxext6:i386 libncurses5:i386
  • ./setup.sh (Quartus)

And then I also did the following for the USB-Blaster:

sudo gedit /etc/udev/rules.d/92-usbblaster.rules. And add

# USB-Blaster

 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6001", MODE="0666", SYMLINK+="usbblaster/%k"

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6002", MODE="0666", SYMLINK+="usbblaster/%k"

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6003", MODE="0666", SYMLINK+="usbblaster/%k"

 

# USB-Blaster II

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6010", MODE="0666", SYMLINK+="usbblaster2/%k"

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6810", MODE="0666", SYMLINK+="usbblaster2/%k"

 

I hope someone could help me with this issue.

 

progrmr_quartus2.png

 

Thanks in advance.

 

0 Kudos
5 Replies
anava3
Beginner
108 Views

Ok, finally I found a way to programm my FPGA DE10 Lite, and I as thougth it was due to some libraries in Ubuntu. The line in a terminal to check my problem is the next:

$ /.../quartus/bin/jtagconfig

1) USB-Blaster [1-3]

Unable to read device chain - JTAG chain broken

So with the next commands :

$sudo apt-get install libudev1:i386

$ sudo ln -sf /lib/x86_64-linux-gnu/libudev.so.1 /lib/x86_64-linux-gnu/libudev.so.0

Then I checked again :

1) USB-Blaster [1-3]              

 031050DD  10M50DA(.|ES)/10M50DC

 

Finally on Quartus, I run programmer and started and I got : Sucessful

 

The source to solve my problem is : https://www-acc.gsi.de/wiki/Timing/QuartusInstallUbuntu1404.

 

 

 

 

 

Pvand1
Novice
108 Views

Ubuntu isn't supported. This has been duscussed on the old forum. Searhing for ubuntu and programmer should give pointers for others where this solution does not work.

JOHI
New Contributor II
108 Views

Hello Pvand1,

 

I am not that sure that Ubuntu is not supported for Q18.1, please consult the latest info.

 

<https://www.intel.com/content/www/us/en/programmable/support/support-resources/download/os-support.h...>:

Best regards,

Johi.

Pvand1
Novice
108 Views

@JOHI thanks, it has been a while since I updated because I did not want to go through the trouble of getting it to work. It seems that Quartus now indeed supports Ubuntu, but modelsim isn't. Maybe I will update.

anava3
Beginner
108 Views

Yes Ubuntu is now supported, as in my first message I tried to install Quartus 10 in a laptop with ubuntu 14, I couldn't get the Usb-Blaster working, besides there was some people that use some old versions of Quartus in Ubuntu. Now I have Quartus 17 in an old Samsung laptop and also in a Hp laptop with Quartus 18, running fine.

Reply