Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
320 Discussions

DS-5 Version 2020.1 - Arria 10 EVB baremetal debug - configuration database empty

TSege1
Beginner
1,109 Views

Hi,

i Am trying to debug and test bare-metal application on Arria 10 EVB according to the instructions in  https://rocketboards.org/foswiki/Documentation/SoCEDS   

 in paragraph Arria 10 Bare Metal Example Using SoC EDS Pro Edition -> Exercise Sample Application,  section 12:

in debug configuration window i need to see all the Platforms like that:1.png

 

But, in my debug configuration window i got  nothing:

Configuration_ database_empty.png

 

Anny help will be appreciated,

Thanks,

Tamir

0 Kudos
10 Replies
TSege1
Beginner
1,081 Views

HI All,

Still waiting for help.

Thanks,

Tamir

AnilErinch_A_Intel
1,063 Views

Hi ,

It looks like that you are using an old DS-5 configuration with new ARM DS.

Please create a new DS-5 configuration instead of using an existing one and let us know the results.

Thanks and Regards

Anil


TSege1
Beginner
1,053 Views

Hi,

Can you guide me how to do that?

I searched for solution and didn't find.

 i made all the steps according to https://rocketboards.org/foswiki/Documentation/SoCEDS#Exercise_Sample_Application

 

thanks,

Tamir

 

AnilErinch_A_Intel
1,048 Views

Hi ,

Please check the steps mentioned in the

https://rocketboards.org/foswiki/Documentation/SoCEDS#Run_U_45Boot_SPL_from_Debugger

and let us know the results.

Thanks and Regards

Anil


TSege1
Beginner
1,041 Views

Hi,

It's the same link to rocketboards site that i was send in my previous message.

I tried again to do the same thing, just to show you that the bug is still exist, this is what i got(again):

Screenshot from 2021-05-03 08-16-01.png

The database is still empty.

Thanks,

Tamir

AnilErinch_A_Intel
1,008 Views

Hi ,

The target connection information comes from the configuration database which you are using.

Please explore your system and check whether you are able to see the data base files.

use the below link link as a reference on how to add a data base.

https://developer.arm.com/documentation/dui0446/z/platform-configuration/adding-a-configuration-data...

Thanks and Regards

Anil


EShar1
Beginner
992 Views

Hello Anil,

 

Thank you for your update.

I am the distributor embedded FAE working with Tamir.

I followed up with him the directions of ARM, still he is  failing to see any platform in the "connection" tab

of the "debug configuration" GUI.

 

This is what was done so far:

- We located the configdb directory, it looks complete.

- We verified the the preferences of the DS debugger are pointing to this directory.

- We also repeated the procedure to ARM DS 2021.0

 

Can you advise how to proceed?

 

Best regards,

 

Elhanan

AnilErinch_A_Intel
960 Views

Hi All,

I am checking with the team here whether some one else has faced an issue similar to this.

The Rocket boards examples are well tested as you can see from the screen shots and multiple people use DS5 for debugging Intel SoCs.

Since you are seeing the same issue with two different versions of ARM DS even after following the configuration data base setup instructions , can you also open a case with ARM support

https://www.arm.com/support/contact-support


Thanks and Regards

Anil


TSege1
Beginner
950 Views

Hi Anil,

 

I already opened an issue at Arm.

Anil, can you please try the next steps to check if you also see this issue:

1.host PC running Linux Ubuntu 16.04.

2. Install DS Version 2020.1

3. Open Linux Terminal and type:

     a. /opt/arm/developmentstudio-2020.1/bin/suite_exec -t "Arm Compiler 5" bash 

     b.  armds_ide -data ~/ds.workspace& 

4. Import or create example project

5. Open Debug configuration  and check for devices list

 

Thanks,

Tamir

AnilErinch_A_Intel
789 Views

Hi Team,

Please let us know whether you were able to resolve the issue after the feed back from ARM Support.

Thanks and Regards

Anil


Reply