Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Robson_R_1
Beginner
70 Views

Cordova prepare for emulation failed: Unexpected call to process.exit()

One of my projects it is present the following message when I try to run the emulator

Cordova prepare for emulation failed: Unexpected call to process.exit()

I can press the Dismiss button, but when I do this the event OnDeviceReady is not triggered. I have removed all plugins already and load them back and did not solve.I have reviewed all code and couldn´t find any reason.

In the xdk.log I have the following error lines              (full log attached)

client:emulator:[2016-03-20T01:48:36.940Z]: (1458438516940): appmobi_plus_cordova :: Emulator changing to project pluglock
client:emulator:[2016-03-20T01:48:36.949Z]: (1458438516949): appmobi_plus_cordova :: _xdkLoad for project pluglock
xdk:client:[2016-03-20T01:48:37.801Z]: (1458438517801): memmrk:    50912832    79980416
xdk:server:[2016-03-20T01:48:38.514Z]: (1458438518514): memmrk:    32029928    47481856
server:cordova-lib:[2016-03-20T01:48:39.350Z]: (1458438519350): Error in cordovaPrepare Error: Unexpected call to process.exit()
client:emulator:[2016-03-20T01:48:39.360Z]: (1458438519360): appmobi_plus_cordova :: Cordova prepare for emulation failed: Unexpected call to process.exit()
server:emulator-webserver:[2016-03-20T01:48:39.388Z]: (1458438519388): emulator-webserver: got a request for userapp.
server:emulator-webserver:[2016-03-20T01:48:39.388Z]: (1458438519388): req.path = /http-services/emulator-webserver/ripple/userapp/x/C/Users/Robson/Google%20Drive/Android_Projects/XDKProjects/PlugLock/www/index.html

 

 

 

 

 

Tags (2)
0 Kudos
4 Replies
PaulF_IntelCorp
Employee
70 Views

Try removing and reinstalling the plugins in that project.

0 Kudos
Pamela_H_Intel
Moderator
70 Views

I see that you already tried removing and adding the plugins back in.

Please resend the full build log - it did not get attached properly (0 bytes).

0 Kudos
Robson_R_1
Beginner
70 Views

Paul and Pamela,

In fact I think the remove/add of th eplugins back solved the problem. I have removed all of them, restart XDK, and add them back.

thanks a lot.

 

Robson Reis

0 Kudos
Pamela_H_Intel
Moderator
70 Views

Robson - Excellent! Carry on.

0 Kudos
Reply